AIBRIDGE-MIB
54 objects
No module-level DESCRIPTION found.
Imported Objects
| AIMIB | aii |
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter TimeTicks |
| RFC1213-MIB | mib-2 |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.539.30 | NodeaiDot1dBridge | |||
| 1.3.6.1.4.1.539.30.1 | NodeaiDot1dBase | |||
| 1.3.6.1.4.1.539.30.1.1 | TableaiDot1dBaseInfoTable | not-accessible | mandatory | A table that contains generic information about every instance of STP that is associated with this bridge. Transparent, source-route, and srt ports are include… |
| 1.3.6.1.4.1.539.30.1.1.1 | RowaiDot1dBaseInfoEntry | not-accessible | mandatory | A list of information for each instance of STP of the bridge. |
| 1.3.6.1.4.1.539.30.1.1.1.1 | ColumnaiDot1dBaseInfoSTPIndex | read-only | mandatory | The STP instance number which this entry contains base information. |
| 1.3.6.1.4.1.539.30.1.1.1.2 | ColumnaiDot1dBaseBridgeAddress | read-only | mandatory | The MAC address used by this bridge when it must be referred to in a unique fashion. It is recommended that this be the numerically smallest MAC address of all… |
| 1.3.6.1.4.1.539.30.1.1.1.3 | ColumnaiDot1dBaseNumPorts | read-only | mandatory | The number of ports controlled by this bridging entity. |
| 1.3.6.1.4.1.539.30.1.1.1.4 | ColumnaiDot1dBaseType | read-only | mandatory | Indicates what type of bridging this bridge can perform. If a bridge is actually performing a certain type of bridging this will be indicated by entries in the… |
| 1.3.6.1.4.1.539.30.1.2 | TableaiDot1dBasePortTable | not-accessible | mandatory | A table that contains generic information about every port that is associated with this bridge. Transparent, source-route, and srt ports are included. |
| 1.3.6.1.4.1.539.30.1.2.1 | RowaiDot1dBasePortEntry | not-accessible | mandatory | A list of information for each port of the bridge. |
| 1.3.6.1.4.1.539.30.1.2.1.1 | ColumnaiDot1dBasePortStpIndex | read-only | mandatory | The STP instance number for which this entry contains bridge management information. |
| 1.3.6.1.4.1.539.30.1.2.1.2 | ColumnaiDot1dBasePort | read-only | mandatory | The port number of the port for which this entry contains bridge management information. |
| 1.3.6.1.4.1.539.30.1.2.1.3 | ColumnaiDot1dBasePortIfIndex | read-only | mandatory | The value of the instance of the ifIndex object, defined in MIB-II, for the interface corresponding to this port. |
| 1.3.6.1.4.1.539.30.1.2.1.4 | ColumnaiDot1dBasePortCircuit | read-only | mandatory | For a port which (potentially) has the same value of aiDot1dBasePortIfIndex as another port on the same bridge, this object contains the name of an object inst… |
| 1.3.6.1.4.1.539.30.1.2.1.5 | ColumnaiDot1dBasePortDelayExceededDiscards | read-only | mandatory | The number of frames discarded by this port due to excessive transit delay through the bridge. It is incremented by both transparent and source route bridges. |
| 1.3.6.1.4.1.539.30.1.2.1.6 | ColumnaiDot1dBasePortMtuExceededDiscards | read-only | mandatory | The number of frames discarded by this port due to an excessive size. It is incremented by both transparent and source route bridges. |
| 1.3.6.1.4.1.539.30.2 | NodeaiDot1dStp | |||
| 1.3.6.1.4.1.539.30.2.1 | TableaiDot1dStpInfoTable | not-accessible | mandatory | A table that contains information and configuration items about every instance of STP that is associated with this bridge. |
| 1.3.6.1.4.1.539.30.2.1.1 | RowaiDot1dStpInfoEntry | not-accessible | mandatory | A list of information and configuration items for each instance of STP of the bridge. |
| 1.3.6.1.4.1.539.30.2.1.1.1 | ColumnaiDot1dStpStpIndex | read-only | mandatory | The STP instance number which this entry contains base information. |
| 1.3.6.1.4.1.539.30.2.1.1.2 | ColumnaiDot1dStpProtocolSpecification | read-only | mandatory | An indication of what version of the Spanning Tree Protocol is being run. The value 'decLb100(2)' indicates the DEC LANbridge 100 Spanning Tree protocol. IEEE … |
| 1.3.6.1.4.1.539.30.2.1.1.3 | ColumnaiDot1dStpPriority | read-write | mandatory | The value of the write-able portion of the Bridge ID, i.e., the first two octets of the (8 octet long) Bridge ID. The other (last) 6 octets of the Bridge ID ar… |
| 1.3.6.1.4.1.539.30.2.1.1.4 | ColumnaiDot1dStpTimeSinceTopologyChange | read-only | mandatory | The time (in hundredths of a second) since the last time a topology change was detected by the bridge entity. |
| 1.3.6.1.4.1.539.30.2.1.1.5 | ColumnaiDot1dStpTopChanges | read-only | mandatory | The total number of topology changes detected by this bridge since the management entity was last reset or initialized. |
| 1.3.6.1.4.1.539.30.2.1.1.6 | ColumnaiDot1dStpDesignatedRoot | read-only | mandatory | The bridge identifier of the root of the spanning tree as determined by the Spanning Tree Protocol as executed by this node. This value is used as the Root Ide… |
| 1.3.6.1.4.1.539.30.2.1.1.7 | ColumnaiDot1dStpRootCost | read-only | mandatory | The cost of the path to the root as seen from this bridge. |
| 1.3.6.1.4.1.539.30.2.1.1.8 | ColumnaiDot1dStpRootPort | read-only | mandatory | The port number of the port which offers the lowest cost path from this bridge to the root bridge. |
| 1.3.6.1.4.1.539.30.2.1.1.9 | ColumnaiDot1dStpMaxAge | read-only | mandatory | The maximum age of Spanning Tree Protocol information learned from the network on any port before it is discarded, in units of hundredths of a second. This is … |
| 1.3.6.1.4.1.539.30.2.1.1.10 | ColumnaiDot1dStpHelloTime | read-only | mandatory | The amount of time between the transmission of Configuration bridge PDUs by this node on any port when it is the root of the spanning tree or trying to become … |
| 1.3.6.1.4.1.539.30.2.1.1.11 | ColumnaiDot1dStpHoldTime | read-only | mandatory | This time value determines the interval length during which no more than two Configuration bridge PDUs shall be transmitted by this node, in units of hundredth… |
| 1.3.6.1.4.1.539.30.2.1.1.12 | ColumnaiDot1dStpForwardDelay | read-only | mandatory | This time value, measured in units of hundredths of a second, controls how fast a port changes its spanning state when moving towards the Forwarding state. The… |
| 1.3.6.1.4.1.539.30.2.1.1.13 | ColumnaiDot1dStpBridgeMaxAge | read-write | mandatory | The value that all bridges use for MaxAge when this bridge is acting as the root. Note that 802.1D-1990 specifies that the range for this parameter is related … |
| 1.3.6.1.4.1.539.30.2.1.1.14 | ColumnaiDot1dStpBridgeHelloTime | read-write | mandatory | The value that all bridges use for HelloTime when this bridge is acting as the root. The granularity of this timer is specified by 802.1D- 1990 to be 1 second.… |
| 1.3.6.1.4.1.539.30.2.1.1.15 | ColumnaiDot1dStpBridgeForwardDelay | read-write | mandatory | The value that all bridges use for ForwardDelay when this bridge is acting as the root. Note that 802.1D-1990 specifies that the range for this parameter is re… |
| 1.3.6.1.4.1.539.30.2.1.1.16 | ColumnaiDot1dStpEnabled | read-write | mandatory | This value indicates whether STP is enabled or disabled. |
| 1.3.6.1.4.1.539.30.2.15 | TableaiDot1dStpPortTable | not-accessible | mandatory | A table that contains port-specific information for the Spanning Tree Protocol. |
| 1.3.6.1.4.1.539.30.2.15.1 | RowaiDot1dStpPortEntry | not-accessible | mandatory | A list of information maintained by every port about the Spanning Tree Protocol state for that port. |
| 1.3.6.1.4.1.539.30.2.15.1.1 | ColumnaiDot1dStpPortStpIndex | read-only | mandatory | The STP instance number which this entry contains Spanning Tree Protocol management information. |
| 1.3.6.1.4.1.539.30.2.15.1.2 | ColumnaiDot1dStpPort | read-only | mandatory | The port number of the port for which this entry contains Spanning Tree Protocol management information. |
| 1.3.6.1.4.1.539.30.2.15.1.3 | ColumnaiDot1dStpPortPriority | read-write | mandatory | The value of the priority field which is contained in the first (in network byte order) octet of the (2 octet long) Port ID. The other octet of the Port ID is … |
| 1.3.6.1.4.1.539.30.2.15.1.4 | ColumnaiDot1dStpPortState | read-only | mandatory | The port's current state as defined by application of the Spanning Tree Protocol. This state controls what action a port takes on reception of a frame. If the … |
| 1.3.6.1.4.1.539.30.2.15.1.5 | ColumnaiDot1dStpPortEnable | read-write | mandatory | The enabled/disabled status of the port. |
| 1.3.6.1.4.1.539.30.2.15.1.6 | ColumnaiDot1dStpPortPathCost | read-write | mandatory | The contribution of this port to the path cost of paths towards the spanning tree root which include this port. 802.1D-1990 recommends that the default value o… |
| 1.3.6.1.4.1.539.30.2.15.1.7 | ColumnaiDot1dStpPortDesignatedRoot | read-only | mandatory | The unique Bridge Identifier of the Bridge recorded as the Root in the Configuration BPDUs transmitted by the Designated Bridge for the segment to which the po… |
| 1.3.6.1.4.1.539.30.2.15.1.8 | ColumnaiDot1dStpPortDesignatedCost | read-only | mandatory | The path cost of the Designated Port of the segment connected to this port. This value is compared to the Root Path Cost field in received bridge PDUs. |
| 1.3.6.1.4.1.539.30.2.15.1.9 | ColumnaiDot1dStpPortDesignatedBridge | read-only | mandatory | The Bridge Identifier of the bridge which this port considers to be the Designated Bridge for this port's segment. |
| 1.3.6.1.4.1.539.30.2.15.1.10 | ColumnaiDot1dStpPortDesignatedPort | read-only | mandatory | The Port Identifier of the port on the Designated Bridge for this port's segment. |
| 1.3.6.1.4.1.539.30.2.15.1.11 | ColumnaiDot1dStpPortForwardTransitions | read-only | mandatory | The number of times this port has transitioned from the Learning state to the Forwarding state. |
| 1.3.6.1.4.1.539.30.3 | NodeaiDot1dSr | |||
| 1.3.6.1.4.1.539.30.4 | NodeaiDot1dTp | |||
| 1.3.6.1.4.1.539.30.5 | NodeaiDot1dStatic |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| BridgeId | OCTET STRING (SIZE (8)) | ||
| MacAddress | OCTET STRING (SIZE (6)) | ||
| Timeout | INTEGER |