CABH-IETF-SEC-MIB
78 objects
This MIB module supplies the basic management objects for the Security Portal Services. Copyright (C) The Internet Society (2003). This version of this MIB module is part of RFC xxxx; see the RFC itself for full legal notices.
Imported Objects
| DOCS-BPI2-MIB | --RFC2571 DocsX509ASN1DEREncodedCertificate |
| DOCS-CABLE-DEVICE-MIB | docsDevFilterIpEntry |
| INET-ADDRESS-MIB | -- RFC2580 InetPortNumber InetAddress InetAddressType |
| RMON2-MIB | txt or after ZeroBasedCounter32 |
| SNMP-FRAMEWORK-MIB | --RFC3291 SnmpAdminString |
| SNMPv2-CONF | -- RFC2579 OBJECT-GROUP MODULE-COMPLIANCE |
| SNMPv2-SMI | mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 zeroDotZero |
| SNMPv2-TC | -- RFC2578 DateAndTime TimeStamp TruthValue VariablePointer |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1 | IdentitycabhSecMib | This MIB module supplies the basic management objects for the Security Portal Services. Copyright (C) The Internet Society (2003). This version of this MIB mod… | ||
| 1.3.6.1.2.1.1 | NodecabhSecMibObjects | |||
| 1.3.6.1.2.1.1.1 | NodecabhSecFwObjects | |||
| 1.3.6.1.2.1.1.1.1 | NodecabhSecFwBase | |||
| 1.3.6.1.2.1.1.1.1.1 | ScalarcabhSecFwPolicyFileEnable | read-write | current | This parameter indicates whether or not to enable the firewall functionality. |
| 1.3.6.1.2.1.1.1.1.2 | ScalarcabhSecFwPolicyFileURL | read-write | current | Contains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. A policy rule set file download is trigge… |
| 1.3.6.1.2.1.1.1.1.3 | ScalarcabhSecFwPolicyFileHash | read-write | current | Hash of the contents of the rules set file, calculated and sent to the PS prior to sending the rules set file. For the SHA-1 authentication algorithm the lengt… |
| 1.3.6.1.2.1.1.1.1.4 | ScalarcabhSecFwPolicyFileOperStatus | read-only | current | inProgress(1) indicates a firewall configuration file download is underway. complete (2) indicates the firewall configuration file downloaded and configured su… |
| 1.3.6.1.2.1.1.1.1.5 | ScalarcabhSecFwPolicyFileCurrentVersion | read-only | current | The rule set version currently operating in the PS device. This object should be in the syntax used by the individual vendor to identify software versions. Any… |
| 1.3.6.1.2.1.1.1.1.6 | ScalarcabhSecFwPolicySuccessfulFileURL | read-only | current | Contains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. If a successful download has not yet occu… |
| 1.3.6.1.2.1.1.1.2 | NodecabhSecFwLogCtl | |||
| 1.3.6.1.2.1.1.1.2.1 | ScalarcabhSecFwEventType1Enable | read-write | current | This object enables or disables logging of type 1 firewall event messages. Type 1 event messages report attempts from both private and public clients to traver… |
| 1.3.6.1.2.1.1.1.2.2 | ScalarcabhSecFwEventType2Enable | read-write | current | This object enables or disables logging of type 2 firewall event messages. Type 2 event messages report identified Denial of Service attack attempts. |
| 1.3.6.1.2.1.1.1.2.3 | ScalarcabhSecFwEventType3Enable | read-write | current | Enables or disables logging of type 3 firewall event messages. Type 3 event messages report changes made to the following firewall management parameters: cabhS… |
| 1.3.6.1.2.1.1.1.2.4 | ScalarcabhSecFwEventAttackAlertThreshold | read-write | current | If the number of type 1 or 2 hacker attacks exceeds this threshold in the period define by cabhSecFwEventAttackAlertPeriod, a firewall message event MUST be lo… |
| 1.3.6.1.2.1.1.1.2.5 | ScalarcabhSecFwEventAttackAlertPeriod | read-write | current | Indicates the period to be used (in hours) for the cabhSecFwEventAttackAlertThreshold. This MIB variable should always keep track of the last x hours of events… |
| 1.3.6.1.2.1.1.2 | NodecabhSecCertObjects | |||
| 1.3.6.1.2.1.1.2.1 | ScalarcabhSecCertPsCert | read-only | current | The X509 DER-encoded PS certificate. |
| 1.3.6.1.2.1.1.3 | NodecabhSecKerbObjects | |||
| 1.3.6.1.2.1.1.3.1 | NodecabhSecKerbBase | |||
| 1.3.6.1.2.1.1.3.1.1 | ScalarcabhSecKerbPKINITGracePeriod | read-write | current | The PKINIT Grace Period is needed by the PS to know when it should start retrying to get a new ticket. The PS MUST obtain a new Kerberos ticket (with a PKINIT … |
| 1.3.6.1.2.1.1.3.1.2 | ScalarcabhSecKerbTGSGracePeriod | read-write | current | The TGS Grace Period is needed by the PS to know when it should start retrying to get a new ticket. The PS MUST obtain a new Kerberos ticket (with a TGS Reques… |
| 1.3.6.1.2.1.1.3.1.3 | ScalarcabhSecKerbUnsolicitedKeyMaxTimeout | read-write | current | This timeout applies to PS initiated AP-REQ/REP key management exchange with NMS. The maximum timeout is the value which may not be exceeded in the exponential… |
| 1.3.6.1.2.1.1.3.1.4 | ScalarcabhSecKerbUnsolicitedKeyMaxRetries | read-write | current | The number of retries the PS is allowed for AP-REQ/REP key management exchange initiation with the NMS. This is the maximum number of retries before the PS giv… |
| 1.3.6.1.2.1.1.4 | NodecabhSec2FwObjects | |||
| 1.3.6.1.2.1.1.4.1 | NodecabhSec2FwBase | |||
| 1.3.6.1.2.1.1.4.1.1 | ScalarcabhSec2FwEnable | read-write | current | This parameter indicates whether to enable or disable the firewall. |
| 1.3.6.1.2.1.1.4.1.2 | ScalarcabhSec2FwPolicyFileURL | read-write | current | Contains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. A policy rule set file download is trigge… |
| 1.3.6.1.2.1.1.4.1.3 | ScalarcabhSec2FwPolicyFileHash | read-write | current | Hash of the contents of the firewall configuration file. For the SHA-1 authentication algorithm the length of the hash is 160 bits. This hash value is encoded … |
| 1.3.6.1.2.1.1.4.1.4 | ScalarcabhSec2FwPolicyFileOperStatus | read-only | current | InProgress(1) indicates a firewall configuration file download is underway. Complete(2) indicates the firewall configuration file was downloaded and processed … |
| 1.3.6.1.2.1.1.4.1.5 | ScalarcabhSec2FwPolicyFileCurrentVersion | read-write | current | A label set by the cable operator that can be used to track various versions of configured rulesets. Once the label is set it and configured rules are changed,… |
| 1.3.6.1.2.1.1.4.1.6 | ScalarcabhSec2FwClearPreviousRuleset | read-write | current | Allows PS or firewall configuration files to contain either a complete firewall configured ruleset or an incremental to the already established configured rule… |
| 1.3.6.1.2.1.1.4.1.7 | ScalarcabhSec2FwPolicySelection | read-write | current | This parameter indicates which policy should currently be running in the firewall, either the factoryDefault policy or the configuredRuleset. |
| 1.3.6.1.2.1.1.4.1.8 | ScalarcabhSec2FwEventSetToFactory | read-write | current | If set to 'true', entries in cabhSec2FwEventControlEntry are set to their default values. Reading this value always returns false. |
| 1.3.6.1.2.1.1.4.1.9 | ScalarcabhSec2FwEventLastSetToFactory | read-only | current | The value of sysUpTime when cabhSec2FwEventSetToFactory was last set to true. Zero if never reset. |
| 1.3.6.1.2.1.1.4.1.10 | ScalarcabhSec2FwPolicySuccessfulFileURL | read-only | current | Contains the location of the last successfull downloaded policy rule set file in the format pointed in the reference. If a successful download has not yet occu… |
| 1.3.6.1.2.1.1.4.2 | NodecabhSec2FwEvent | |||
| 1.3.6.1.2.1.1.4.2.1 | TablecabhSec2FwEventControlTable | not-accessible | current | This table controls the reporting of the Firewall Attacks events |
| 1.3.6.1.2.1.1.4.2.1.1 | RowcabhSec2FwEventControlEntry | not-accessible | current | Allows configuration of the reporting mechanisms for a particular type of attack. |
| 1.3.6.1.2.1.1.4.2.1.1.1 | ColumncabhSec2FwEventType | not-accessible | current | Classification of the different types of attacks. Type 1 logs all attempts from both LAN and WAN clients to traverse the Firewall that violate the Security Pol… |
| 1.3.6.1.2.1.1.4.2.1.1.2 | ColumncabhSec2FwEventEnable | read-write | current | Enables or disables counting and logging of firewall events by type as assigned by cabhSec2FwEventType. |
| 1.3.6.1.2.1.1.4.2.1.1.3 | ColumncabhSec2FwEventThreshold | read-write | current | Number of attacks to count before sending the appropriate event by type as assigned by cabhSec2FwEventType. |
| 1.3.6.1.2.1.1.4.2.1.1.4 | ColumncabhSec2FwEventInterval | read-write | current | Indicates the time interval in hours to count and log occurrences of a firewall event type as assigned in cabhSec2FwEventType. If this MIB has a value of zero … |
| 1.3.6.1.2.1.1.4.2.1.1.5 | ColumncabhSec2FwEventCount | read-only | current | Indicates the current count up to the cabhSec2FwEventThreshold value by type as assigned by cabhSec2FwEventType. |
| 1.3.6.1.2.1.1.4.2.1.1.6 | ColumncabhSec2FwEventLogReset | read-write | current | Setting this object to true clears the log table for the specified event type. Reading this object always returns false. |
| 1.3.6.1.2.1.1.4.2.1.1.7 | ColumncabhSec2FwEventLogLastReset | read-only | current | The value of sysUpTime when cabhSec2FwEventLogReset was last set to true. Zero if never reset. |
| 1.3.6.1.2.1.1.4.3 | NodecabhSec2FwLog | |||
| 1.3.6.1.2.1.1.4.3.1 | TablecabhSec2FwLogTable | not-accessible | current | Contains a log of packet information as related to events enabled by the cable operator. The types are defined in the CableHome 1.1 specification and require v… |
| 1.3.6.1.2.1.1.4.3.1.1 | RowcabhSec2FwLogEntry | not-accessible | current | Each entry contains the log of firewall events |
| 1.3.6.1.2.1.1.4.3.1.1.1 | ColumncabhSec2FwLogIndex | not-accessible | current | A sequence number for the specific events under a cabhSec2FwEventType. |
| 1.3.6.1.2.1.1.4.3.1.1.2 | ColumncabhSec2FwLogEventType | read-only | current | Classification of the different types of attacks. Type 1 logs all attempts from both LAN and WAN clients to traverse the Firewall that violate the Security Pol… |
| 1.3.6.1.2.1.1.4.3.1.1.3 | ColumncabhSec2FwLogEventPriority | read-only | current | The priority level of this event as defined by CableHome Specification. If a priority is not assigned in the CableHome specification for a particular event the… |
| 1.3.6.1.2.1.1.4.3.1.1.4 | ColumncabhSec2FwLogEventId | read-only | current | The assigned event ID. |
| 1.3.6.1.2.1.1.4.3.1.1.5 | ColumncabhSec2FwLogTime | read-only | current | The time that this entry was created by the PS. |
| 1.3.6.1.2.1.1.4.3.1.1.6 | ColumncabhSec2FwLogIpProtocol | read-only | current | The IP Protocol |
| 1.3.6.1.2.1.1.4.3.1.1.7 | ColumncabhSec2FwLogIpAddrType | read-only | current | The type of IP addresses in the packet |
| 1.3.6.1.2.1.1.4.3.1.1.8 | ColumncabhSec2FwLogIpSourceAddr | read-only | current | The Source IP Address of the packet logged. The address type of this object is specified by cabhSec2FwLogIpAddrType. |
| 1.3.6.1.2.1.1.4.3.1.1.9 | ColumncabhSec2FwLogIpDestAddr | read-only | current | The Destination IP Address of the packet logged. The address type of this object is specified by cabhSec2FwLogIpAddrType. |
| 1.3.6.1.2.1.1.4.3.1.1.10 | ColumncabhSec2FwLogIpSourcePort | read-only | current | The Source IP Port of the packet logged |
| 1.3.6.1.2.1.1.4.3.1.1.11 | ColumncabhSec2FwLogIpDestPort | read-only | current | The Source IP Port of the packet logged |
| 1.3.6.1.2.1.1.4.3.1.1.12 | ColumncabhSec2FwLogMessageType | read-only | current | The ICMP defined types. |
| 1.3.6.1.2.1.1.4.3.1.1.13 | ColumncabhSec2FwLogReplayCount | read-only | current | The number of identical attack packets that were seen by the firewall based on cabhSec2FwLogIpProtocol, cabhSec2FwLogIpSourceAddr, cabhSec2FwLogIpDestAddr, cab… |
| 1.3.6.1.2.1.1.4.3.1.1.14 | ColumncabhSec2FwLogMIBPointer | read-only | current | Identifies if the cabhSec2FwPolicyFileURL or the cabhSec2FwEnable MIB object changed or an attempt was made to change it. |
| 1.3.6.1.2.1.1.4.4 | NodecabhSec2FwFilter | |||
| 1.3.6.1.2.1.1.4.4.1 | TablecabhSec2FwFilterScheduleTable | not-accessible | current | Extends the filtering matching parameters of docsDevFilterIpTable defined in RFC 2669 for CableHome Residential Gateways to include time day intervals and days… |
| 1.3.6.1.2.1.1.4.4.1.1 | RowcabhSec2FwFilterScheduleEntry | not-accessible | current | Extended values for entries of docsDevFilterIpTable. If the PS has not acquired ToD the entire docsDevFilterIpEntry rule set is ignored. |
| 1.3.6.1.2.1.1.4.4.1.1.1 | ColumncabhSec2FwFilterScheduleStartTime | read-create | current | The start time, with optional time zone, for a firewall filter ruleset. Only the time portion of the DateAndTime TEXTUAL-CONVENTION have a meaning. |
| 1.3.6.1.2.1.1.4.4.1.1.2 | ColumncabhSec2FwFilterScheduleEndTime | read-create | current | The end time, with optional time zone, for a firewall filter ruleset. Only the time portion of the DateAndTime TEXTUAL-CONVENTION have a meaning. |
| 1.3.6.1.2.1.1.4.4.1.1.3 | ColumncabhSec2FwFilterScheduleDOW | read-create | current | If the day of week bit associated with the PS given day is '1', this object criteria matches. |
| 1.3.6.1.2.1.2 | NodecabhSecNotification | |||
| 1.3.6.1.2.1.3 | NodecabhSecConformance | |||
| 1.3.6.1.2.1.3.1 | NodecabhSecCompliances | |||
| 1.3.6.1.2.1.3.1.1 | CompliancecabhSecCompliance | current | The compliance statement for CableHome Security. | |
| 1.3.6.1.2.1.3.2 | NodecabhSecGroups | |||
| 1.3.6.1.2.1.3.2.1 | GroupcabhSecGroup | current | Group of objects in CableHome 1.0 Firewall MIB. | |
| 1.3.6.1.2.1.3.2.2 | GroupcabhSecCertGroup | current | Group of objects in CableHome gateway for PS Certificate. | |
| 1.3.6.1.2.1.3.2.3 | GroupcabhSecKerbGroup | current | Group of objects in CableHome gateway for Kerberos. | |
| 1.3.6.1.2.1.3.2.4 | GroupcabhSec2Group | current | Group of objects in CableHome 1.1 Firewall MIB. |