MIB Viewer

CHECK-MIB

47 objects
This MIB module defines a set of objects that allow to define a health check procedure on a managed node. The health check procedure is performed through a sequence of simple comparison operations on some managed objects against a control value. The result of the health check is accumulated into a single managed object that can be read by a manager to discover the status of the whole set of managed objects instead of retrieving all the single values controlled during the health check procedure. The main purpose of the CHECK-MIB is increasing scalability of network management applications by moving check operations from the management station to managed nodes. There are five groups of managed objects defined by this MIB module: - objects describing capabilities of the CHECK-MIB implementation; - objects controlling the operational status of the health check procedure; - objects defining the checks in the checkResultTable; - objects defining the operations for each of the configured checks in the checkRuleTable; - objects providing information about failed checks.
Imported Objects
SNMP-FRAMEWORK-MIB-- RFC2580 SnmpAdminString
SNMPv2-CONF-- RFC2579 MODULE-COMPLIANCE OBJECT-GROUP
SNMPv2-SMImib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE TimeTicks Unsigned32 zeroDotZero
SNMPv2-TC-- RFC2578 StorageType RowStatus TEXTUAL-CONVENTION TimeInterval TimeStamp
OIDNameAccessStatusDescription
1.3.6.1.2.1.7777IdentitycheckMIBThis MIB module defines a set of objects that allow to define a health check procedure on a managed node. The health check procedure is performed through a seq…
1.3.6.1.2.1.7777.1NodecheckObjects
1.3.6.1.2.1.7777.1.1NodecheckCapabilities
1.3.6.1.2.1.7777.1.1.1ScalarcheckCapabMinCheckIntervalread-onlycurrentThe minimum interval that can be scheduled between two performances of the same check defined in the checkResultTable using the object checkResultInterval. Thi…
1.3.6.1.2.1.7777.1.1.2ScalarcheckCapabMaxResultsread-onlycurrentThe maximum number of entries supported in the checkResultTable. A value of 0 indicates that there is no fixed limitation. Creating a new row in the checkResul…
1.3.6.1.2.1.7777.1.1.3ScalarcheckCapabMaxRulesread-onlycurrentThe maximum number of entries supported in the checkRuleTable. A value of 0 indicates that there is no fixed limitation. Creating a new row in the checkRuleTab…
1.3.6.1.2.1.7777.1.2NodecheckControl
1.3.6.1.2.1.7777.1.2.1ScalarcheckCtrlAdminStatusread-writecurrentThe desidered state of the checking engine of the Check MIB implementation. Setting this object to up(1) indicates a request for performing all checks as defin…
1.3.6.1.2.1.7777.1.2.2ScalarcheckCtrlOperStatusread-onlycurrentThe current operational state of the Check MIB implementation. The up(1) state indicates that all checks defined in the checkResultTable and the checkRuleTable…
1.3.6.1.2.1.7777.1.3TablecheckResultTablenot-accessiblecurrentThis table contains the definitions of the checks to be performed by the Check MIB implementation. Each row defines one check and contains the parameters contr…
1.3.6.1.2.1.7777.1.3.1RowcheckResultEntrynot-accessiblecurrentAn entry defining a check. Each entry is indexed by the string checkResultName, which represents the name of the check. An entry can be created with the object…
1.3.6.1.2.1.7777.1.3.1.1ColumncheckResultNamenot-accessiblecurrentA name describing the check. Since the name serves as table index, it must be unique for each row in the table. The name of a check is chosen arbitrary by the …
1.3.6.1.2.1.7777.1.3.1.2ColumncheckResultSeverityread-onlycurrentEach time the check defined by this entry (and the corresponding entries of the checkRuleTable) is performed, this object is set to to the maximum value of all…
1.3.6.1.2.1.7777.1.3.1.3ColumncheckResultSizeread-onlycurrentThe number of rules defined in corresponding entries of the checkFailureTable for which the check failed when it was performed last. If no check has been perfo…
1.3.6.1.2.1.7777.1.3.1.4ColumncheckResultTimeread-onlycurrentA timestamp indicating the time when the last performance of the check defined in this row was completed. If no check has been performed so far, then the value…
1.3.6.1.2.1.7777.1.3.1.5ColumncheckResultIntervalread-createcurrentThe interval between two performances of the check defined in this row. When this object is set to a value greater than 0, then the check is performed regularl…
1.3.6.1.2.1.7777.1.3.1.6ColumncheckResultSeverityThresholdread-onlycurrentThis object serves for sending notifications in case of failures occurred in the check defined in this row. If the value of this object is set to 0, then no no…
1.3.6.1.2.1.7777.1.3.1.7ColumncheckResultStorageTyperead-createcurrentThe value of this object indicates the storage type of this entry in the checkResultTable and of all corresponding entries in the checkRuleTable. The value of …
1.3.6.1.2.1.7777.1.3.1.8ColumncheckResultRowStatusread-createcurrentThis object allows to create and delete rows in the table. The value createAndGo(4) is not allowed and an wrongValue error is returned when attempting to set i…
1.3.6.1.2.1.7777.1.4TablecheckRuleTablenot-accessiblecurrentThis table contains the definitions of the operations performed for checks defined in the checkResultTable. Each row defines an operation on the value of a man…
1.3.6.1.2.1.7777.1.4.1RowcheckRuleEntrynot-accessiblecurrentAn entry defining a rule for a check defined in the checkResultTable. Each entry is indexed by: 1. the checkResultName of the check which includes the operatio…
1.3.6.1.2.1.7777.1.4.1.2ColumncheckRuleNamenot-accessiblecurrentA name describing the rule. Since the name serves as table index coupled with the value of checkResultName, it must be unique per each row in the table inside …
1.3.6.1.2.1.7777.1.4.1.3ColumncheckRuleOidread-createcurrentThe OID indicating the managed object to be checked. The OID must be: - the OID of an instance object: in this case the rule is applied to that object; - the O…
1.3.6.1.2.1.7777.1.4.1.4ColumncheckRuleValueread-createcurrentThe control value compared to the value of the managed object indicated by checkRuleOid. The control value encoded in this object must be consistent with the t…
1.3.6.1.2.1.7777.1.4.1.5ColumncheckRuleOperationread-writecurrentThe value of this object specifies the comparison operation to be performed between the value of the managed object indicated by checkRuleOid and the value ind…
1.3.6.1.2.1.7777.1.4.1.6ColumncheckRuleSeverityread-createcurrentThe severity of a failure of the operation specified by the row for the whole check. A severity of 0 indicates that a failure of the operation is irrelevant.
1.3.6.1.2.1.7777.1.4.1.7ColumncheckRuleRowStatusread-createcurrentThe control to create and delete rows. It is possible to create new rules only for a check which is already defined in the CHECK-MIB. Creating a new row indexe…
1.3.6.1.2.1.7777.1.5TablecheckFailureTablenot-accessiblecurrentThis table lists all the rules defined in the checkRuleTable, which failed at the last time the check including them has been performed. Entries only describe …
1.3.6.1.2.1.7777.1.5.1RowcheckFailureEntrynot-accessiblecurrentAn entry referencing a failed rule. Each entry is indexed by: 1. the checkResultName of the check including the rule failed; 2. the severity of the rule failed…
1.3.6.1.2.1.7777.1.5.1.1ColumncheckFailureSeveritynot-accessiblecurrentThe severity with which the rule failed.
1.3.6.1.2.1.7777.1.5.1.2ColumncheckFailureOidread-onlycurrentThe OID of the managed object for which a rule failed. This value contains the value of checkRuleOid of the rule failed.
1.3.6.1.2.1.7777.2NodecheckNotifications
1.3.6.1.2.1.7777.2.0NodecheckEvent
1.3.6.1.2.1.7777.2.0.1NotificationcheckFailedcurrentThis notification can be generated to report that a check failed. The notification is generated each time, the value of checkSeverityThreshold is greater than …
1.3.6.1.2.1.7777.3NodecheckConformance
1.3.6.1.2.1.7777.3.1NodecheckCompliances
1.3.6.1.2.1.7777.3.1.1CompliancecheckCompliancecurrentThe compliance statement for SNMP entities that implement the CHECK-MIB.
1.3.6.1.2.1.7777.3.2NodecheckGroups
1.3.6.1.2.1.7777.3.2.1GroupcheckCapabilitiesGroupcurrentA collection of objects providing information about the capabilities of the CHECK-MIB implementation.
1.3.6.1.2.1.7777.3.2.2GroupcheckControlGroupcurrentA collection of objects controlling the state of the CHECK-MIB.
1.3.6.1.2.1.7777.3.2.3GroupcheckResultGroupcurrentA collection of objects defining a check.
1.3.6.1.2.1.7777.3.2.4GroupcheckRuleGroupcurrentA collection of objects defining the operations computed for each check.
1.3.6.1.2.1.7777.3.2.5GroupcheckFailureGroupcurrentA collection of objects indicating managed objects for which a check operation failed.
1.3.6.1.2.1.7777.3.2.6GroupcheckNotificationsGroupcurrentThe notifications emitted by the CHECK-MIB.
Type Definitions
NameSyntaxStatusDescription
RuleValueOCTET STRINGcurrentThe control value compared with the value of a monitored object. This value encodes all the object types defined by the SMIv2, except the Opaque, with the following rules: - INTEGER, Integer32, Unsigned32, TimeTicks, Co…
SeverityConfiguredUnsigned32 (0..4294967293)currentThe severity value measures the gravity of a failure of a rule or a result. A low value indicates a minor failure, while a high value indicates a sever failure. The scale of the severity is arbitrary chosen by the manag…
SeverityReturnedUnsigned32currentThe severity value measures the gravity of a failure of a rule or a result. A low value indicates a minor failure, while a high value indicates a sever failure. The scale of the severity is arbitrary chosen by the manag…