MIB Viewer

DOCS-BPI2EXT-MIB

26 objects
This MIB module adds to the BPI management objects that are defined in the DOCS-IETF-BPI2-MIB (RFC 4131). These objects are in addition to and the DOCS-IETF-BPI2-MIB (RFC 4131). These objects are in addition to and separate from RFC 4131 and provide management support for new DOCSIS 3.1 features. The following MIBs from RFC 4131 are used to support legacy PKI CM certificate functions defined in the DOCSIS 3.0 security specification: docsBpi2CmDeviceCertTable, docsBpi2CodeMfgOrgName, docsBpi2CodeMfgCodeAccessStart, docsBpi2CodeMfgCvcAccessStart, docsBpi2CodeCoSignerOrgName, docsBpi2CodeCoSignerCodeAccessStart, docsBpi2CodeCoSignerCvcAccessStart, docsBpi2CodeCvcUpdate. The following MIBs defined in this MIB module are used to support new PKI CM certificate functions defined in the DOCSIS 3.1 security specification: docsBpi2Ext31CmDeviceCmCert, docsBpi2Ext31CodeUpdateCvcChain, docsBpi2Ext31CodeMfgOrgName, docsBpi2Ext31CodeMfgCodeAccessStart, docsBpi2Ext31CodeMfgCvcAccessStart, docsBpi2Ext31CodeCoSignerOrgName, docsBpi2Ext31CodeCoSignerCodeAccessStart, docsBpi2Ext31CodeCoSignerCvcAccessStart. Copyright 2015-2016 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
CLAB-DEF-MIBclabProjDocsis
DOCS-IETF-BPI2-MIBDocsX509ASN1DEREncodedCertificate
DOCS-RPHY-MIB-- RFC 2863 -- Removed by INTEL for CM MIB compilation -- docsRphyRpdInfoUniqueId --
IF-MIB-- RFC 3411 ifIndex
SNMP-FRAMEWORK-MIB-- RFC 2580 SnmpAdminString
SNMPv2-CONF-- RFC 2579 OBJECT-GROUP MODULE-COMPLIANCE
SNMPv2-SMIMODULE-IDENTITY OBJECT-TYPE
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION DateAndTime
OIDNameAccessStatusDescription
1.3.6.1.4.1.4491.2.1.29IdentitydocsBpi2Ext31MibThis MIB module adds to the BPI management objects that are defined in the DOCS-IETF-BPI2-MIB (RFC 4131). These objects are in addition to and the DOCS-IETF-BP…
1.3.6.1.4.1.4491.2.1.29.0NodedocsBpi2Ext31Notifications
1.3.6.1.4.1.4491.2.1.29.1NodedocsBpi2Ext31MibObjects
1.3.6.1.4.1.4491.2.1.29.1.1NodedocsBpi2Ext31CmObjects
1.3.6.1.4.1.4491.2.1.29.1.1.1NodedocsBpi2Ext31CmCertObjects
1.3.6.1.4.1.4491.2.1.29.1.1.1.1TabledocsBpi2Ext31CmDeviceCertTablenot-accessiblecurrentThis table describes the Baseline Privacy Plus device certificates issued from the new PKI defined in DOCSIS 3.1 for each CM MAC interface.
1.3.6.1.4.1.4491.2.1.29.1.1.1.1.1RowdocsBpi2Ext31CmDeviceCertEntrynot-accessiblecurrentEach entry contains the device certificates of one CM MAC interface. An entry in this table exists for each ifEntry with an ifType of docsCableMaclayer(127).
1.3.6.1.4.1.4491.2.1.29.1.1.1.1.1.1ColumndocsBpi2Ext31CmDeviceCmCertread-writecurrentThe X509 DER-encoded cable modem certificate. Note: This object can be set only when the value is the zero-length OCTET STRING; otherwise, an error of 'inconsi…
1.3.6.1.4.1.4491.2.1.29.1.1.1.1.1.2ColumndocsBpi2Ext31CmDeviceManufCertread-onlycurrentThe X509 DER-encoded manufacturer certificate that signed the cable modem certificate.
1.3.6.1.4.1.4491.2.1.29.1.2NodedocsBpi2Ext31CodeDownloadControl
1.3.6.1.4.1.4491.2.1.29.1.2.1ScalardocsBpi2Ext31CodeUpdateCvcChainread-writecurrentThe value of this object is a degenerate PKCS7 signedData structure that contains the CVC and the CVC CA certificate chain in the certificates field. Setting t…
1.3.6.1.4.1.4491.2.1.29.1.2.2ScalardocsBpi2Ext31CodeMfgOrgNameread-onlycurrentThe value of this object is the device manufacturer's organizationName used to validate the code verification certificate issued from the new PKI defined in DO…
1.3.6.1.4.1.4491.2.1.29.1.2.3ScalardocsBpi2Ext31CodeMfgCodeAccessStartread-onlycurrentThe value of this object is the device manufacturer's current codeAccessStart value used with the new PKI defined in DOCSIS 3.1. This value will always refer t…
1.3.6.1.4.1.4491.2.1.29.1.2.4ScalardocsBpi2Ext31CodeMfgCvcAccessStartread-onlycurrentThe value of this object is the device manufacturer's current cvcAccessStart value used with the new PKI defined in DOCSIS 3.1. This value will always refer to…
1.3.6.1.4.1.4491.2.1.29.1.2.5ScalardocsBpi2Ext31CodeCoSignerOrgNameread-onlycurrentThe value of this object is the co-signer's organizationName used to validate the code verification certificate issued from the new PKI defined in DOCSIS 3.1. …
1.3.6.1.4.1.4491.2.1.29.1.2.6ScalardocsBpi2Ext31CodeCoSignerCodeAccessStartread-onlycurrentThe value of this object is the co-signer's current codeAccessStart value used with the new PKI defined in DOCSIS 3.1. This value will always refer to Greenwic…
1.3.6.1.4.1.4491.2.1.29.1.2.7ScalardocsBpi2Ext31CodeCoSignerCvcAccessStartread-onlycurrentThe value of this object is the co-signer's current cvcAccessStart value used with the new PKI defined in DOCSIS 3.1. This value will always refer to Greenwich…
1.3.6.1.4.1.4491.2.1.29.1.3NodedocsBpi2Ext31CcapRpdObjects
1.3.6.1.4.1.4491.2.1.29.1.3.1NodedocsBpi2Ext31CcapRpdCertObjects
1.3.6.1.4.1.4491.2.1.29.2NodedocsBpi2Ext31Conformance
1.3.6.1.4.1.4491.2.1.29.2.1NodedocsBpi2Ext31Compliances
1.3.6.1.4.1.4491.2.1.29.2.1.1CompliancedocsBpi2Ext31MIBCompliancecurrentThe compliance statement for implementations of the DOC-BPI2EXT-MIB.
1.3.6.1.4.1.4491.2.1.29.2.2NodedocsBpi2Ext31Groups
1.3.6.1.4.1.4491.2.1.29.2.2.1GroupdocsBpi2Ext31CmGroupcurrentThe group of objects implemented by the CM.
1.3.6.1.4.1.4491.2.1.29.2.2.2GroupdocsBpi2Ext31BaseGroupcurrentThe group of objects implemented by the CM and open to implementation by other devices.
Type Definitions
NameSyntaxStatusDescription
DocsCvcCaCertificateChainOCTET STRING (SIZE (0..8192))currentA degenerate PKCS7 signedData structure that contains the CVC and the CVC CA certificate chain in the certificates field.