DOCS-FDX-MIB
29 objects
This MIB module contains the management objects for the management of DOCSIS 4.0 Full-Duplex capabilities. Copyright 2019-2023 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
| CLAB-DEF-MIB | -- RFC 2580 clabProjDocsis |
| DOCS-IF3-MIB | docsIf3CmtsCmRegStatusEntry docsIf3CmtsCmRegStatusId |
| DOCS-IF31-MIB | docsIf31CmtsCmDsOfdmChannelStatusEntry docsIf31CmtsCmUsOfdmaChannelStatusEntry docsIf31CmtsDsOfdmChanEntry docsIf31CmtsUsOfdmaChanEntry |
| SNMPv2-CONF | -- RFC 2579 OBJECT-GROUP MODULE-COMPLIANCE |
| SNMPv2-SMI | MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | -- RFC 2578 TEXTUAL-CONVENTION TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.4491.2.1.35 | IdentitydocsFdxMib | This MIB module contains the management objects for the management of DOCSIS 4.0 Full-Duplex capabilities. Copyright 2019-2023 Cable Television Laboratories, I… | ||
| 1.3.6.1.4.1.4491.2.1.35.0 | NodedocsFdxNotifications | |||
| 1.3.6.1.4.1.4491.2.1.35.1 | NodedocsFdxMibObjects | |||
| 1.3.6.1.4.1.4491.2.1.35.2 | NodedocsFdxCcapMibObjects | |||
| 1.3.6.1.4.1.4491.2.1.35.2.1 | TabledocsFdxCmtsCmRegStatusTable | not-accessible | current | This table extends the table in the IF3 MIB that defines attributes that represent the CM's registration status as tracked by the CMTS. In particular. this tab… |
| 1.3.6.1.4.1.4491.2.1.35.2.1.1 | RowdocsFdxCmtsCmRegStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsCmRegStatusTable. |
| 1.3.6.1.4.1.4491.2.1.35.2.1.1.1 | ColumndocsFdxCmtsCmRegStatusFdxCapability | read-only | current | This attribute indicates the FDX capability of this CM. |
| 1.3.6.1.4.1.4491.2.1.35.2.2 | TabledocsFdxCmtsCmUsOfdmaChannelStatusTable | not-accessible | current | This table defines current status information of the CM on each OFDMA upstream channel, as reported by the CMTS. In particular, the Full-Duplex capabilities. |
| 1.3.6.1.4.1.4491.2.1.35.2.2.1 | RowdocsFdxCmtsCmUsOfdmaChannelStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsCmUsOfdmaChannelStatusTable. A separate entry exists for every OFDMA channel of every CM currently assigned to an OFDMA channe… |
| 1.3.6.1.4.1.4491.2.1.35.2.2.1.1 | ColumndocsFdxCmtsCmUsOfdmaChannelStatusFdxEnabled | read-only | current | This attribute has a value of 'true' to indicate that the CM's upstream channel is contained within an FDX subband. |
| 1.3.6.1.4.1.4491.2.1.35.2.3 | TabledocsFdxCmtsCmDsOfdmChannelStatusTable | not-accessible | current | This object defines current status information of the CM on each OFDM downstream channel, as reported by the CMTS. A separate entry exists for every OFDM chann… |
| 1.3.6.1.4.1.4491.2.1.35.2.3.1 | RowdocsFdxCmtsCmDsOfdmChannelStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsCmDsOfdmChannelStatusTable. |
| 1.3.6.1.4.1.4491.2.1.35.2.3.1.1 | ColumndocsFdxCmtsCmDsOfdmChannelStatusFdxEnabled | read-only | current | This attribute has a value of 'true' to indicate that the CM's downstream channel is contained within an FDX subband. |
| 1.3.6.1.4.1.4491.2.1.35.2.4 | TabledocsFdxCmtsCmFdxStatusTable | not-accessible | current | This table defines status information of an FDX-capable CM (either FDX-L or FDX), as reported by the CMTS. An entry is created in this table when a CM register… |
| 1.3.6.1.4.1.4491.2.1.35.2.4.1 | RowdocsFdxCmtsCmFdxStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsCmFdxStatusTable. |
| 1.3.6.1.4.1.4491.2.1.35.2.4.1.1 | ColumndocsFdxCmtsCmFdxStatusFdxStatus | read-only | current | This attribute reports the status of the FDX-capable CM. |
| 1.3.6.1.4.1.4491.2.1.35.2.5 | TabledocsFdxCmtsUsOfdmaChannelStatusTable | not-accessible | current | This table provides channel-level visibility into Upstream OFDMA channel configuration and status, in particular, the Full-Duplex capabilities. |
| 1.3.6.1.4.1.4491.2.1.35.2.5.1 | RowdocsFdxCmtsUsOfdmaChannelStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsUsOfdmaChannelStatusTable. |
| 1.3.6.1.4.1.4491.2.1.35.2.5.1.1 | ColumndocsFdxCmtsUsOfdmaChannelStatusFdxEnabled | read-only | current | This attribute reports if the OFDMA channel is enabled for FDX as indicated by the channel's spectrum being configured in the FDX Allocated Spectrum. |
| 1.3.6.1.4.1.4491.2.1.35.2.6 | TabledocsFdxCmtsDsOfdmChannelStatusTable | not-accessible | current | This CMTS table reports the status of the downstream OFDM channels, in particular full-duplex capabilities. |
| 1.3.6.1.4.1.4491.2.1.35.2.6.1 | RowdocsFdxCmtsDsOfdmChannelStatusEntry | not-accessible | current | The conceptual row of docsFdxCmtsDsOfdmChannelStatusTable. |
| 1.3.6.1.4.1.4491.2.1.35.2.6.1.1 | ColumndocsFdxCmtsDsOfdmChannelStatusFdxEnabled | read-only | current | This attribute reports if the OFDM channel is enabled for FDX as indicated by the channel's spectrum being configured in the FDX Allocated Spectrum. |
| 1.3.6.1.4.1.4491.2.1.35.3 | NodedocsFdxCmMibObjects | |||
| 1.3.6.1.4.1.4491.2.1.35.4 | NodedocsFdxMibConformance | |||
| 1.3.6.1.4.1.4491.2.1.35.4.1 | NodedocsFdxMibCompliances | |||
| 1.3.6.1.4.1.4491.2.1.35.4.1.1 | CompliancedocsFdxCcapCompliance | current | The compliance statement for the CCAP. | |
| 1.3.6.1.4.1.4491.2.1.35.4.2 | NodedocsFdxMibGroups | |||
| 1.3.6.1.4.1.4491.2.1.35.4.2.1 | GroupdocsFdxCcapGroup | current | Group of objects implemented in a DOCSIS 4.0 CCAP for Full-Duplex capabiities. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| FdxCapabilityType | INTEGER { other(1), noFdx(2), fdxL(3), fdx(4) } | current | This data type enumerates values associated with the FDXCapability. Values are as follows: 'other' Indicates vendor-specific and future extensions. 'noFdx' Indicates that the CM does not support any form of FDX operatio… |