DOCS-FMA-LI-MIB
72 objects
This MIB module contains the lawful intercept objects for the DOCSIS Flexible MAC Architecture. Copyright 2021-2022 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
| CLAB-DEF-MIB | -- RFC 4639 clabProjDocsis |
| DIFFSERV-DSCP-TC | -- RFC 4001 DscpOrAny |
| DOCS-CABLE-DEVICE-MIB | -- RFC 3289 docsDevEvLevel docsDevEvId docsDevEvLastTime docsDevEvText |
| INET-ADDRESS-MIB | -- RFC 3418 InetAddressType InetAddress InetAddressPrefixLength InetPortNumber |
| SNMP-FRAMEWORK-MIB | SnmpAdminString |
| SNMPv2-CONF | -- RFC 2578 OBJECT-GROUP MODULE-COMPLIANCE NOTIFICATION-GROUP |
| SNMPv2-MIB | -- RFC 2579 sysName |
| SNMPv2-SMI | Counter64 Integer32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 3411 DateAndTime MacAddress RowStatus TEXTUAL-CONVENTION TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.4491.2.1.36 | IdentitydocsFmaLiMib | This MIB module contains the lawful intercept objects for the DOCSIS Flexible MAC Architecture. Copyright 2021-2022 Cable Television Laboratories, Inc. All rig… | ||
| 1.3.6.1.4.1.4491.2.1.36.0 | NodedocsFmaLiNotifications | |||
| 1.3.6.1.4.1.4491.2.1.36.0.1 | NotificationdocsFmaLiEventNotif | current | A notification to report a Lawful Intercept event sent from the MAC Manager to a provisioned notification receiver. It represents an implementation of the DOCS… | |
| 1.3.6.1.4.1.4491.2.1.36.1 | NodedocsFmaLiObjects | |||
| 1.3.6.1.4.1.4491.2.1.36.1.1 | NodedocsFmaLiStatusObjects | |||
| 1.3.6.1.4.1.4491.2.1.36.1.1.1 | TabledocsFmaLiTapStreamStatsTable | not-accessible | current | This table provides basic statistics in terms of counts of intercepted packets and intercepted packets that have been dropped by the MAC NE for the traffic str… |
| 1.3.6.1.4.1.4491.2.1.36.1.1.1.1 | RowdocsFmaLiTapStreamStatsEntry | not-accessible | current | The conceptual row of the docsFmaLiTapStreamStatsTable |
| 1.3.6.1.4.1.4491.2.1.36.1.1.1.1.1 | ColumndocsFmaLiTapStreamStatsInterceptedPkts | read-only | current | The number of packets matching this data stream specification that have been intercepted. |
| 1.3.6.1.4.1.4491.2.1.36.1.1.1.1.2 | ColumndocsFmaLiTapStreamStatsInterceptedDroppedPkts | read-only | current | The number of packets matching this data stream specification that, having been intercepted, were dropped in the lawful intercept process. |
| 1.3.6.1.4.1.4491.2.1.36.1.1.2 | TabledocsFmaLiTapDebugTable | not-accessible | current | This table provides access to Lawful Intercept debug messages generated by the MAC NE. A row in this table contains a debug message which is created when eithe… |
| 1.3.6.1.4.1.4491.2.1.36.1.1.2.1 | RowdocsFmaLiTapDebugEntry | not-accessible | current | The conceptual row of the docsFmaLiTapDebugTable. |
| 1.3.6.1.4.1.4491.2.1.36.1.1.2.1.1 | ColumndocsFmaLiTapDebugIndex | not-accessible | current | This key attribute is a simple index used in cases where there are multiple errors that are reported for a single TapStream. |
| 1.3.6.1.4.1.4491.2.1.36.1.1.2.1.2 | ColumndocsFmaLiTapDebugMessage | read-only | current | This attribute is a text string containing the debug message about the referenced tap that was generated by the MAC-NE. The format and content of this string a… |
| 1.3.6.1.4.1.4491.2.1.36.1.1.3 | ScalardocsFmaLiMedDevCapab | read-only | current | This attribute reports the MAC Manager's capabilities with respect to certain fields in MediationDeviceCfg that can be configured for a TAP. It is possible tha… |
| 1.3.6.1.4.1.4491.2.1.36.1.1.4 | ScalardocsFmaLiStreamCapab | read-only | current | This attribute reports the supported Lawful Intercept Stream parameters that can be configured on the MAC Manager. The inclusion of a specific parameter in the… |
| 1.3.6.1.4.1.4491.2.1.36.1.2 | NodedocsFmaLiConfigObjects | |||
| 1.3.6.1.4.1.4491.2.1.36.1.2.1 | TabledocsFmaLiMedDevCfgTable | not-accessible | current | The Mediation Device Configuration table is used to configure the Mediation device with which the intercepting device communicates. Rows in this table are crea… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1 | RowdocsFmaLiMedDevCfgEntry | not-accessible | current | The conceptual row of docsFmaLiMedDevCfgTable |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.1 | ColumndocsFmaLiMedDevCfgContentId | not-accessible | current | The Content key attribute is a session identifier from the intercept application's perspective, and a content identifier from the Mediation Device's perspectiv… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.2 | ColumndocsFmaLiMedDevCfgDestAddrType | read-create | current | This indicates whether the IP address provided in the MedDevCfgDestAddress is IPv4 or IPv6. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.3 | ColumndocsFmaLiMedDevCfgDestAddress | read-create | current | This attribute is the IP Address of the Mediation Device. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.4 | ColumndocsFmaLiMedDevCfgDestPort | read-create | current | This attribute is the port number on the Mediation Device's network interface to which to direct intercepted traffic. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.5 | ColumndocsFmaLiMedDevCfgIapSourceAddrType | read-only | current | This indicates whether the IP address provided in the MedDevCfgSourceAddress is IPv4 or IPv6. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.6 | ColumndocsFmaLiMedDevCfgIapSourceAddress | read-only | current | This attribute is the IP address of the MAC-NE that will be sending the intercepted packet stream to the configured Mediation Device. This value is auto-popula… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.7 | ColumndocsFmaLiMedDevCfgDscp | read-create | current | This attribute is the Differentiated Services Code Point (DSCP) the intercepting device applies to the IP packets encapsulating the intercepted traffic. This a… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.8 | ColumndocsFmaLiMedDevCfgVlanId | read-create | current | This attribute allows for the configuration of an optional VLAN ID to be associated with the intercepted packet stream traffic exiting the MAC-NE toward the Me… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.9 | ColumndocsFmaLiMedDevCfgTimeout | read-create | current | This attribute is the time from the point in which the Tap was provisioned after which the MedDevCfg table row, and all related TapStreamCfg table rows should … |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.10 | ColumndocsFmaLiMedDevCfgTransport | read-create | current | This attribute is the protocol used in transferring intercepted data to the Mediation Device. The UDP protocol is the only mandated protocol for the MAC NE. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.11 | ColumndocsFmaLiMedDevCfgNotifEnabled | read-create | current | This attribute controls the generation of any notifications or informs by the MIB agent for the device. When this attribute is set to 'true', the device will g… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.1.1.12 | ColumndocsFmaLiMedDevCfgStatus | read-create | current | The status of this row in the table. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2 | TabledocsFmaLiTapStreamCfgTable | not-accessible | current | The TapStreamCfg table is used to configure the list of traffic streams to be intercepted. The TapStreamCfg table has two keys, the ContentId and an Index. Eac… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1 | RowdocsFmaLiTapStreamCfgEntry | not-accessible | current | The conceptual row of docsFmaLiTapStreamCfgTable |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1.1 | ColumndocsFmaLiTapStreamCfgIndex | not-accessible | current | This key attribute configures the index of the stream itself. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1.2 | ColumndocsFmaLiTapStreamCfgType | read-create | current | This attribute configures the type of intercept filter associated to this generic stream. The following types of streams are supported: ip - The specific filte… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1.3 | ColumndocsFmaLiTapStreamCfgInterceptEnabled | read-create | current | This attribute configures whether the MAC Manager intercepts matching traffic. If this column in the table is set to 'true', the tap should intercept matching … |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1.4 | ColumndocsFmaLiTapStreamCfgTargetMacAddress | read-create | current | This attribute configures the MAC address of the device to be intercepted. If the TargetMacAddress identifies a cable modem and the Type is configured for 'ip'… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.2.1.5 | ColumndocsFmaLiTapStreamCfgStatus | read-create | current | The status of this row in the table. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3 | TabledocsFmaLiTap802InterceptCfgTable | not-accessible | current | This table configures the Layer2 parameters related to a specific stream that are sent to a specific Mediation Device as defined by the Content Identifier. Thi… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1 | RowdocsFmaLiTap802InterceptCfgEntry | not-accessible | current | The conceptual row of docsFmaLiTap802InterceptCfgTable |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.1 | ColumndocsFmaLiTap802InterceptCfgIndex | not-accessible | current | This key attribute allows for multiple Layer 2 (MAC) filter definitions to be defined for a specific row in the TapStreamCfg table. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.2 | ColumndocsFmaLiTap802InterceptCfgDestAddress | read-create | current | This attribute configures the Destination MAC address used in packet selection. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.3 | ColumndocsFmaLiTap802InterceptCfgSourceAddress | read-create | current | This attribute configures the Source MAC address used in packet selection. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.4 | ColumndocsFmaLiTap802InterceptCfgEthernetPid | read-create | current | This attribute configures the value of the Ethernet Protocol Identifier, which may be found on Ethernet traffic or IEEE 802.2 SNAP traffic. The value of this a… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.5 | ColumndocsFmaLiTap802InterceptCfgDestLlcSap | read-create | current | This optional attribute configures the value of the IEEE 802.2 Destination SAP. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.6 | ColumndocsFmaLiTap802InterceptCfgSourceLlcSap | read-create | current | This optional attribute configures the value of the IEEE 802.2 Source SAP. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.3.1.7 | ColumndocsFmaLiTap802InterceptCfgStatus | read-create | current | The status of this row in the table. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4 | TabledocsFmaLiTapIpInterceptCfgTable | not-accessible | current | This table configures the IP Layer 3 and Layer 4 filter criteria related to a specific stream that is sent to a specific Mediation Device as defined by the Con… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1 | RowdocsFmaLiTapIpInterceptCfgEntry | not-accessible | current | The conceptual row of docsFmaLiTapIpInterceptCfgTable |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.1 | ColumndocsFmaLiTapIpInterceptCfgIndex | not-accessible | current | This key attribute allows for multiple Layer 3 (IP) filter definitions to be defined for a specific TapStreamCfg instance. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.2 | ColumndocsFmaLiTapIpInterceptCfgDestAddrType | read-create | current | This indicates whether the IP address provided in the TapIpInterceptCfgDestAddr is IPv4 or IPv6. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.3 | ColumndocsFmaLiTapIpInterceptCfgDestAddress | read-create | current | This attribute configures the Destination IP address or prefix used in packet selection. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.4 | ColumndocsFmaLiTapIpInterceptCfgDestLength | read-create | current | This attribute configures the length of the Destination IP Address Prefix. A value of zero causes all addresses to match. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.5 | ColumndocsFmaLiTapIpInterceptCfgSourceAddrType | read-create | current | This indicates whether the IP address provided in the TapIpInterceptCfgSourceAddr is IPv4 or IPv6. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.6 | ColumndocsFmaLiTapIpInterceptCfgSourceAddress | read-create | current | This attribute configures the Source IP Address or prefix used in packet selection. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.7 | ColumndocsFmaLiTapIpInterceptCfgSourceLength | read-create | current | This attribute configures the length of the Source IP Address Prefix. A value of zero causes all addresses to match. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.8 | ColumndocsFmaLiTapIpInterceptCfgTosByte | read-create | current | This attribute configures the value of the TOS byte, when masked with TosByteMask, of traffic to be intercepted. If TosByte&(~TosByteMask)!=0, configuration is… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.9 | ColumndocsFmaLiTapIpInterceptCfgTosByteMask | read-create | current | This attribute configures the value of the TOS byte in an IPv4 or IPv6 header is ANDed with TosByteMask and compared with TosByte. If the values are equal, the… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.10 | ColumndocsFmaLiTapIpInterceptCfgFlowId | read-create | current | This attribute provides configuration of the flow label (id) in the IPv6 header. This attribute is optional. The value -1 configures any value of FlowId. |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.11 | ColumndocsFmaLiTapIpInterceptCfgProtocol | read-create | current | This attribute configures the IP protocol to match against the IPv4 protocol number or the IPv6 Next-Header number in the packet. The value -1 means 'any IP pr… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.12 | ColumndocsFmaLiTapIpInterceptCfgDestL4PortMin | read-create | current | This attribute configures the minimum value that the Layer-4 destination port number in the packet is required to have in order to match. The MAC Manager MUST … |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.13 | ColumndocsFmaLiTapIpInterceptCfgDestL4PortMax | read-create | current | This attribute configures the maximum value that the Layer-4 destination port number in the packet is required to have in order to match. The MAC Manager MUST … |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.14 | ColumndocsFmaLiTapIpInterceptCfgSourceL4PortMin | read-create | current | This attribute configures the minimum value that the Layer-4 source port number in the packet is required to have in order to match. The MAC Manager MUST rejec… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.15 | ColumndocsFmaLiTapIpInterceptCfgSourceL4PortMax | read-create | current | This attribute configures the maximum value that the Layer-4 source port number in the packet is required to have in order to match. The MAC Manager MUST rejec… |
| 1.3.6.1.4.1.4491.2.1.36.1.2.4.1.16 | ColumndocsFmaLiTapIpInterceptCfgStatus | read-create | current | The status of this row in the table. |
| 1.3.6.1.4.1.4491.2.1.36.2 | NodedocsFmaLiConformance | |||
| 1.3.6.1.4.1.4491.2.1.36.2.1 | NodedocsFmaLiCompliances | |||
| 1.3.6.1.4.1.4491.2.1.36.2.1.1 | CompliancedocsFmaLiCompliance | current | The compliance statement for FMA Lawful Intercept. | |
| 1.3.6.1.4.1.4491.2.1.36.2.2 | NodedocsFmaLiGroups | |||
| 1.3.6.1.4.1.4491.2.1.36.2.2.1 | GroupdocsFmaLiConfigGroup | current | Group of lawful intercept configuration tables | |
| 1.3.6.1.4.1.4491.2.1.36.2.2.2 | GroupdocsFmaLiStatusGroup | current | Group of lawful intercept status tables and scalars | |
| 1.3.6.1.4.1.4491.2.1.36.2.2.3 | GroupdocsFmaLiNotificationGroup | current | MAC Manager is required to support notifications in this group |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| IPv6FlowLabelOrAny | Integer32 (-1 | 0..1048575) | current | The flow identifier or Flow Label in an IPv6 packet header that may be used to discriminate traffic flows. The value of -1 is used to indicate a wildcard, i.e. any value. |