DOCS-RPHY-CTRL-MIB
52 objects
This MIB module contains the control management objects for the Remote PHY Device (RPD) management. Copyright 2017-2023 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
| CLAB-DEF-MIB | clabProjDocsis |
| DOCS-RPHY-MIB | -- RFC 4001 docsRphyRpdDevInfoUniqueId |
| INET-ADDRESS-MIB | -- RFC 3411 InetAddressType InetAddress |
| SNMP-FRAMEWORK-MIB | SnmpAdminString |
| SNMPv2-CONF | MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2578 TEXTUAL-CONVENTION |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.4491.2.1.31 | IdentitydocsRphyCtrlMib | This MIB module contains the control management objects for the Remote PHY Device (RPD) management. Copyright 2017-2023 Cable Television Laboratories, Inc. All… | ||
| 1.3.6.1.4.1.4491.2.1.31.0 | NodedocsRphyCtrlNotifications | |||
| 1.3.6.1.4.1.4491.2.1.31.1 | NodedocsRphyCtrlObjects | |||
| 1.3.6.1.4.1.4491.2.1.31.1.1 | NodedocsRphyCtrlRpdMibObjects | |||
| 1.3.6.1.4.1.4491.2.1.31.1.1.1 | TabledocsRphyCtrlRpdResetCtrlTable | not-accessible | current | This table allows an RPD to be reset remotely via GCP from the Principal CCAP Core. The RpdResetCtrl TLV is 40.1 |
| 1.3.6.1.4.1.4491.2.1.31.1.1.1.1 | RowdocsRphyCtrlRpdResetCtrlEntry | not-accessible | current | The conceptual row of docsRphyCtrlRpdResetCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.1.1.1 | ColumndocsRphyCtrlRpdResetCtrlReset | read-write | current | This attribute allows a reset of the RPD to be commanded. Reading this attribute always returns a value of softReset. The following reset states are supported:… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.2 | TabledocsRphyCtrlRpdLogCtrlTable | not-accessible | current | This table provides RPD log management functions. The RpdLogCtrl TLV is 40.2. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.2.1 | RowdocsRphyCtrlRpdLogCtrlEntry | not-accessible | current | The conceptual row of docsRphyRpdLogCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.2.1.1 | ColumndocsRphyCtrlRpdResetLog | read-write | current | This attribute controls resetting an RPD's local event log and/or the pending event queue. When this attribute is read, if it had been written, the RPD returns… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3 | TabledocsRphyCtrlRpdSsdCtrlTable | not-accessible | current | This table describes secure software downloads of software running on RPDs. The RpdSsdCtrl TLV Type is 90. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1 | RowdocsRphyCtrlRpdSsdCtrlEntry | not-accessible | current | The conceptual row of docsRphyCtrlRpdSsdCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.1 | ColumndocsRphyCtrlRpdSsdCtrlServerAddressType | read-write | current | This attribute represents the IP address type of the server. This value is of type InetAddressType, which is defined by [RFC 4001]. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.2 | ColumndocsRphyCtrlRpdSsdCtrlServerAddress | read-write | current | This attribute identifies the SSD server in the form of IPv4 or IPv6 address. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.3 | ColumndocsRphyCtrlRpdSsdCtrlTransport | read-write | current | This attribute communicates the type of transport for the RPD download of the software file. The supported transports are TFTP and HTTP. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.4 | ColumndocsRphyCtrlRpdSsdCtrlFilename | read-write | current | This attribute is used to communicate the name of the software file that the RPD needs to download. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.5 | ColumndocsRphyCtrlRpdSsdCtrlManufCvcChain | read-write | current | This attribute is used to communicate the certificate chain from the new PKI that contains both the Manufacturer Code Verification Certificate and the certific… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.6 | ColumndocsRphyCtrlRpdSsdCtrlCosignerCvcChain | read-write | current | This attribute is used to communicate the certificate chain from the new PKI that contains both the Co-signer Code Verification Certificate and the certificati… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.7 | ColumndocsRphyCtrlRpdSsdCtrlAdminControl | read-write | current | This attribute allows the CCAP Core to maintain control over the SSD process. When read, this attribute returns other. Valid values are listed and defined belo… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.8 | ColumndocsRphyCtrlRpdSsdCtrlStatus | read-only | current | This attribute reports the status of the SSD process in the RPD. This includes software image download and activation. Upon successful completion of the SSD op… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.9 | ColumndocsRphyCtrlRpdSsdCtrlSwImageIndex | read-write | current | This attribute identifies the software image that is the target of secure software download or software image activation. The CCAP Core can select the Main Sof… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.10 | ColumndocsRphyCtrlRpdSsdCtrlSsdStatusInfo | read-only | current | This attribute contains a human readable text string containing helpful information to describe the current status of SSD process. This applies to software ima… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.3.1.11 | ColumndocsRphyCtrlRpdSsdCtrlNextBootImage | read-write | current | This communicates to the RPD which software image to boot from the next time it reboots. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.4 | TabledocsRphyCtrlRpdCrashDataFileCtrlTable | not-accessible | current | This table provides CCAP Core control attributes needed to initiate an RPD upload of a crash analysis file to the Server. The RpdCrashDataFileCtrl TLV is 40.3. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.4.1 | RowdocsRphyCtrlRpdCrashDataFileCtrlEntry | not-accessible | current | The conceptual row of docsRphyCtrlRpdCrashDataFileCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.4.1.1 | ColumndocsRphyCtrlRpdCrashDataFileCtrlIndex | not-accessible | current | This key attribute uniquely identifies a particular device crash analysis file. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.4.1.2 | ColumndocsRphyCtrlRpdCrashDataFileCtrlFileControl | read-write | current | This attribute controls the action taken by the device regarding the file selected by Index attribute. When a value is written to this attribute for a given in… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5 | TabledocsRphyCtrlRpdCrashDataServerCtrlTable | not-accessible | current | This table provides the CCAP Core control attributes needed by the RPD to describe the upload server for crash analysis files. The RpdCrashDataServerCtrl TLV i… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1 | RowdocsRphyCtrlRpdCrashDataServerCtrlEntry | not-accessible | current | The conceptual row of docsRphyCtrlRpdCrashDataServerCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1.1 | ColumndocsRphyCtrlRpdCrashDataServerCtrlDestIpAddrType | read-write | current | This attribute represents the IP address type of the server. This value is of type InetAddressType, which is defined by [RFC 4001]. A successful connection dep… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1.2 | ColumndocsRphyCtrlRpdCrashDataServerCtrlDestIpAddr | read-write | current | This attribute represents the IP address of the server to which the crash analysis file is to be sent. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1.3 | ColumndocsRphyCtrlRpdCrashDataServerCtrlDestPath | read-write | current | This attribute represents the path, excluding the filename, at the server to which the crash analysis file is to be sent via TFTP. This attribute is not used w… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1.4 | ColumndocsRphyCtrlRpdCrashDataServerCtrlProtocol | read-write | current | Represents the protocol used for transferring the crash data file from the RPD to the file server. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.5.1.5 | ColumndocsRphyCtrlRpdCrashDataServerCtrlHttpFilenameKeyword | read-write | current | This attribute represents HTTP POST keyword which is used by the HTTP server to convey the crash data filename. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6 | TabledocsRphyCtrlRpdInitProvCtrlTable | not-accessible | current | This table allows the asset ID, device alias, and location of the RPD to be updated by the operator once an RPD is authenticated to the CCAP Core. Generally, t… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1 | RowdocsRphyCtrlRpdInitProvCtrlEntry | not-accessible | current | The conceptual row of docsRphyCtrlRpdInitProvCtrlTable. |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1.1 | ColumndocsRphyCtrlRpdInitProvCtrlAssetId | read-write | current | This attribute is used to communicate the asset tracking identifier as assigned by a network manager. When this attribute is written, the RPD stores its value … |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1.2 | ColumndocsRphyCtrlRpdInitProvCtrlDeviceAlias | read-write | current | This attribute communicates a device name assigned by the operator via management interface. This attribute is an 'alias' name for the device as specified by a… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1.3 | ColumndocsRphyCtrlRpdInitProvCtrlLocationDescription | read-write | current | This attribute allows a short text description to be written to the RPD describing where the RPD has been installed, such as a street address. The format is sp… |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1.4 | ColumndocsRphyCtrlRpdInitProvCtrlGeoLocationLatitude | read-write | current | This attribute allows the latitude portion of the RPD's geographic location to be written to the RPD. It consists of a 9-byte string formatted as specified in … |
| 1.3.6.1.4.1.4491.2.1.31.1.1.6.1.5 | ColumndocsRphyCtrlRpdInitProvCtrlGeoLocationLongitude | read-write | current | This attribute allows the longitude portion of the RPD's geographic location to be written to the RPD. It consists of a 10-byte long string formatted as specif… |
| 1.3.6.1.4.1.4491.2.1.31.2 | NodedocsRphyCtrlConformance | |||
| 1.3.6.1.4.1.4491.2.1.31.2.1 | NodedocsRphyCtrlCompliances | |||
| 1.3.6.1.4.1.4491.2.1.31.2.1.1 | CompliancedocsRphyCtrlCompliance | current | The compliance statement for RPD control features. | |
| 1.3.6.1.4.1.4491.2.1.31.2.2 | NodedocsRphyCtrlGroups | |||
| 1.3.6.1.4.1.4491.2.1.31.2.2.1 | GroupdocsRphyCtrlRpdGroup | current | Group of control objects implemented in CCAP Cores which represent RPD control objects managed via the GCP protocol. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| RphyCrashDataFileControlType | INTEGER { other(1), upload(2), cancelUpload(3), deleteFile(4), uploadAndDelete(5) } | current | This data type describes the action taken by the device regarding the file selected |
| RphyCrashDataServerControlProtocolType | INTEGER { other(1), tftp(2), http(3) } | current | This data type describes the protocol used during the upload. |
| RphyResetCtrlType | INTEGER { softReset(1), hardReset(2), nvReset(3), factoryReset(4) } | current | This data type indicates the type of reset to be performed by the RPD. |
| RphySsdAdminControlType | INTEGER { other(1), startSsd(2), abortSsd(3), activateImage(4) } | current | This data type describes values for the CCAP Core to maintain control over the SSD process. |
| RphySsdStatusType | INTEGER { other(1), idle(2), inProgress(3), cvcVerified(4), cvcRejected(5), codeFileVerified(6), codeFileRejected(7), activateRejected(8) } | current | This data type describes the status of the SSD process in the RPD. |
| RphySsdTransportType | INTEGER { tftp(1), http(2) } | current | This data type indicates the type of transport for the RPD download of the software file. |