DSG-IF-STD-MIB
83 objects
Licensed under the Apache License, Version 2.0 (the 'License'); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an 'AS IS' BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License. This MIB module provides the management objects of the DOCSIS Set-top Gateway (DSG) client controller CM component for DSG operations of Set-top devices. Copyright 1999-2023 Cable Television Laboratories, Inc. All rights reserved.
Imported Objects
| CLAB-DEF-MIB | clabProjDocsis |
| DOCS-CABLE-DEVICE-MIB | -- RFC 2863 docsDevEvLevel docsDevEvId docsDevEvText |
| DOCS-IF-MIB | -- RFC 4639 docsIfCmCmtsAddress docsIfCmStatusDocsisOperMode docsIfCmStatusModulationType docsIfDocsisBaseCapability |
| DOCS-IF3-MIB | Dsid |
| IF-MIB | -- RFC 3291 ifPhysAddress |
| INET-ADDRESS-MIB | -- RFC 2579 InetAddressType InetAddress InetPortNumber |
| SNMPv2-CONF | --RFC 2578 OBJECT-GROUP MODULE-COMPLIANCE NOTIFICATION-GROUP |
| SNMPv2-SMI | Counter32 Integer32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2580 MacAddress TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.4491.2.1.4 | IdentitydsgIfStdMib | Licensed under the Apache License, Version 2.0 (the 'License'); you may not use this file except in compliance with the License. You may obtain a copy of the L… | ||
| 1.3.6.1.4.1.4491.2.1.4.0 | NodedsgIfStdNotifications | |||
| 1.3.6.1.4.1.4491.2.1.4.0.1 | NotificationdsgIfStdUpstreamEnabledNotify | current | Indicates the eCM is being instructed to have the upstream transmitter enabled. This notification is send after CM registration. Note that the objects docsIfDo… | |
| 1.3.6.1.4.1.4491.2.1.4.0.2 | NotificationdsgIfStdUpstreamDisabledNotify | current | Indicates the CM is being instructed to have the upstream transmitter disabled. This notification is only send when the CM is registered and prior to disable t… | |
| 1.3.6.1.4.1.4491.2.1.4.0.3 | NotificationdsgIfStdTdsg2TimeoutNotify | current | Notifies that the eCM has a timeout Tdsg2. Note that the objects docsIfDocsisBaseCapability, docsIfCmStatusDocsisOperMode and docsIfCmStatusModulationType may … | |
| 1.3.6.1.4.1.4491.2.1.4.1 | NodedsgIfStdMibObjects | |||
| 1.3.6.1.4.1.4491.2.1.4.1.1 | NodedsgIfStdConfig | |||
| 1.3.6.1.4.1.4491.2.1.4.1.1.1 | ScalardsgIfStdDsgMode | read-only | current | The DSG Mode of operation of this device. The value 'none' indicates that the eCM is not performing DSG operations. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.2 | ScalardsgIfStdTdsg1 | read-only | current | The configured value for the Tdsg1 timer. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.3 | ScalardsgIfStdTdsg2 | read-only | current | The configured value for the Tdsg2 timer. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.4 | ScalardsgIfStdTdsg3 | read-only | current | The configured value for the Tdsg3 timer. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.5 | ScalardsgIfStdTdsg4 | read-only | current | The configured value for the Tdsg4 timer. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.6 | ScalardsgIfStdTdsg1Timeouts | read-only | current | The number of times Tdsg1 expired in the DSG eCM since last reboot. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.7 | ScalardsgIfStdTdsg2Timeouts | read-only | current | The number of times Tdsg2 expired in the DSG eCM since last reboot. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.8 | ScalardsgIfStdTdsg3Timeouts | read-only | current | The number of times Tdsg3 expired in the DSG eCM since last reboot. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.9 | ScalardsgIfStdTdsg4Timeouts | read-only | current | The number of times Tdsg4 expired in the DSG eCM since last reboot. |
| 1.3.6.1.4.1.4491.2.1.4.1.1.10 | ScalardsgIfStdOneWayRecovery | read-write | current | This objects describes what the eCM does when the Tdsg3 timer expires. A value of retryUp(1) indicates that the eCM will remain on the current downstream chann… |
| 1.3.6.1.4.1.4491.2.1.4.1.2 | NodedsgIfStdTunnelFilter | |||
| 1.3.6.1.4.1.4491.2.1.4.1.2.1 | TabledsgIfStdTunnelFilterTable | not-accessible | current | A table of the active DSG Tunnel Filters. Each DSG Tunnel Filter is used to identify packets to forward to a DSG Client. Conceptually, each DSG Tunnel is compo… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1 | RowdsgIfStdTunnelFilterEntry | not-accessible | current | The DSG eCM will have one entry for each DSG Tunnel Filter. One or more entries in this table are created when the DSG Client Controller instructs the eCM to b… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.1 | ColumndsgIfStdTunnelFilterIndex | not-accessible | current | The unique index of entries in this table. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.2 | ColumndsgIfStdTunnelFilterApplicationId | read-only | deprecated | The Application ID of the DSG Tunnel associated with this DSG Tunnel Filter. This object returns -1 for: DSG Tunnels that do not have an associated Application… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.3 | ColumndsgIfStdTunnelFilterMacAddress | read-only | current | The destination MAC Address matching this DSG Tunnel Filter entry. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.4 | ColumndsgIfStdTunnelFilterIpAddressType | read-only | current | The type of InetAddress for dsgIfStdTunnelFilterSrcIpAddr, dsgIfStdTunnelFilterSrcIpMask and dsgIfStdTunnelFilterDestIpAddr. Currently DSG Agents, DSG Client C… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.5 | ColumndsgIfStdTunnelFilterSrcIpAddr | read-only | current | The source IP Address matching this DSG Tunnel Filter. This object is used in conjunction with dsgIfStdTunnelFilterSrcMask. A value of zero indicates that sour… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.6 | ColumndsgIfStdTunnelFilterSrcIpMask | read-only | current | The Source IP Mask to be used with dsgIfStdTunnelFilterSrcIpAddr when comparing a packet to this DSG Tunnel Filter. The type of this address is determined by t… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.7 | ColumndsgIfStdTunnelFilterDestIpAddr | read-only | current | The destination IP Address matching this DSG Tunnel Filter. A value of zero indicates that destination IP Address filtering does not apply. The type of this ad… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.8 | ColumndsgIfStdTunnelFilterDestPortStart | read-only | current | The lower UDP destination port value in the range matching this DSG Tunnel Filter. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.9 | ColumndsgIfStdTunnelFilterDestPortEnd | read-only | current | The upper UDP destination port value in the range matching this DSG Tunnel Filter. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.10 | ColumndsgIfStdTunnelFilterPkts | read-only | current | The total number of Packets matching this DSG Tunnel Filter entry since creation of the entry. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.11 | ColumndsgIfStdTunnelFilterOctets | read-only | current | The total number of octets matching this DSG Tunnel Filter entry since creation of the entry. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.12 | ColumndsgIfStdTunnelFilterTimeActive | read-only | current | The total number of seconds that this DSG Tunnel Filter entry has been instantiated. |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.13 | ColumndsgIfStdTunnelFilterTunnelId | read-only | current | In DSG Advanced Mode, this value identifies the DSG Tunnel corresponding to this DSG Tunnel Filter entry. This value may correspond to the DSG Rule ID from the… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.14 | ColumndsgIfStdTunnelFilterDsid | read-only | current | When operating with Multicast DSID Forwarding (MDF) enabled, this object contains the DSID value obtained from the DA-to-DSID TLV in the MDD. If no DSID has be… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.15 | ColumndsgIfStdTunnelFilterClientIdType | read-only | current | The value of cableCard(0) indicates a DSG Tunnel requested by the CableCARD on an OpenCable Host. The value of broadcast(1) indicates a DSG Tunnel for an indus… |
| 1.3.6.1.4.1.4491.2.1.4.1.2.1.1.16 | ColumndsgIfStdTunnelFilterClientIdValue | read-only | current | The Client Identification Value. The content depends on the value of the dsgIfStdTunnelFilterClientIdType. For dsgIfStdTunnelFilterClientIdType of type cableCa… |
| 1.3.6.1.4.1.4491.2.1.4.1.3 | NodedsgIfStdDsgChannelList | |||
| 1.3.6.1.4.1.4491.2.1.4.1.3.1 | TabledsgIfStdDsgChannelListTable | not-accessible | current | This table contains the list of DSG channels provided to the DSG eCM for use in scanning. |
| 1.3.6.1.4.1.4491.2.1.4.1.3.1.1 | RowdsgIfStdDsgChannelListEntry | not-accessible | current | The conceptual row for this table. The DSG eCM creates an entry per each downstream channel provided in the DCD message. An entry is deleted when removed from … |
| 1.3.6.1.4.1.4491.2.1.4.1.3.1.1.1 | ColumndsgIfStdDsgChannelListIndex | not-accessible | current | The unique identifier for entries in this table |
| 1.3.6.1.4.1.4491.2.1.4.1.3.1.1.2 | ColumndsgIfStdDsgChannelListFrequency | read-only | current | The downstream channel center frequency of this entry. |
| 1.3.6.1.4.1.4491.2.1.4.1.4 | NodedsgIfStdDsgSeb | |||
| 1.3.6.1.4.1.4491.2.1.4.1.4.1 | ScalardsgIfStdDsgSebControlObject | read-write | current | This object controls the state of DSG SEB. When set to FALSE the device is prohibited from enabling DSG SEB, both as a client or a server. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.2 | ScalardsgIfStdDsgSebRole | read-only | current | This object reports the current role of this device. The value of disabled(1) is used for a device where SEB is administratively disabled. The value of sebServ… |
| 1.3.6.1.4.1.4491.2.1.4.1.4.3 | ScalardsgIfStdDsgSebFomWeightUpstreamPower | read-write | current | This object controls the contribution of the upstream transmit power level term for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.4 | ScalardsgIfStdDsgSebFomWeightDownstreamPower | read-write | current | This object controls the contribution of the downstream receive power level term for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.5 | ScalardsgIfStdDsgSebFomWeightEqualizer | read-write | current | This object controls the contribution of the equalizer performance term for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.6 | ScalardsgIfStdDsgSebFomUsPwrHr | read-write | current | This object defines the Upstream transmit power headroom value for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.7 | ScalardsgIfStdDsgSebFomMfQpsk | read-write | current | This object defines the value of maximum power level for QPSK upstream for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.8 | ScalardsgIfStdDsgSebFomMfQam16 | read-write | current | This object defines the value of maximum power level for QAM16 upstream for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.9 | ScalardsgIfStdDsgSebFomMfQam64 | read-write | current | This object defines the value of maximum power level for QAM64 upstream for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.10 | ScalardsgIfStdDsgSebFomDsDesPwr | read-write | current | This object defines the value of desired downstream receive power for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.11 | ScalardsgIfStdDsgSebFomDspMin | read-write | current | This object defines the value of downstream receive power minimum for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.12 | ScalardsgIfStdDsgSebFomDspMax | read-write | current | This object defines the value of downstream receive power maximum for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.13 | ScalardsgIfStdDsgSebFomNmteRng | read-write | current | This object defines the value of non-main tap energy range for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.14 | ScalardsgIfStdDsgSebFomNmteMax | read-write | current | This object defines the value of non-main tap energy maximum for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.15 | ScalardsgIfStdDsgSebFomMtcMin | read-write | current | This object defines the value of main tap compression minimum for the Figure of Merit Calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.16 | ScalardsgIfStdDsgSebFom | read-only | current | This object contains the value resulting from the FOM calculation. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.17 | ScalardsgIfStdDsgSebTunnelTimeout | read-write | current | The number of seconds the SEB Server will wait for the SEB Tunnel to be established by the SEBC after receiving the ClientConnect service action. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.18 | ScalardsgIfStdDsgSebTdsg3Override | read-write | current | This object overrides the value of the Tdsg3 timeout specified in the DCD. A value of -1 indicates that the DCD value will be used. This object is ignored when… |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19 | TabledsgIfStdDsgSebConnectedDeviceTable | not-accessible | current | For a SEB Server, a list of the connected devices. In general, each SEB Tunnel will be used for multiple devices and will therefore have multiple entries in th… |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1 | RowdsgIfStdDsgSebConnectedDeviceEntry | not-accessible | current | The conceptual row of dsgIfStdDsgSebConnectedDeviceTable. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.1 | ColumndsgIfStdDsgSebConnectedDeviceIndex | not-accessible | current | The unique identifier for entries in this table |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.2 | ColumndsgIfStdDsgSebConnectedDeviceMacAddress | read-only | current | MAC Address of the connected device. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.3 | ColumndsgIfStdDsgSebConnectedDeviceIpAddressType | read-only | current | Type of IP Address for dsgIfStdDsgSebConnectedDeviceIpAddress. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.4 | ColumndsgIfStdDsgSebConnectedDeviceIpAddress | read-only | current | Global IP address assigned by a DHCP server and used on the DOCSIS network for this device. This object will report 0.0.0.0 if no address has been assigned or … |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.5 | ColumndsgIfStdDsgSebConnectedDeviceType | read-only | current | Type of device. Type cableCard(2) has been deprecated. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.6 | ColumndsgIfStdDsgSebTunnelClientIpAddressType | read-only | current | This object specifies the IP address type of dsgIfStdDsgSebTunnelClientIpAddress. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.7 | ColumndsgIfStdDsgSebTunnelClientIpAddress | read-only | current | The client side IP address of the SEB Tunnel. If a SEB Tunnel is not established, this object will report 0.0.0.0. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.8 | ColumndsgIfStdDsgSebTunnelClientPort | read-only | current | The server side TCP port used by this tunnel. If a SEB Tunnel is not established, this object will report 0. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.9 | ColumndsgIfStdDsgSebTunnelServerIpAddressType | read-only | current | This object specifies the IP address type of dsgIfStdDsgSebTunnelServerIpAddress. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.10 | ColumndsgIfStdDsgSebTunnelServerIpAddress | read-only | current | The server side IP address of the SEB Tunnel. If a SEB Tunnel is not established, this object will report 0.0.0.0. |
| 1.3.6.1.4.1.4491.2.1.4.1.4.19.1.11 | ColumndsgIfStdDsgSebTunnelServerPort | read-only | current | The server side TCP port used by this tunnel. If a SEB Tunnel is not established, this object will report 0. |
| 1.3.6.1.4.1.4491.2.1.4.2 | NodedsgIfStdConformance | |||
| 1.3.6.1.4.1.4491.2.1.4.2.1 | NodedsgIfStdCompliances | |||
| 1.3.6.1.4.1.4491.2.1.4.2.1.1 | CompliancedsgIfStdBasicCompliance | current | The compliance statement for DOCSIS Set-top Gateway eCMs. | |
| 1.3.6.1.4.1.4491.2.1.4.2.1.2 | CompliancedsgIfStdDsgSebCompliance | current | The compliance statement for DOCSIS Set-top Gateway devices that support DSG SEB. | |
| 1.3.6.1.4.1.4491.2.1.4.2.1.3 | CompliancedsgIfStdDeprecatedCompliance | deprecated | The compliance statement for deprecated objects of the DSGIFSTD MIB. | |
| 1.3.6.1.4.1.4491.2.1.4.2.2 | NodedsgIfStdGroups | |||
| 1.3.6.1.4.1.4491.2.1.4.2.2.1 | GroupdsgIfStdConfigGroup | current | A collection of configuration elements provided in DCD messages and DSG operations. | |
| 1.3.6.1.4.1.4491.2.1.4.2.2.2 | GroupdsgIfStdNotifyGroup | current | The collection of DSG notifications that the eCM reports as part of the Set-top device | |
| 1.3.6.1.4.1.4491.2.1.4.2.2.3 | GroupdsgIfStdDsgSebGroup | current | A collection of configuration elements in support of DSG SEB operation. These objects are required for both clients and servers. | |
| 1.3.6.1.4.1.4491.2.1.4.2.2.4 | GroupdsgIfStdDeprecatedGroup | deprecated | Group of deprecated objects |