EMPIRE-APACHEMOD
72 objects
No module-level DESCRIPTION found.
Imported Objects
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter enterprises Gauge TimeTicks |
| RFC1213-MIB | DisplayString |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.546 | Nodeempire | |||
| 1.3.6.1.4.1.546.16 | Nodeapplications | |||
| 1.3.6.1.4.1.546.16.3 | NodeapacheSrv | |||
| 1.3.6.1.4.1.546.16.3.1 | ScalarapacheModVersion | read-only | mandatory | Description and version number of this module for licensing. |
| 1.3.6.1.4.1.546.16.3.2 | ScalarapacheModMode | read-only | mandatory | This object indicates if the Apache Module is in full-mode or restricted-mode. Restricted-mode is entered, when SystemEDGE 4.0 and higher, fails to find a vali… |
| 1.3.6.1.4.1.546.16.3.10 | TableapacheConfigTable | not-accessible | mandatory | This table describes the configuration settings for each Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1 | RowapacheConfigEntry | not-accessible | mandatory | An entry in the Apache Configuration table. |
| 1.3.6.1.4.1.546.16.3.10.1.1 | ColumnapacheConfigPort | read-only | mandatory | The TCP port currently used by this Apache configuration. This value serves as the index for this table. |
| 1.3.6.1.4.1.546.16.3.10.1.2 | ColumnapacheConfigVersion | read-only | mandatory | Apache Web Server version number and description. |
| 1.3.6.1.4.1.546.16.3.10.1.3 | ColumnapacheConfigPID | read-only | mandatory | The process ID (PID) of the master Apache process. If the server is not running, 0 is returned. |
| 1.3.6.1.4.1.546.16.3.10.1.4 | ColumnapacheConfigRunMode | read-only | mandatory | The current operating mode. (e.g. standalone) |
| 1.3.6.1.4.1.546.16.3.10.1.5 | ColumnapacheConfigUser | read-only | mandatory | The user currently running the server processes. |
| 1.3.6.1.4.1.546.16.3.10.1.6 | ColumnapacheConfigGroup | read-only | mandatory | The group currently running the server processes. |
| 1.3.6.1.4.1.546.16.3.10.1.7 | ColumnapacheConfigHostname | read-only | mandatory | The hostname used by this Apache configuration. |
| 1.3.6.1.4.1.546.16.3.10.1.8 | ColumnapacheConfigStartProcs | read-only | mandatory | The number of server processes started by Apache at startup. |
| 1.3.6.1.4.1.546.16.3.10.1.9 | ColumnapacheConfigMinIdleProcs | read-only | mandatory | The minimum number of idle server processes maintained by Apache. |
| 1.3.6.1.4.1.546.16.3.10.1.10 | ColumnapacheConfigMaxIdleProcs | read-only | mandatory | The maximum number of idle server processes maintained by Apache. |
| 1.3.6.1.4.1.546.16.3.10.1.11 | ColumnapacheConfigMaxProcs | read-only | mandatory | The maximum total number of server processes allowed by Apache. |
| 1.3.6.1.4.1.546.16.3.10.1.12 | ColumnapacheConfigRequestsMaxPerChild | read-only | mandatory | The number of requests handled by a server process before it is recycled by Apache. |
| 1.3.6.1.4.1.546.16.3.10.1.13 | ColumnapacheConfigRequestsKeepAlive | read-only | mandatory | Is keep-alive enabled for persistent connections? disabled(0) or enabled(1) |
| 1.3.6.1.4.1.546.16.3.10.1.14 | ColumnapacheConfigRequestsMaxPerConn | read-only | mandatory | The number of requests handled in a single connection if keep-alive is on. |
| 1.3.6.1.4.1.546.16.3.10.1.15 | ColumnapacheConfigThreadsPerChild | read-only | mandatory | The maximum number of threads per child process. |
| 1.3.6.1.4.1.546.16.3.10.1.16 | ColumnapacheConfigConnectionTimeout | read-only | mandatory | The timeout value for closing inactive connections. |
| 1.3.6.1.4.1.546.16.3.10.1.17 | ColumnapacheConfigKeepAliveTimeout | read-only | mandatory | The keep-alive timeout value for open connections. |
| 1.3.6.1.4.1.546.16.3.10.1.18 | ColumnapacheConfigServerRoot | read-only | mandatory | The root directory for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.19 | ColumnapacheConfigConfigFile | read-only | mandatory | The current configuration file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.20 | ColumnapacheConfigPIDFile | read-only | mandatory | The current PID file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.21 | ColumnapacheConfigScoreboardFile | read-only | mandatory | The current scoreboard file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.22 | ColumnapacheConfigDocumentRoot | read-only | mandatory | The current document root directory for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.23 | ColumnapacheConfigAccessLogFile | read-only | mandatory | The current access or transaction log file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.24 | ColumnapacheConfigErrorLogFile | read-only | mandatory | The current error log file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.10.1.25 | ColumnapacheConfigScriptLogFile | read-only | mandatory | The current script log file for this Apache installation. |
| 1.3.6.1.4.1.546.16.3.11 | NodeapachePerformance | |||
| 1.3.6.1.4.1.546.16.3.11.1 | TableapacheFootprintTable | not-accessible | mandatory | This table reports the performance footprint for each Apache service. |
| 1.3.6.1.4.1.546.16.3.11.1.1 | RowapacheFootprintEntry | not-accessible | mandatory | An entry in the Apache Performance Footprint table. |
| 1.3.6.1.4.1.546.16.3.11.1.1.1 | ColumnapacheFootprintPort | read-only | mandatory | The TCP port currently used by this Apache configuration. This value serves as the index for this table. |
| 1.3.6.1.4.1.546.16.3.11.1.1.2 | ColumnapacheFootprintCPUTime | read-only | mandatory | CPU time, in seconds, accumulated by Apache which includes all Apache processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.3 | ColumnapacheFootprintPercentCPU | read-only | mandatory | The percentage of CPU utilization, by Apache, over the last sample interval. Since fractions are not supported by SNMP, the value reported is the percentage mu… |
| 1.3.6.1.4.1.546.16.3.11.1.1.4 | ColumnapacheFootprintTotalMEMSize | read-only | mandatory | The combined size of Apache's text, data, and stack segments in KBytes. It is the summation of the process sizes for all Apache server processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.5 | ColumnapacheFootprintTotalRSS | read-only | mandatory | The real memory (resident set) size of Apache in KBytes. It is the summation of the process RSS for all Apache server processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.6 | ColumnapacheFootprintPercentMEM | read-only | mandatory | The percentage (0-100) of real memory used by Apache which includes all Apache server processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.7 | ColumnapacheFootprintNumThreads | read-only | mandatory | The number of threads executing within all Apache processes. Note, on some systems, the operating system may be un-aware of user-level threads executing within… |
| 1.3.6.1.4.1.546.16.3.11.1.1.8 | ColumnapacheFootprintInBlks | read-only | mandatory | The number of blocks of data input by the processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.9 | ColumnapacheFootprintOutBlks | read-only | mandatory | The number of blocks of data output by the processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.10 | ColumnapacheFootprintMsgsSent | read-only | mandatory | The number of messages sent by the processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.11 | ColumnapacheFootprintMsgsRecv | read-only | mandatory | The number of messages received by the processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.12 | ColumnapacheFootprintSysCalls | read-only | mandatory | The number of system calls invoked by the processes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.13 | ColumnapacheFootprintMinorPgFlts | read-only | mandatory | The number of minor page faults incurred by the processes. Minor faults do not require I/O to retrieve the page. |
| 1.3.6.1.4.1.546.16.3.11.1.1.14 | ColumnapacheFootprintMajorPgFlts | read-only | mandatory | The number of major page faults incurred by the processes. Major faults require I/O to retrieve the page. |
| 1.3.6.1.4.1.546.16.3.11.1.1.15 | ColumnapacheFootprintNumSwaps | read-only | mandatory | The number of times the processes have been swapped. |
| 1.3.6.1.4.1.546.16.3.11.1.1.16 | ColumnapacheFootprintVolCtx | read-only | mandatory | The number of voluntary context switches incurred by the processes. Voluntary context switches occur when the processor 'voluntary' gives up the CPU (e.g. wait… |
| 1.3.6.1.4.1.546.16.3.11.1.1.17 | ColumnapacheFootprintInvolCtx | read-only | mandatory | The number of involuntary context switches incurred by the processes. An involuntary context switch occurs when the process has executed for the duration of it… |
| 1.3.6.1.4.1.546.16.3.11.1.1.18 | ColumnapacheFootprintTotalLogSize | read-only | mandatory | The size, in KBytes of the Apache service logs. This number is the sum of the access and error log file sizes. |
| 1.3.6.1.4.1.546.16.3.11.1.1.19 | ColumnapacheFootprintDocSize | read-only | mandatory | The size, in KBytes of the Apache document root directory and all files beneath it. |
| 1.3.6.1.4.1.546.16.3.11.1.1.20 | ColumnapacheFootprintTotalDiskSize | read-only | mandatory | The size, in KBytes, of all the Apache disk storage areas. It is a summation of log sizes, and service directories. Summing these storage components in one loc… |
| 1.3.6.1.4.1.546.16.3.11.2 | TableapacheServerPerfTable | not-accessible | mandatory | This table reports the performance of each Apache service. |
| 1.3.6.1.4.1.546.16.3.11.2.1 | RowapacheServerPerfEntry | not-accessible | mandatory | An entry in the Apache Server Performance table. |
| 1.3.6.1.4.1.546.16.3.11.2.1.1 | ColumnapacheServerPerfPort | read-only | mandatory | The TCP port currently used by this Apache configuration. This value serves as the index for this table. |
| 1.3.6.1.4.1.546.16.3.11.2.1.2 | ColumnapacheServerPerfUptime | read-only | mandatory | Number of seconds the Apache server has been up. |
| 1.3.6.1.4.1.546.16.3.11.2.1.3 | ColumnapacheServerPerfTotalAccesses | read-only | mandatory | Number of accesses (hits) to this server since it was last started. |
| 1.3.6.1.4.1.546.16.3.11.2.1.4 | ColumnapacheServerPerfTotalTraffic | read-only | mandatory | Number of KBytes transferred by this server since it was last started. |
| 1.3.6.1.4.1.546.16.3.11.2.1.5 | ColumnapacheServerPerfCurrentUsers | read-only | mandatory | Number of current active users (connections) maintained by the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.6 | ColumnapacheServerPerfCurrentIdleProcs | read-only | mandatory | Number of current idle processes available on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.7 | ColumnapacheServerPerfCurrentStartupProcs | read-only | mandatory | Number of processes currently in startup on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.8 | ColumnapacheServerPerfCurrentReadProcs | read-only | mandatory | Number of processes currently reading requests on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.9 | ColumnapacheServerPerfCurrentReplyProcs | read-only | mandatory | Number of processes currently replying to requests on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.10 | ColumnapacheServerPerfCurrentKeepAliveProcs | read-only | mandatory | Number of processes currently in keep-alive on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.11 | ColumnapacheServerPerfCurrentDNSProcs | read-only | mandatory | Number of processes currently doing a DNS lookup on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.12 | ColumnapacheServerPerfCurrentLoggingProcs | read-only | mandatory | Number of processes currently logging transactions on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.13 | ColumnapacheServerPerfCurrentFinishingProcs | read-only | mandatory | Number of processes currently finishing transactions on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.14 | ColumnapacheServerPerfCurrentTotalProcs | read-only | mandatory | Total number of Apache processes currently running on the Apache server. |
| 1.3.6.1.4.1.546.16.3.11.2.1.15 | ColumnapacheServerPerfCurrentBusyProcs | read-only | mandatory | Total number of Apache processes currently busy. This is the sum of apacheServerPerfCurrentStartupProcs, apacheServerPerfCurrentReadProcs, apacheServerPerfCurr… |