MIB Viewer

GBOND-TDIM-MIB

43 objects
The objects in this MIB module are used to manage the multi-pair bonded xDSL Interfaces using time-division inverse multiplexing (TDIM), defined in ITU-T recommendation G.998.3 (G.Bond/TDIM). This MIB module MUST be used in conjunction with GBOND-MIB module, common to all G.Bond technologies. The following references are used throughout this MIB module: [G.998.3] refers to: ITU-T Recommendation G.998.1: 'Multi-pair bonding using time-division inverse multiplexing', January 2005. [WT-159] refers to: DSL Forum Technical Report: 'Management Framework for xDSL Bonding', January 2007. Naming Conventions: BCE - Bonding Channel Entity CO - Central Office CPE - Customer Premises Equipment GBS - Generic Bonding Sublayer SNR - Signal to Noise Ratio Copyright (C) The Internet Society (2007). This version of this MIB module is part of RFC XXXX; see the RFC itself for full legal notices.
Imported Objects
GBOND-MIB-- RFC 2863 gBondMIB
IF-MIB-- RFC 2580 ifIndex InterfaceIndex
SNMPv2-CONF-- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP
SNMPv2-SMICounter32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION TruthValue
OIDNameAccessStatusDescription
1.3.6.1.2.1.211.3IdentitygBondTdimMIBThe objects in this MIB module are used to manage the multi-pair bonded xDSL Interfaces using time-division inverse multiplexing (TDIM), defined in ITU-T recom…
1.3.6.1.2.1.211.3.1NodegBondTdimObjects
1.3.6.1.2.1.211.3.1.1NodegBondTdimPort
1.3.6.1.2.1.211.3.1.1.0NodegBondTdimPortNotifications
1.3.6.1.2.1.211.3.1.1.0.1NotificationgBondTdimServiceUpcurrentThis notification indicates that a service indicated by the gBondTdimServiceIfIdx in a particular G.Bond TDIM port' is passing traffic. This notification MAY b…
1.3.6.1.2.1.211.3.1.1.0.2NotificationgBondTdimServiceDowncurrentThis notification indicates that a service indicated by the gBondTdimServiceIfIdx in a particular G.Bond TDIM port' has stopped passing the traffic. This notif…
1.3.6.1.2.1.211.3.1.1.1TablegBondTdimPortConfTablenot-accessiblecurrentTable for Configuration of G.Bond TDIM ports. Entries in this table MUST be maintained in a persistent manner
1.3.6.1.2.1.211.3.1.1.1.1RowgBondTdimPortConfEntrynot-accessiblecurrentAn entry in the G.Bond TDIM Port Configuration table. Each entry represents an G.Bond TDIM port indexed by the ifIndex. Additional conifguration parameters are…
1.3.6.1.2.1.211.3.1.1.1.1.1ColumngBondTdimFecAdminStateread-writecurrentA desired state of the OPTIONAL Forward Error Correction (FEC) function of the G.Bond TDIM port. A value of 'false' indicates that the FEC function is disabled…
1.3.6.1.2.1.211.3.1.1.1.1.2ColumngBondTdimFecWordSizeread-writecurrentA FEC code word size in octets for the G.Bond TDIM ports supporting FEC function. This object is read-write for the GBS-C ports and read-only for the GBS-R. A …
1.3.6.1.2.1.211.3.1.1.1.1.3ColumngBondTdimFecRedundancySizeread-writecurrentA FEC redundancy word size in octets for the G.Bond TDIM ports supporting FEC function. This object is read-write for the GBS-C ports and read-only for the GBS…
1.3.6.1.2.1.211.3.1.1.1.1.4ColumngBondTdimFecInterleaverTyperead-writecurrentAn Interleaver type for the G.Bond TDIM ports supporting FEC function. This object is read-write for the GBS-C ports and read-only for the GBS-R. A value of no…
1.3.6.1.2.1.211.3.1.1.1.1.5ColumngBondTdimFecInterleaverDepthread-writecurrentAn Interleaver Depth for the G.Bond TDIM ports supporting FEC function. This object is read-write for the GBS-C ports and read-only for the GBS-R. A value of z…
1.3.6.1.2.1.211.3.1.1.1.1.6ColumngBondTdimServiceUpDownEnableread-writecurrentIndicates whether gBondTdimServiceUp and gBondTdimServiceDown notifications should be generated for this interface. Value of true(1) indicates that the notific…
1.3.6.1.2.1.211.3.1.1.2TablegBondTdimPortCapabilityTablenot-accessiblecurrentTable for Capabilities of G.Bond TDIM ports. Entries in this table MUST be maintained in a persistent manner
1.3.6.1.2.1.211.3.1.1.2.1RowgBondTdimPortCapabilityEntrynot-accessiblecurrentAn entry in the G.Bond TDIM port Capability table. Each entry represents an G.Bond TDIM port indexed by the ifIndex. Additional capabilities are available via …
1.3.6.1.2.1.211.3.1.1.2.1.1ColumngBondTdimFecSupportedread-onlycurrentFEC and Interleaver Capability of the G.Bond/TDIM port. This object has a value of true(1) when the port supports the FEC and Interleaver function. A value of …
1.3.6.1.2.1.211.3.1.1.2.1.2ColumngBondTdimFecMaxWordSizeread-onlycurrentA Maximum supported FEC code word size in octets for the G.Bond TDIM ports with FEC function. A value of zero SHALL be returned if the FEC is not supported. Th…
1.3.6.1.2.1.211.3.1.1.2.1.3ColumngBondTdimFecMaxRedundancySizeread-onlycurrentA Maximum supported FEC redundancy word size in octets for the G.Bond TDIM ports with FEC function. A value of zero SHALL be returned if the FEC is not support…
1.3.6.1.2.1.211.3.1.1.2.1.4ColumngBondTdimFecInterleaverTypeSupportedread-onlycurrentSuported Interleaver types for the G.Bond TDIM ports with FEC function. Possible values are: none - the port does not support interleaving block - the port sup…
1.3.6.1.2.1.211.3.1.1.2.1.5ColumngBondTdimFecMaxInterleaverDepthread-onlycurrentA Maximum Interleaver Depth for the G.Bond TDIM ports with FEC function. A value of zero SHALL be returned if the Interleaver is not supported. This object par…
1.3.6.1.2.1.211.3.1.1.3TablegBondTdimPortStatusTablenot-accessiblecurrentThis table provides overall status information of G.Bond TDIM ports, complementing the generic status information from the ifTable of IF-MIB and gBondFltStatus…
1.3.6.1.2.1.211.3.1.1.3.1RowgBondTdimPortStatusEntrynot-accessiblecurrentAn entry in the G.Bond TDIM port Status table. Each entry represents a G.Bond TDIM port indexed by the ifIndex. Note that an G.Bond GBS port runs on top of a s…
1.3.6.1.2.1.211.3.1.1.3.1.1ColumngBondTdimCrc4Errorsread-onlycurrentThe total number of CRC-4 errors (frame header error) on all pairs in the G.Bond TDIM port. Simultaneous errors on M lines SHOULD be counted M times. This obje…
1.3.6.1.2.1.211.3.1.1.3.1.2ColumngBondTdimCrc6Errorsread-onlycurrentThe total number of CRC-6 errors (super-frame error) on all pairs in the G.Bond TDIM port. Simultaneous errors on M lines SHOULD be counted 1 time. This object…
1.3.6.1.2.1.211.3.1.1.3.1.3ColumngBondTdimCrc8Errorsread-onlycurrentThe total number of CRC-8 errors (event/message error) on all pairs in the G.Bond TDIM port. Simultaneous errors on M lines SHOULD be counted M times. This obj…
1.3.6.1.2.1.211.3.1.1.3.1.4ColumngBondTdimFltStatusread-onlycurrentG.Bond TDIM port Fault Status. This is a bitmap of possible conditions. The various bit positions are: serviceDown - at least one of the services defined for t…
1.3.6.1.2.1.211.3.1.1.4TablegBondTdimServiceTablenot-accessiblecurrentTable of Services in G.Bond TDIM ports. Entries in this table MUST be maintained in a persistent manner
1.3.6.1.2.1.211.3.1.1.4.1RowgBondTdimServiceEntrynot-accessiblecurrentAn entry in the G.Bond TDIM Port Service table, containing the management information applicable to a particular Service in a G.Bond TDIM port, indexed by the …
1.3.6.1.2.1.211.3.1.1.4.1.1ColumngBondTdimServiceIdxnot-accessiblecurrentG.Bond TDIM Service index - a unique index associated with a particular service entry, indicating relative placement of the service inside the G.Bond/TDIM fram…
1.3.6.1.2.1.211.3.1.1.4.1.2ColumngBondTdimServiceIfIdxread-writecurrentThis is a unique index within the ifTable. It represents the interface index of a service to be transmitted over the G.Bond/TDIM service instance. This objects…
1.3.6.1.2.1.211.3.1.1.4.1.3ColumngBondTdimServiceTyperead-writecurrentG.Bond TDIM Service Type. Possible values are: ds1 - Clear Channel DS1 (synchronous) e1 - Clear Channel E1 (synchronous) nxds0 - Fractional DS1 (synchronous) n…
1.3.6.1.2.1.211.3.1.1.4.1.4ColumngBondTdimServiceSizeread-writecurrentService size in octets per bonding sub-block for a specific service identified by gBondTdimServiceIdx. For TDM (synchronous) services with variable size e.g. f…
1.3.6.1.2.1.211.3.1.1.4.1.5ColumngBondTdimServiceOperStateread-onlycurrentG.Bond TDIM Service Operation State. Possible values are: up - Service is up passing traffic. down - Service is down, due to a variety of reasons, e.g. G.Bond …
1.3.6.1.2.1.211.3.2NodegBondTdimConformance
1.3.6.1.2.1.211.3.2.1NodegBondTdimGroups
1.3.6.1.2.1.211.3.2.1.1GroupgBondTdimBasicGroupcurrentA collection of objects representing management information for G.Bond TDIM ports.
1.3.6.1.2.1.211.3.2.1.2GroupgBondTdimFecGroupcurrentA collection of objects supporting OPTIONAL Forward Error Correction (FEC) and Interleaver function in G.Bond TDIM ports.
1.3.6.1.2.1.211.3.2.1.3GroupgBondTdimAlarmConfGroupcurrentA collection of objects required for configuration of alarm thresholds and notifications in G.Bond TDIM ports.
1.3.6.1.2.1.211.3.2.1.4GroupgBondTdimNotificationGroupcurrentThis group supports notifications of significant conditions associated with G.Bond TDIM ports.
1.3.6.1.2.1.211.3.2.2NodegBondTdimCompliances
1.3.6.1.2.1.211.3.2.2.1CompliancegBondTdimCompliancecurrentThe compliance statement for G.Bond TDIM interfaces. Compliance with the following external compliance statements is REQUIRED: MIB Module Compliance Statement …
Type Definitions
NameSyntaxStatusDescription
GBondTdimServiceIndexUnsigned32 (1..60)currentA unique value, greater than zero, for each Service defined in the managed G.Bond TDIM port, showing its relative position inside the G.Bond/TDIM frame. It is RECOMMENDED that values are assigned contiguously starting f…