IPFIX-EXPORTER-MIB
54 objects
The IPFIX MIB defines managed objects for IP flow information export. These objects provide information about managed nodes supporting IP flow information export, including flow information export capabilities, configuration and statistics. They also allow to configure IP flow information export concerning the IP interface at which flow information is gathered, the flow selections methods used, and the collector to which flow information is exported. Copyright (C) The Internet Society (2006). This version of this MIB module is part of RFC yyyy; see the RFC itself for full legal notices.
Imported Objects
| IF-MIB | -- RFC2580 InterfaceIndexOrZero |
| INET-ADDRESS-MIB | -- RFC2863 InetAddressType InetAddress InetAutonomousSystemNumber |
| SNMPv2-CONF | -- RFC2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Integer32 mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC2578 TEXTUAL-CONVENTION DateAndTime DisplayString RowStatus TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.999 | IdentityipfixMIB | The IPFIX MIB defines managed objects for IP flow information export. These objects provide information about managed nodes supporting IP flow information expo… | ||
| 1.3.6.1.2.1.999.1 | NodeipfixExporter | |||
| 1.3.6.1.2.1.999.1.1 | NodeipfixExporterObjects | |||
| 1.3.6.1.2.1.999.1.1.1 | NodeipfixReporting | |||
| 1.3.6.1.2.1.999.1.1.1.1 | TableipfixCollectorTable | not-accessible | current | This table lists collectors to which reports are exported. |
| 1.3.6.1.2.1.999.1.1.1.1.1 | RowipfixCollectorEntry | not-accessible | current | Defines an entry in the ipfixCollectorTable. |
| 1.3.6.1.2.1.999.1.1.1.1.1.1 | ColumnipfixCollectorIndex | not-accessible | current | The locally arbitrary, but unique identifier of a collector. The value is expected to remain constant at least from one re-initialization of the entity's netwo… |
| 1.3.6.1.2.1.999.1.1.1.1.1.2 | ColumnipfixCollectorDstIpAddressType | read-create | current | The IP address type of the collector. |
| 1.3.6.1.2.1.999.1.1.1.1.1.3 | ColumnipfixCollectorDstIpAddress | read-create | current | The IP address of the collector. |
| 1.3.6.1.2.1.999.1.1.1.1.1.4 | ColumnipfixCollectorDstProtocol | read-create | current | The transport protocol used for exporting sampled packets to the collector. The recommended protocols are TCP (6), UDP (17) and SCTP (132). The default is SCTP. |
| 1.3.6.1.2.1.999.1.1.1.1.1.5 | ColumnipfixCollectorDstPort | read-create | current | The port number of the collector. |
| 1.3.6.1.2.1.999.1.1.1.1.1.6 | ColumnipfixCollectorReportsSent | read-only | current | The number of reports sent to the collector. |
| 1.3.6.1.2.1.999.1.1.1.2 | TableipfixCollectorGroupTable | not-accessible | current | This table lists groups of collectors to which flow records packets are exported. If flow records are exported to only one collector the group consists of exac… |
| 1.3.6.1.2.1.999.1.1.1.2.1 | RowipfixCollectorGroupEntry | not-accessible | current | Defines an entry in the ipfixCollectorGroupTable. |
| 1.3.6.1.2.1.999.1.1.1.2.1.1 | ColumnipfixCollectorGroupIndex | not-accessible | current | The locally arbitrary, but unique identifier of a collector group. The value is expected to remain constant at least from one re-initialization of the entity's… |
| 1.3.6.1.2.1.999.1.1.1.3 | TableipfixTemplateTable | not-accessible | current | This table lists templates used by the exporter. |
| 1.3.6.1.2.1.999.1.1.1.3.1 | RowipfixTemplateEntry | not-accessible | current | Defines an entry in the ipfixTemplateTable. |
| 1.3.6.1.2.1.999.1.1.1.3.1.1 | ColumnipfixTemplateId | not-accessible | current | The unique identifier for the template. |
| 1.3.6.1.2.1.999.1.1.1.3.1.2 | ColumnipfixTemplateIndex | not-accessible | current | The locally arbitrary, but unique identifier of a field Id in the template identified by ipfixTemplateId. The value is expected to remain constant at least fro… |
| 1.3.6.1.2.1.999.1.1.1.3.1.3 | ColumnipfixTemplateFieldId | read-only | current | The Field Id at position ipfixTemplateIndex in the template ipfixTemplateId. This implicitly gives the data type and state values that are exported. |
| 1.3.6.1.2.1.999.1.1.1.3.1.4 | ColumnipfixTemplateFieldLength | read-only | current | The Length of the Field. Used to indicate if reduced encoding or variable length field is used. |
| 1.3.6.1.2.1.999.1.1.2 | NodeipfixInstances | |||
| 1.3.6.1.2.1.999.1.1.2.1 | TableipfixObservationDomainTable | not-accessible | current | This table lists the Observation Domains used at the managed node. |
| 1.3.6.1.2.1.999.1.1.2.1.1 | RowipfixObservationDomainEntry | not-accessible | current | Defines an entry in the ipfixObservationDomainTable. |
| 1.3.6.1.2.1.999.1.1.2.1.1.1 | ColumnipfixObservationDomainId | not-accessible | current | The locally arbitrary, but unique identifier of an Observation Domain. The value is expected to remain constant at least from one re-initialization of the enti… |
| 1.3.6.1.2.1.999.1.1.2.1.1.2 | ColumnipfixInstanceObservationPoint | read-create | current | The point where the packet is observed. If it is e.g, an interface it points to the mib-II object of the interface. |
| 1.3.6.1.2.1.999.1.1.2.1.1.3 | ColumnipfixInstanceStartTime | read-create | current | The date and time when exporting for this parameter set should start. |
| 1.3.6.1.2.1.999.1.1.2.1.1.4 | ColumnipfixInstanceStopTime | read-create | current | The date and time when exporting for this parameter set should stop. |
| 1.3.6.1.2.1.999.1.1.2.2 | TableipfixInstanceTable | not-accessible | current | This table lists active instances of packet sampling at the managed node. |
| 1.3.6.1.2.1.999.1.1.2.2.1 | RowipfixInstanceEntry | not-accessible | current | Defines an entry in the ipfixInstanceTable. |
| 1.3.6.1.2.1.999.1.1.2.2.1.1 | ColumnipfixInstanceIndex | not-accessible | current | The locally arbitrary, but unique identifier of an instance. The value is expected to remain constant at least from one re-initialization of the entity's netwo… |
| 1.3.6.1.2.1.999.1.1.2.2.1.2 | ColumnipfixInstanceTemplateId | read-create | current | The Id of a template in the template table. This implies the knowledge about the method chain from the method chain table. Furthermore it links the instance, m… |
| 1.3.6.1.2.1.999.1.1.2.2.1.3 | ColumnipfixInstanceCollectorGroupIndex | read-create | current | The index of the collector group to which packet reports are sent. |
| 1.3.6.1.2.1.999.1.1.2.2.1.4 | ColumnipfixInstancePacketsObserved | read-only | current | The number of packets observed at the observation point. |
| 1.3.6.1.2.1.999.1.1.2.2.1.5 | ColumnipfixInstancePacketsDropped | read-only | current | The number of packets dropped while filtering/sampling packets. |
| 1.3.6.1.2.1.999.1.1.2.2.1.6 | ColumnipfixInstanceProcessId | read-only | current | The process id of the metering process used by this instance. |
| 1.3.6.1.2.1.999.1.1.2.2.1.7 | ColumnipfixInstanceReportingProcessId | read-only | current | The process id of the reporting process used by this instance. |
| 1.3.6.1.2.1.999.1.1.2.2.1.8 | ColumnipfixInstanceReportsSent | read-only | current | The number of reports on sampled packets sent to the collector. |
| 1.3.6.1.2.1.999.1.1.2.4 | TableipfixMethodChainTable | not-accessible | current | This table contains method chains lists and connects them to the instances where they are applied to different observation points. The filtered/sampled packets… |
| 1.3.6.1.2.1.999.1.1.2.4.1 | RowipfixMethodChainEntry | not-accessible | current | Defines an entry in the ipfixMethodChainTable. |
| 1.3.6.1.2.1.999.1.1.2.4.1.2 | ColumnipfixMethodChainIndex | not-accessible | current | The locally arbitrary, but unique identifier of a template. The value is expected to remain constant at least from one re-initialization of the entity's networ… |
| 1.3.6.1.2.1.999.1.1.2.4.1.3 | ColumnipfixMethodChainMethod | read-create | current | The method used for the template at a certain position in the method chain. |
| 1.3.6.1.2.1.999.1.1.2.4.1.4 | ColumnipfixMethodChainPacketsObserved | read-only | current | The number of packets observed at the method entry point. |
| 1.3.6.1.2.1.999.1.1.2.4.1.5 | ColumnipfixMethodChainPacketsDropped | read-only | current | The number of packets dropped while selecting packets. |
| 1.3.6.1.2.1.999.2 | NodeipfixCollector | |||
| 1.3.6.1.2.1.999.3 | NodeipfixPsampExtension | |||
| 1.3.6.1.2.1.999.4 | NodeipfixConformance | |||
| 1.3.6.1.2.1.999.4.1 | NodeipfixCompliances | |||
| 1.3.6.1.2.1.999.4.1.1 | ComplianceipfixCompliance | current | An implementation that complies to this module must implement the objects defined in the mandatory groups ipfixGroupMetering and ipfixGroupReporting. The imple… | |
| 1.3.6.1.2.1.999.4.2 | NodeipfixGroups | |||
| 1.3.6.1.2.1.999.4.2.1 | GroupipfixGroupMetering | current | All objects that are basic for the metering process. It contains a basic metering function (ipfixSelectAll), The template definitions needed for the export of … | |
| 1.3.6.1.2.1.999.4.2.2 | GroupipfixGroupReporting | current | These objects define the collectors i.e., the destinations of the exporting process. | |
| 1.3.6.1.2.1.999.4.2.3 | GroupipfixGroupStatistics | current | These objects contain statistical values gathered at different points in the metering process. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| PsampMethodAvailability | INTEGER { available(1), notAvailable(2) } | current | Used to report the availability of a selection method: available(1) - the method is supported and can be used notAvailable(2) - the method is not available |