IPSEC-FLOW-MIB-TC
13 objects
This MIB module defines the textual conventions used in the IPsec Flow Monitoring MIB. This includes Internet DOI numbers defined in RFC 2407, ISAKMP numbers defined in RFC 2408, and IKE numbers defined in RFC 2409. Revision control of this document after publication will be under the authority of the IANA.
Imported Objects
| RFC1213-MIB | -- mib-2 |
| SNMPv2-SMI | experimental MODULE-IDENTITY |
| SNMPv2-TC | TEXTUAL-CONVENTION |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.3.170 | IdentityipsecFlowMibTC | This MIB module defines the textual conventions used in the IPsec Flow Monitoring MIB. This includes Internet DOI numbers defined in RFC 2407, ISAKMP numbers d… |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| AuthAlgo | INTEGER{ reserved(0), hmacMd5(2), hmacSha(3), desMac(4), hmacSha256(5), hmacSha384(6), hmacSha512(7), ripemd(8) } | current | The authentication algorithm used by a security association of an IPsec Phase-2 Tunnel. |
| CompAlgo | INTEGER{ reserved(0), compOui(1), compDeflate(2), compLzs(3), compLzjh(4) } | current | The compression algorithm used by a security association of an IPsec Phase-2 Tunnel. |
| ControlProtocol | INTEGER { reserved(0), cpNone(1), cpIkev1(2), cpIkev2(3), cpKink(4), cpOther(5) } | current | The protocol used for keying and control. The value of cp_none indicate manual administration of IPsec tunnels. This enumeration will be expanded as new keying protocols are standardized. |
| DiffHellmanGrp | INTEGER { reserved(0), modp768(1), modp1024(2), ec2nGP155(3), ec2nGP185(4), modp1536(5), ec2nGF163(6), ec2nGF283(8), ec2nGF409(10), ec2nGF571(12) } | current | The Diffie Hellman Group used in negotiations. reserved modp768 modp1024 modp1536 ec2nGP155 ec2nGP185 ec2nGF163 ec2nGF283 ec2nGF409 ec2nGF571 |
| EncapMode | INTEGER{ reserved(0), tunnel(1), transport(2) } | current | The encapsulation mode used by an IPsec Phase-2 Tunnel. |
| EncryptAlgo | INTEGER { reserved(0), espDes(1), esp3des(2), espRc5(3), espIdea(4), espCast(5), espBlowfish(6), esp3idea(7), espRc4(8), espNull(9), espAes(10) } | current | The encryption algorithm used in negotiations. |
| EndPtType | INTEGER { reserved(0), idIpv4Addr(1), idFqdn(2), idUserFqdn(3), idIpv4AddrSubnet(4), idIpv6Addr(5), idIpv6AddrSubnet(6), idIpv4AddrRange(7), idIpv6AddrRange(8), idDerAsn1Dn(9), idDerAsn1Gn(10), idKeyId(11) } | current | The type of identity use to specify an IPsec End Point. |
| IkeAuthMethod | INTEGER { reserved(0), preSharedKey(1), dssSignature(2), rsaSignature(3), rsaEncryption(4), revRsaEncryption(5), elGamalEncryption(6), revElGamalEncryption(7), ecsdaSignature(8), gssApiV1(9), gssApiV2(10) } | current | The authentication method used in IPsec Phase-1 IKE negotiations. |
| IkeHashAlgo | INTEGER { reserved(0), md5(1), sha(2), tiger(3), sha256(4), sha384(5), sha512(6) } | current | The hash algorithm used in IPsec Phase-1 IKE negotiations. |
| IkeNegoMode | INTEGER { reserved(0), main(1), aggressive(2) } | current | The IPsec Phase-1 IKE negotiation mode. |
| Phase1PeerIdentityType | INTEGER { reserved(0), idIpv4Addr(1), idFqdn(2), idDn(3), idIpv6Addr(4), idUserFqdn(5), idIpv4AddrSubnet(6), idIpv6AddrSubnet(7), idIpv4AddrRange(8), idIpv6AddrRange(9), idDerAsn1Gn(10), idKeyId(11) } | current | The type of IPsec Phase-1 peer identity. The peer may be identified by one of the ID types defined in IPSEC DOI. id_dn represent the binary DER encoding of the identity. |
| Spi | INTEGER (256..4294967295) | current | The type of the SPI associated with IPsec Phase-2 security associations. |