MIB Viewer

JACOBS-RPL-MIB

98 objects
The MIB module for monitoring nodes implementing the IPv6 routing protocol for low power and lossy networks (RPL). Copyright (c) 2012 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
Imported Objects
IF-MIB-- RFC 2580 InterfaceIndex
INET-ADDRESS-MIB-- RFC 2863 InetAddressIPv6
JACOBS-SMI-- RFC 4001 cnds
SNMPv2-CONF-- RFC 2579 OBJECT-GROUP MODULE-COMPLIANCE
SNMPv2-SMICounter32 mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION TruthValue
OIDNameAccessStatusDescription
1.3.6.1.4.1.30982.1.2IdentityrplMibThe MIB module for monitoring nodes implementing the IPv6 routing protocol for low power and lossy networks (RPL). Copyright (c) 2012 IETF Trust and the person…
1.3.6.1.4.1.30982.1.2.0NoderplNotifications
1.3.6.1.4.1.30982.1.2.1NoderplObjects
1.3.6.1.4.1.30982.1.2.1.1NoderplDefaults
1.3.6.1.4.1.30982.1.2.1.1.1ScalarrplDefaultDISModeread-writecurrentDetermines whether a DIS message is send upon boot-up. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.2ScalarrplDefaultDISMessagesread-writecurrentThe number of DIS messages that are sent as an initial probe for nearby DODAGs if the DIS mode is 'send'. The value of this object is ignored if the DIS mode i…
1.3.6.1.4.1.30982.1.2.1.1.3ScalarrplDefaultDISTimeoutread-writecurrentThe number of seconds after which a node in DIS mode 'send' in the absence of DIO messages may decide to root a floating DODAG. Changes to this value may not p…
1.3.6.1.4.1.30982.1.2.1.1.4ScalarrplDefaultDAODelayread-writecurrentThe default delay for aggregations before a DAO is send. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.5ScalarrplDefaultDAOAckEnabledread-writecurrentIndicates whether DAO Acknowledgements are sent on this RPL instance. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.6ScalarrplDefaultPreferenceread-writecurrentThe default preference of this DODAG compared to other DODAGs within the same instance. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.7ScalarrplDefaultMinHopRankIncreaseread-writecurrentThe default minimum increase of the rank in a single hop. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.8ScalarrplDefaultMaxRankIncreaseread-writecurrentThe default maximum allowable increase in rank in support of local repair. If DAGMaxRankIncrease is 0 then this mechanism is disabled. Changes to this value ma…
1.3.6.1.4.1.30982.1.2.1.1.9ScalarrplDefaultModeOfOperationread-writecurrentThe mode of operation of the RPL instance. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.10ScalarrplDefaultIntervalDoublingsread-writecurrentThe default Imax parameter of the DIO trickle timer. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.11ScalarrplDefaultIntervalMinread-writecurrentThe default Imin parameter of the DIO trickle timer. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.1.12ScalarrplDefaultRedundancyConstantread-writecurrentThe default k parameter of the DIO trickle timer. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.2NoderplActive
1.3.6.1.4.1.30982.1.2.1.2.1ScalarrplActiveInstanceread-writecurrentThe currently active RPL Instance. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.2.2ScalarrplActiveDodagread-writecurrentThe currently active RPL DODAG in the active RPL Instance. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.2.3ScalarrplActiveDodagTriggerSequenceread-writecurrentThe DAO Trigger Sequence Number (DTSN) of the active DODAG as defined in Section 6.3.1 of RFC 6550. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.3TablerplOCPTablenot-accessiblecurrentThe table of all supported Objective Code Points (OCPs).
1.3.6.1.4.1.30982.1.2.1.3.1RowrplOCPEntrynot-accessiblecurrentAn entry representing a supported Objective Code Point.
1.3.6.1.4.1.30982.1.2.1.3.1.1ColumnrplOCPCodepointnot-accessiblecurrentA supported Objective Code Point.
1.3.6.1.4.1.30982.1.2.1.3.1.2ColumnrplOCPEnabledread-writecurrentEnables the usage of this Objective Code Point. Changes to this value may not persist across restarts.
1.3.6.1.4.1.30982.1.2.1.4TablerplInstanceTablenot-accessiblecurrentThe table represents information about all known RPL Instances.
1.3.6.1.4.1.30982.1.2.1.4.1RowrplInstanceEntrynot-accessiblecurrentAn entry representing information about a RPL Instance.
1.3.6.1.4.1.30982.1.2.1.4.1.1ColumnrplInstanceIDnot-accessiblecurrentThe InstanceID of this RPL Instance.
1.3.6.1.4.1.30982.1.2.1.4.1.2ColumnrplInstanceDISModeread-onlycurrentReports whether a DIS message is send for this instance upon boot-up.
1.3.6.1.4.1.30982.1.2.1.4.1.3ColumnrplInstanceDISMessagesread-onlycurrentThe number of DIS messages that are sent as an initial probe for nearby DODAGs if the DIS mode is 'send'.
1.3.6.1.4.1.30982.1.2.1.4.1.4ColumnrplInstanceDISTimeoutread-onlycurrentThe number of seconds after which a node in DIS mode 'send' in the absence of DIO messages may decide to root a floating DODAG.
1.3.6.1.4.1.30982.1.2.1.4.1.5ColumnrplInstanceModeOfOperationread-onlycurrentThe mode of operation of the RPL instance.
1.3.6.1.4.1.30982.1.2.1.5TablerplDodagTablenot-accessiblecurrentThe table represents information about all locally known DODAGs.
1.3.6.1.4.1.30982.1.2.1.5.1RowrplDodagEntrynot-accessiblecurrentAn entry representing information about a DODAG.
1.3.6.1.4.1.30982.1.2.1.5.1.1ColumnrplDodagIndexnot-accessiblecurrentThe index identifying a DODAG within an RPL instance. This index is used to keep the table indexes short. The RPL protocol identifies a DODAG within an RPL ins…
1.3.6.1.4.1.30982.1.2.1.5.1.2ColumnrplDodagIDread-onlycurrentThe identifier of a DODAG root (DODAGID) of this RPL instance. The root of the DODAG reports its own IPv6 address as the DODAG root. This is uniquely identifyi…
1.3.6.1.4.1.30982.1.2.1.5.1.3ColumnrplDodagVersionread-onlycurrentThe version of the DODAG in this RPL instance.
1.3.6.1.4.1.30982.1.2.1.5.1.4ColumnrplDodagRankread-onlycurrentThe rank of the node within the DODAG.
1.3.6.1.4.1.30982.1.2.1.5.1.5ColumnrplDodagStateread-onlycurrentThe status of the DODAG: other(0) An unknown state. grounded(1) The DODAG is grounded. floating(2) The DODAG is floating (not grounded).
1.3.6.1.4.1.30982.1.2.1.5.1.6ColumnrplDodagOCPread-onlycurrentThe Objective Code Point of this DODAG.
1.3.6.1.4.1.30982.1.2.1.5.1.7ColumnrplDodagDAODelayread-onlycurrentThe delay for aggregations before a DAO is send.
1.3.6.1.4.1.30982.1.2.1.5.1.8ColumnrplDodagDAOAckEnabledread-onlycurrentIndicates whether DAO Acknowledgements are sent on this DODAG.
1.3.6.1.4.1.30982.1.2.1.5.1.9ColumnrplDodagPreferenceread-onlycurrentHow preferred this DODAG is compared to other DODAGs within the same instance.
1.3.6.1.4.1.30982.1.2.1.5.1.10ColumnrplDodagMinHopRankIncreaseread-onlycurrentThe minimum increase of the rank in a single hop.
1.3.6.1.4.1.30982.1.2.1.5.1.11ColumnrplDodagMaxRankIncreaseread-onlycurrentThe maximum allowable increase in rank in support of local repair. If DAGMaxRankIncrease is 0 then this mechanism is disabled.
1.3.6.1.4.1.30982.1.2.1.5.1.12ColumnrplDodagIntervalDoublingsread-onlycurrentThe Imax parameter of the DIO trickle timer.
1.3.6.1.4.1.30982.1.2.1.5.1.13ColumnrplDodagIntervalMinread-onlycurrentThe Imin parameter of the DIO trickle timer.
1.3.6.1.4.1.30982.1.2.1.5.1.14ColumnrplDodagRedundancyConstantread-onlycurrentThe k parameter of the DIO trickle timer.
1.3.6.1.4.1.30982.1.2.1.5.1.15ColumnrplDodagPathControlSizeread-onlycurrentThe Path Control Size of this DODAG.
1.3.6.1.4.1.30982.1.2.1.6TablerplDodagParentTablenot-accessiblecurrentThe list of parents for a DODAG.
1.3.6.1.4.1.30982.1.2.1.6.1RowrplDodagParentEntrynot-accessiblecurrentInformation about a known DODAG parent.
1.3.6.1.4.1.30982.1.2.1.6.1.1ColumnrplDodagParentIDnot-accessiblecurrentAn RPL parent associated with this DODAG.
1.3.6.1.4.1.30982.1.2.1.6.1.2ColumnrplDodagParentIfread-onlycurrentThe interface over which the parent can be reached.
1.3.6.1.4.1.30982.1.2.1.7TablerplDodagChildTablenot-accessiblecurrentThe list of children for a DODAG.
1.3.6.1.4.1.30982.1.2.1.7.1RowrplDodagChildEntrynot-accessiblecurrentInformation about a known DODAG child.
1.3.6.1.4.1.30982.1.2.1.7.1.1ColumnrplDodagChildIDnot-accessiblecurrentAn RPL child associated with this DODAG.
1.3.6.1.4.1.30982.1.2.1.7.1.2ColumnrplDodagChildIfread-onlycurrentThe interface over which the child can be reached.
1.3.6.1.4.1.30982.1.2.1.8NoderplStats
1.3.6.1.4.1.30982.1.2.1.8.1ScalarrplMemOverflowsread-onlycurrentThe number of memory allocation failures (e.g., routing table overflows).
1.3.6.1.4.1.30982.1.2.1.8.2ScalarrplParseErrorsread-onlycurrentThe number of received malformed messages.
1.3.6.1.4.1.30982.1.2.1.8.3ScalarrplUnknownMsgTypesread-onlycurrentThe number of received RPL messages that we dropped because the message type is not recognized by the implementation.
1.3.6.1.4.1.30982.1.2.1.8.4ScalarrplSecurityPolicyViolationsread-onlycurrentThe number of messages discarded because the described level of security for the message type and originator is unknown or does not meet locally maintained sec…
1.3.6.1.4.1.30982.1.2.1.8.5ScalarrplIntegrityCheckFailuresread-onlycurrentThe number of messages discarded because the integrity check failed against the received message authentication code (MAC) as defined in Section 10.7. of RFC 6…
1.3.6.1.4.1.30982.1.2.1.8.6ScalarrplReplayProtectionFailuresread-onlycurrentThe number of messages discarded because the received message Counter value is non-zero and less than the maintained incoming Counter watermark or because the …
1.3.6.1.4.1.30982.1.2.1.8.7ScalarrplValidParentFailuresread-onlycurrentThe number of times a packet could not be sent to a DODAG parent flagged as valid.
1.3.6.1.4.1.30982.1.2.1.8.8ScalarrplNoInstanceIDsread-onlycurrentThe number of times a packet could not be sent because of a missing RPLInstanceID.
1.3.6.1.4.1.30982.1.2.1.8.9ScalarrplTriggeredLocalRepairsread-onlycurrentThe number of times a local repair procedure was triggered.
1.3.6.1.4.1.30982.1.2.1.8.10ScalarrplTriggeredGlobalRepairsread-onlycurrentThe number of times a global repair procedure was triggered.
1.3.6.1.4.1.30982.1.2.1.8.11ScalarrplNoParentSecsread-onlycurrentThe number of seconds without a next hop (DODAG parent).
1.3.6.1.4.1.30982.1.2.1.8.12ScalarrplActiveNoParentSecsread-onlycurrentThe number of seconds with packets to forward without a next hop (DODAG parent).
1.3.6.1.4.1.30982.1.2.1.8.13ScalarrplOBitSetDownwardsread-onlycurrentNumber of packets received with the 'O' bit set from a node with a higher rank as defined in Section 18.3.2 of RFC 6550.
1.3.6.1.4.1.30982.1.2.1.8.14ScalarrplOBitClearedUpwardsread-onlycurrentNumber of packets received with the 'O' bit cleared from a node with a lower rank as defined in Section 18.3.2 of RFC 6550.
1.3.6.1.4.1.30982.1.2.1.8.15ScalarrplFBitSetread-onlycurrentNumber of packets received with the 'F' bit set as defined in Section 18.3.2 of RFC 6550.
1.3.6.1.4.1.30982.1.2.1.8.16ScalarrplRBitSetread-onlycurrentNumber of packets received with the 'R' bit set as defined in Section 18.3.2 of RFC 6550.
1.3.6.1.4.1.30982.1.2.1.8.17ScalarrplTrickleTimerResetsread-onlycurrentThe number of trickle timer resets.
1.3.6.1.4.1.30982.1.2.1.9TablerplMsgStatsTablenot-accessiblecurrentBasic RPL message statistics by message type.
1.3.6.1.4.1.30982.1.2.1.9.1RowrplMsgStatsEntrynot-accessiblecurrentStatistics for a specific RPL message type.
1.3.6.1.4.1.30982.1.2.1.9.1.1ColumnrplMsgStatsTypenot-accessiblecurrentThe RPL message type being counted by this row.
1.3.6.1.4.1.30982.1.2.1.9.1.2ColumnrplMsgStatsInMsgsread-onlycurrentThe number of RPL messages received of this type.
1.3.6.1.4.1.30982.1.2.1.9.1.3ColumnrplMsgStatsOutMsgsread-onlycurrentThe number of RPL messages sent of this type.
1.3.6.1.4.1.30982.1.2.2NoderplConformance
1.3.6.1.4.1.30982.1.2.2.1NoderplGroups
1.3.6.1.4.1.30982.1.2.2.1.1GrouprplGeneralGroupcurrentA collection of objects providing general information about the RPL implementation.
1.3.6.1.4.1.30982.1.2.2.1.2GrouprplInstanceGroupcurrentA collection of objects providing insight into RPL Instances and RPL DODAGs.
1.3.6.1.4.1.30982.1.2.2.1.3GrouprplStatsGroupcurrentA collection of objects providing statistics about the RPL implementation.
1.3.6.1.4.1.30982.1.2.2.2NoderplCompliances
1.3.6.1.4.1.30982.1.2.2.2.1CompliancerplFullCompliancecurrentCompliance statement for implementations supporting read/write access, according to the object definitions.
1.3.6.1.4.1.30982.1.2.2.2.2CompliancerplReadOnlyComplianceread-onlycurrentCompliance statement for implementations supporting only readonly access.
Type Definitions
NameSyntaxStatusDescription
RplDAODelayUnsigned32currentThe delay time used for aggregation before a DAO message is send.
RplDISModeINTEGER { silent(1), send(2) }currentDetermines whether a DIS message is send upon boot-up or not as defined in Section 18.2.1.1 of RFC 6550: silent(1) do not send DIS messages send(2) send DIS messages
RplDodagPreferenceUnsigned32 (0..7)currentThe preference of a DODAG compared to another DODAG of the same instance as defined in Section 6.3 of RFC 6550.
RplDodagVersionNumberUnsigned32 (0..255)currentThe version number of a DODAG as defined in Section 6.3 of RFC 6550.
RplInstanceIDUnsigned32 (0..255)currentA global or local RPLinstanceID as defined in Section 5.1. of RFC 6550.
RplMessageTypeUnsigned32 (0..255)currentThe type of an RPL control message as defined in Section 6 of RFC 6550.
RplMinHopRankIncreaseUnsigned32 (0..131071)currentThe minimal incerease of a rank within a single hop as defined in Section 6.7.6 of RFC 6550.
RplModeOfOperationINTEGER { noDownwardRoutes(0), nonStoringMode(1), storingWithoutMulticastSupport(2), storingWithMulticastSupport(3) }currentDetermines the mode of operation.
RplObjectiveCodePointUnsigned32 (0..65535)currentThe Objective Code Point of a DODAG as defined in Section 6.7.6 of RFC 6550.
RplPathControlSizeUnsigned32 (0..7)currentThe Path Control Size within a DODAG as defined in Section 6.7.6 of RFC 6550.
RplRankUnsigned32 (0..65535)currentThe rank of a node within a DODAG as defined in Section 6.3 of RFC 6550.