MAP-E-MIB
29 objects
This MIB module is defined for management of objects for MAP-E BRs or CEs. Copyright (c) 2018 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (https://trustee.ietf.org/license-info).
Imported Objects
| IF-MIB | --RFC 2579 ifIndex |
| INET-ADDRESS-MIB | --RFC 2863 InetAddressIPv6 InetAddressIPv4 InetAddressPrefixLength |
| SNMPv2-CONF | --RFC 4001 OBJECT-GROUP MODULE-COMPLIANCE |
| SNMPv2-SMI | Counter64 mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | --RFC 2578 TEXTUAL-CONVENTION |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.242 | IdentitymapMIB | This MIB module is defined for management of objects for MAP-E BRs or CEs. Copyright (c) 2018 IETF Trust and the persons identified as authors of the code. All… | ||
| 1.3.6.1.2.1.242.1 | NodemapMIBObjects | |||
| 1.3.6.1.2.1.242.1.1 | NodemapRule | |||
| 1.3.6.1.2.1.242.1.1.1 | TablemapRuleTable | not-accessible | current | The (conceptual) table containing rule information for a specific mapping rule. It can also be used for row creation. |
| 1.3.6.1.2.1.242.1.1.1.1 | RowmapRuleEntry | not-accessible | current | Each entry in this table contains the information on a particular mapping rule. |
| 1.3.6.1.2.1.242.1.1.1.1.1 | ColumnmapRuleID | not-accessible | current | A unique identifier used to distinguish mapping rules. |
| 1.3.6.1.2.1.242.1.1.1.1.2 | ColumnmapRuleIPv6Prefix | read-only | current | The IPv6 prefix defined in the mapping rule that will be assigned to CEs. |
| 1.3.6.1.2.1.242.1.1.1.1.3 | ColumnmapRuleIPv6PrefixLen | read-only | current | The length of the IPv6 prefix defined in the mapping rule that will be assigned to CEs. |
| 1.3.6.1.2.1.242.1.1.1.1.4 | ColumnmapRuleIPv4Prefix | read-only | current | The IPv4 prefix defined in the mapping rule that will be assigned to CEs. |
| 1.3.6.1.2.1.242.1.1.1.1.5 | ColumnmapRuleIPv4PrefixLen | read-only | current | The length of the IPv4 prefix defined in the mapping rule that will be assigned to CEs. |
| 1.3.6.1.2.1.242.1.1.1.1.6 | ColumnmapRuleBRIPv6Address | read-only | current | The IPv6 address of the BR that will be conveyed to CEs. If the BR IPv6 address is anycast, the relay must use this anycast IPv6 address as the source address … |
| 1.3.6.1.2.1.242.1.1.1.1.7 | ColumnmapRulePSID | read-only | current | The PSID value algorithmically identifies a set of ports assigned to a CE. |
| 1.3.6.1.2.1.242.1.1.1.1.8 | ColumnmapRulePSIDLen | read-only | current | The bit length value of the number of significant bits in the PSID field. When it is set to 0, the PSID field is to be ignored. |
| 1.3.6.1.2.1.242.1.1.1.1.9 | ColumnmapRuleOffset | read-only | current | The number of the mapRuleOffset is 6 by default to exclude the system ports (0-1023). It is provided via the Rule Port Mapping Parameters in the Basic Mapping … |
| 1.3.6.1.2.1.242.1.1.1.1.10 | ColumnmapRuleEALen | read-only | current | The length of the Embedded Address (EA) defined in mapping rule that will be assigned to CEs. |
| 1.3.6.1.2.1.242.1.1.1.1.11 | ColumnmapRuleType | read-only | current | Indicates the type of mapping rule. '1' represents a BMR. '2' represents an FMR. '3' represents a BMR that is also an FMR for mesh mode. |
| 1.3.6.1.2.1.242.1.2 | NodemapSecurityCheck | |||
| 1.3.6.1.2.1.242.1.2.1 | TablemapSecurityCheckTable | not-accessible | current | The (conceptual) table containing information on MAP security checks. This table can be used for statistics on the number of invalid packets that have been ide… |
| 1.3.6.1.2.1.242.1.2.1.1 | RowmapSecurityCheckEntry | not-accessible | current | Each entry in this table contains information on a particular MAP security check. |
| 1.3.6.1.2.1.242.1.2.1.1.1 | ColumnmapSecurityCheckInvalidv4 | read-only | current | Indicates the number of received IPv4 packets that do not have a payload source IPv4 address or port within the range defined in the matching MAP rule. It corr… |
| 1.3.6.1.2.1.242.1.2.1.1.2 | ColumnmapSecurityCheckInvalidv6 | read-only | current | Indicates the number of received IPv6 packets that do not have a source or destination IPv6 address matching a Basic Mapping Rule. It corresponds to the first … |
| 1.3.6.1.2.1.242.2 | NodemapMIBConformance | |||
| 1.3.6.1.2.1.242.2.1 | NodemapMIBCompliances | |||
| 1.3.6.1.2.1.242.2.1.1 | CompliancemapMIBCompliance | current | Describes the minimal requirements for conformance to the MAP-E MIB. | |
| 1.3.6.1.2.1.242.2.2 | NodemapMIBGroups | |||
| 1.3.6.1.2.1.242.2.2.1 | GroupmapMIBRuleGroup | current | The group of objects used to describe the MAP-E mapping rule. | |
| 1.3.6.1.2.1.242.2.2.2 | GroupmapMIBSecurityGroup | current | The group of objects used to provide information on the MAP-E security checks. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| RulePSID | OCTET STRING (SIZE (2)) | current | Indicates that the Port Set ID (PSID) is represented as hexadecimal for clarity. |
| RuleType | INTEGER { bmr(1), fmr(2), bmrAndfmr(3) } | current | Enumerates the type of the mapping rule. It defines three types of mapping rules here: bmr: Basic Mapping Rule (not Forwarding Mapping Rule) fmr: Forwarding Mapping Rule (not Basic Mapping Rule) bmrAndfmr: Basic and For… |