MPLS-OAM-ID-STD-MIB
44 objects
Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This MIB module contains generic object definitions for MPLS OAM identifiers.
Imported Objects
| DIFFSERV-MIB | -- RFC 3411 IndexIntegerNextFree |
| IF-MIB | -- RFC 3811 InterfaceIndexOrZero ifCounterDiscontinuityGroup ifGeneralInformationGroup |
| MPLS-TC-STD-MIB | -- RFC 3289 mplsStdMIB |
| SNMP-FRAMEWORK-MIB | -- RFC 2579 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2578 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2580 RowStatus RowPointer StorageType |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.10.166.21 | IdentitymplsOamIdStdMIB | Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with o… | ||
| 1.3.6.1.2.1.10.166.21.0 | NodemplsOamIdNotifications | |||
| 1.3.6.1.2.1.10.166.21.0.1 | NotificationmplsOamIdDefectCondition | current | This notification is sent whenever the operational status of the MEG is changed. | |
| 1.3.6.1.2.1.10.166.21.1 | NodemplsOamIdObjects | |||
| 1.3.6.1.2.1.10.166.21.1.1 | ScalarmplsOamIdMegIndexNext | read-only | current | This object contains an unused value for mplsOamIdMegIndex, or a zero to indicate that none exist. Negative values are not allowed, as they do not correspond t… |
| 1.3.6.1.2.1.10.166.21.1.2 | TablemplsOamIdMegTable | not-accessible | current | This table contains information about the Maintenance Entity Groups (MEGs). A MEG, as mentioned in the MPLS-TP OAM framework, defines a set of one or more Main… |
| 1.3.6.1.2.1.10.166.21.1.2.1 | RowmplsOamIdMegEntry | not-accessible | current | An entry in this table represents an MPLS-TP MEG. An entry can be created by a network administrator or by an SNMP agent as instructed by an MPLS-TP OAM framew… |
| 1.3.6.1.2.1.10.166.21.1.2.1.1 | ColumnmplsOamIdMegIndex | not-accessible | current | Index for the conceptual row identifying a MEG within this MEG table. Managers should obtain new values for row creation in this table by reading mplsOamIdMegI… |
| 1.3.6.1.2.1.10.166.21.1.2.1.2 | ColumnmplsOamIdMegName | read-create | current | Each MEG has a unique name amongst all those used or available to a service provider or operator. It facilitates easy identification of administrative responsi… |
| 1.3.6.1.2.1.10.166.21.1.2.1.3 | ColumnmplsOamIdMegOperatorType | read-create | current | Indicates the operator type for the MEG. Conceptual rows having 'iccBased' as the operator type MUST have valid values for the objects mplsOamIdMegIdIcc and mp… |
| 1.3.6.1.2.1.10.166.21.1.2.1.4 | ColumnmplsOamIdMegIdCc | read-create | current | Global uniqueness is assured by concatenating the ICC with a Country Code (CC). The Country Code (alpha-2) is a string of two alphabetic characters represented… |
| 1.3.6.1.2.1.10.166.21.1.2.1.5 | ColumnmplsOamIdMegIdIcc | read-create | current | Unique code assigned to a network operator or service provider; maintained by the ITU-T. This is the ITU Carrier Code used to form the MEGID. This object MUST … |
| 1.3.6.1.2.1.10.166.21.1.2.1.6 | ColumnmplsOamIdMegIdUmc | read-create | current | Unique code assigned by a network operator or service provider. This code is appended to mplsOamIdMegIdIcc to form the MEGID. This object MUST contain a non-nu… |
| 1.3.6.1.2.1.10.166.21.1.2.1.7 | ColumnmplsOamIdMegServicePointerType | read-create | current | Indicates the service type for the MEG. If the service type indicates tunnel (1), the service pointer in the mplsOamIdMeTable points to an entry in the point-t… |
| 1.3.6.1.2.1.10.166.21.1.2.1.8 | ColumnmplsOamIdMegMpLocation | read-create | current | Indicates the MP location type for this MEG. If the value is perNode, then the MEG in the LSR supports only perNode MEPs/MIPs, i.e., only one MEP/MIP in an LSR… |
| 1.3.6.1.2.1.10.166.21.1.2.1.9 | ColumnmplsOamIdMegPathFlow | read-create | current | Indicates the transport path flow for this MEG. In the case of a unidirectional point-to-point transport path, a single unidirectional ME is defined to monitor… |
| 1.3.6.1.2.1.10.166.21.1.2.1.10 | ColumnmplsOamIdMegOperStatus | read-only | current | This object specifies the operational status of the Maintenance Entity Group (MEG). This object is used to send the notification to the SNMP manager about the … |
| 1.3.6.1.2.1.10.166.21.1.2.1.11 | ColumnmplsOamIdMegSubOperStatus | read-only | current | This object specifies the reason why the MEG operational status, as indicated by the object mplsOamIdMegOperStatus, is down. This object is used to send the no… |
| 1.3.6.1.2.1.10.166.21.1.2.1.12 | ColumnmplsOamIdMegRowStatus | read-create | current | This variable is used to create, modify, and/or delete a row in this table. When a row in this table is in the active(1) state, no objects in that row can be m… |
| 1.3.6.1.2.1.10.166.21.1.2.1.13 | ColumnmplsOamIdMegStorageType | read-create | current | This variable indicates the storage type for this object. Conceptual rows having the value 'permanent' need not allow write access to any columnar objects in t… |
| 1.3.6.1.2.1.10.166.21.1.3 | ScalarmplsOamIdMeIndexNext | read-only | current | This object contains an unused value for mplsOamIdMeIndex, or a zero to indicate that none exist. Negative values are not allowed, as they do not correspond to… |
| 1.3.6.1.2.1.10.166.21.1.4 | ScalarmplsOamIdMeMpIndexNext | read-only | current | This object contains an unused value for mplsOamIdMeMpIndex, or a zero to indicate that none exist. Negative values are not allowed, as they do not correspond … |
| 1.3.6.1.2.1.10.166.21.1.5 | TablemplsOamIdMeTable | not-accessible | current | This table contains MPLS-TP ME information. The ME is some portion of a transport path that requires management bounded by two points (called MEPs), and the re… |
| 1.3.6.1.2.1.10.166.21.1.5.1 | RowmplsOamIdMeEntry | not-accessible | current | An entry in this table represents an MPLS-TP ME. This entry represents the ME if the source and sink MEPs are defined. An ME is a point-to-point entity. One ME… |
| 1.3.6.1.2.1.10.166.21.1.5.1.1 | ColumnmplsOamIdMeIndex | not-accessible | current | Uniquely identifies an ME index within a MEG. Managers should obtain new values for row creation in this table by reading mplsOamIdMeIndexNext. |
| 1.3.6.1.2.1.10.166.21.1.5.1.2 | ColumnmplsOamIdMeMpIndex | not-accessible | current | Indicates the Maintenance Point (MP) index that is used to create multiple MEPs in a node of a single ME. The value of this object can be the MEP index or the … |
| 1.3.6.1.2.1.10.166.21.1.5.1.3 | ColumnmplsOamIdMeName | read-create | current | This object denotes the ME name. Each ME has a unique name within a MEG. |
| 1.3.6.1.2.1.10.166.21.1.5.1.4 | ColumnmplsOamIdMeMpIfIndex | read-create | current | Indicates the MP interface. If the mplsOamIdMegMpLocation object value is perNode (1), the MP interface index should point to the incoming interface or outgoin… |
| 1.3.6.1.2.1.10.166.21.1.5.1.5 | ColumnmplsOamIdMeSourceMepIndex | read-create | current | Indicates the source MEP index of the ME. This object should be configured if the mplsOamIdMegOperatorType object in the mplsOamIdMegEntry is configured as icc… |
| 1.3.6.1.2.1.10.166.21.1.5.1.6 | ColumnmplsOamIdMeSinkMepIndex | read-create | current | Indicates the sink MEP index of the ME. This object should be configured if the mplsOamIdMegOperatorType object in the mplsOamIdMegEntry is configured as iccBa… |
| 1.3.6.1.2.1.10.166.21.1.5.1.7 | ColumnmplsOamIdMeMpType | read-create | current | Indicates the MP type within the MEG. The object should have the value mep (1) only in the ingress or egress nodes of the transport path. The object can have t… |
| 1.3.6.1.2.1.10.166.21.1.5.1.8 | ColumnmplsOamIdMeMepDirection | read-create | current | Indicates the direction of the MEP. This object should be configured if mplsOamIdMeMpType is configured as mep (1); otherwise, notApplicable (3) is set. |
| 1.3.6.1.2.1.10.166.21.1.5.1.9 | ColumnmplsOamIdMeServicePointer | read-create | current | This variable represents a pointer to the MPLS-TP transport path. This value MUST point at an entry in the mplsTunnelEntry if mplsOamIdMegServicePointerType is… |
| 1.3.6.1.2.1.10.166.21.1.5.1.10 | ColumnmplsOamIdMeRowStatus | read-create | current | This variable is used to create, modify, and/or delete a row in this table. When a row in this table is in the active(1) state, no objects in that row can be m… |
| 1.3.6.1.2.1.10.166.21.1.5.1.11 | ColumnmplsOamIdMeStorageType | read-create | current | This variable indicates the storage type for this object. Conceptual rows having the value 'permanent' need not allow write access to any columnar objects in t… |
| 1.3.6.1.2.1.10.166.21.2 | NodemplsOamIdConformance | |||
| 1.3.6.1.2.1.10.166.21.2.1 | NodemplsOamIdCompliances | |||
| 1.3.6.1.2.1.10.166.21.2.1.1 | CompliancemplsOamIdModuleFullCompliance | current | Compliance statement for agents that provide full support for the MPLS-TP-OAM-STD-MIB. Such devices can then be monitored and also be configured using this MIB… | |
| 1.3.6.1.2.1.10.166.21.2.1.2 | CompliancemplsOamIdModuleReadOnlyCompliance | read-only | current | Compliance statement for agents that only provide read-only support for the MPLS-TP-OAM-STD-MIB module. |
| 1.3.6.1.2.1.10.166.21.2.2 | NodemplsOamIdGroups | |||
| 1.3.6.1.2.1.10.166.21.2.2.1 | GroupmplsOamIdMegGroup | current | Collection of objects needed for MPLS MEG information. | |
| 1.3.6.1.2.1.10.166.21.2.2.2 | GroupmplsOamIdMeGroup | current | Collection of objects needed for MPLS ME information. | |
| 1.3.6.1.2.1.10.166.21.2.2.3 | GroupmplsOamIdNotificationObjectsGroup | current | Collection of objects needed to implement notifications. | |
| 1.3.6.1.2.1.10.166.21.2.2.4 | GroupmplsOamIdNotificationGroup | current | Set of notifications implemented in this module. |