NPI-DEV-MIB
47 objects
No module-level DESCRIPTION found.
Imported Objects
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter Gauge IpAddress mgmt NetworkAddress TimeTicks |
| RFC1213-MIB | DisplayString |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.1101 | Nodenpi | |||
| 1.3.6.1.4.1.1101.1 | Nodecommon | |||
| 1.3.6.1.4.1.1101.1.1 | NodedevDeviceInfo | |||
| 1.3.6.1.4.1.1101.1.1.1 | ScalardevDeviceName | read-only | mandatory | Full model number of this device, e.g. NPI NuWave DS24+ 24 port 10/100 Managed Ethernet Switch\n. |
| 1.3.6.1.4.1.1101.1.1.2 | ScalardevDeviceType | read-only | mandatory | The value indicates the type of this device. |
| 1.3.6.1.4.1.1101.1.1.3 | ScalardevDeviceModel | read-only | mandatory | DW24+ |
| 1.3.6.1.4.1.1101.1.1.4 | ScalardevDeviceHardwareVersion | read-only | mandatory | ASCII string to specify device hardware verion, e.g. 0A.01 |
| 1.3.6.1.4.1.1101.1.1.5 | ScalardevDeviceSoftwareVersion | read-only | mandatory | The current software/firmware version implemented in this device represented in non-zero integer. e.g. 10000 means version 1.00.00 |
| 1.3.6.1.4.1.1101.1.1.6 | ScalardevDeviceSNMPVersion | read-only | mandatory | Current version of SNMP protocol used in device, e.g. 1 means SNMPV1, 2 means SNMPV2, 3 means SNMPV3. |
| 1.3.6.1.4.1.1101.1.1.7 | ScalardevDeviceNPIMIBVersion | read-only | mandatory | Current version of NPI common MIB this device supports. e.g. the value 10000 indicates version 1.00.00 |
| 1.3.6.1.4.1.1101.1.1.8 | ScalardevDeviceTrapLevel | read-write | mandatory | Trap reporting level for occasional event. The events are categorized into 7 levels based on severity. For example, if the value set to 3, the Trap will be sen… |
| 1.3.6.1.4.1.1101.1.1.9 | ScalardevDeviceSubnetControl | read-only | mandatory | The entity indicates whether the firmware of the device implements internet subnet addressing. |
| 1.3.6.1.4.1.1101.1.1.10 | ScalardevDeviceIfMAX | read-only | mandatory | This object defines the maximum number of interfaces this device contains. |
| 1.3.6.1.4.1.1101.1.1.11 | TabledevDeviceIfTable | not-accessible | mandatory | This table contains addressing information relevant to this interface corresponding to IfEntry table. The number of entries is given by the value of ifNumber. |
| 1.3.6.1.4.1.1101.1.1.11.1 | RowdevDeviceIfEntry | not-accessible | mandatory | |
| 1.3.6.1.4.1.1101.1.1.11.1.1 | ColumndevDeviceIfIndex | read-only | mandatory | This index value uniquely identifies the interface to which this entry is applicable. |
| 1.3.6.1.4.1.1101.1.1.11.1.2 | ColumndevDeviceIfOperation | read-only | mandatory | This object indicates the operational status of this device. |
| 1.3.6.1.4.1.1101.1.1.11.1.3 | ColumndevDeviceIfMacAddr | read-only | mandatory | The MAC address of the specified interface of the device. |
| 1.3.6.1.4.1.1101.1.1.11.1.4 | ColumndevDeviceIfIpAddr | read-write | mandatory | The Internet address of the specified interface of the device. |
| 1.3.6.1.4.1.1101.1.1.11.1.5 | ColumndevDeviceIfSNetMask | read-write | mandatory | The internet address subnet mask of the specified interface of the device. |
| 1.3.6.1.4.1.1101.1.1.11.1.6 | ColumndevDeviceIfDfGateway | read-write | mandatory | The default gateway address which the routed packets are delivered to. |
| 1.3.6.1.4.1.1101.1.1.12 | TabledevDeviceSpecificOIDTable | not-accessible | mandatory | A list of SNMP MIB groups that the device supports |
| 1.3.6.1.4.1.1101.1.1.12.1 | RowdevDeviceSpecificOIDEntry | not-accessible | mandatory | |
| 1.3.6.1.4.1.1101.1.1.12.1.1 | ColumndevDeviceSpecificOIDIndex | read-only | mandatory | |
| 1.3.6.1.4.1.1101.1.1.12.1.2 | ColumndevDeviceSpecificOIDPtr | read-only | mandatory | The Object ID for the SMI enterprises subtree that the device did implement. |
| 1.3.6.1.4.1.1101.1.1.12.1.3 | ColumndevDeviceSpecificOIDDescription | read-only | mandatory | The description of this MIB group |
| 1.3.6.1.4.1.1101.1.1.12.1.4 | ColumndevDeviceSpecificOIDVersion | read-only | mandatory | The version of this MIB group, e.g., 10000 means version 1.00.00 |
| 1.3.6.1.4.1.1101.1.1.13 | TabledevDeviceTrapManagerTable | not-accessible | mandatory | This table contains the information needed for sending traps. |
| 1.3.6.1.4.1.1101.1.1.13.1 | RowdevDeviceTrapManagerEntry | not-accessible | mandatory | |
| 1.3.6.1.4.1.1101.1.1.13.1.1 | ColumndevDeviceTrapManagerIndex | read-only | mandatory | |
| 1.3.6.1.4.1.1101.1.1.13.1.2 | ColumndevDeviceTrapManagerMacAddr | read-only | mandatory | The MAC address of the management station which trap is sent to . |
| 1.3.6.1.4.1.1101.1.1.13.1.3 | ColumndevDeviceTrapManagerIpAddr | read-write | mandatory | The Internet address of the management station which trap is sent to . |
| 1.3.6.1.4.1.1101.1.1.13.1.4 | ColumndevDeviceTrapManagerAttribute | read-write | mandatory | The dynamic attribute of the station address indicates whether the address is learned from the and the permanent entries means specified by user. |
| 1.3.6.1.4.1.1101.1.1.13.1.5 | ColumndevDeviceTrapManagerProtocol | read-write | mandatory | Indicate the frame format used in the management station |
| 1.3.6.1.4.1.1101.1.1.13.1.6 | ColumndevDeviceTrapManagerComm | read-write | mandatory | Community name used for sending the trap to this management station |
| 1.3.6.1.4.1.1101.1.2 | NodedevMonitorInfo | |||
| 1.3.6.1.4.1.1101.1.2.1 | ScalardevMonTrapReportNumber | read-only | mandatory | The specific number of the latest trap event |
| 1.3.6.1.4.1.1101.1.2.2 | ScalardevMonTrapReportLevel | read-only | mandatory | The trap level of the latest trap event |
| 1.3.6.1.4.1.1101.1.2.3 | ScalardevMonTrapReportString | read-only | mandatory | The trap message to describe the latest trap event. |
| 1.3.6.1.4.1.1101.1.2.4 | ScalardevMonTrapReportTimestamp | read-only | mandatory | the value of sysUpTime at the time the latest trap event arises. |
| 1.3.6.1.4.1.1101.1.2.5 | ScalardevMonTrapReportPortNumber | read-only | mandatory | the port number binding with this event |
| 1.3.6.1.4.1.1101.1.3 | NodedevActionInfo | |||
| 1.3.6.1.4.1.1101.1.3.1 | ScalardevActReset | read-write | mandatory | Request system to perform reset in short time |
| 1.3.6.1.4.1.1101.1.3.2 | ScalardevActFactoryReset | read-write | mandatory | Request the system to perform factory reset in short time, all the setting will be changed to default ones, after this action. |
| 1.3.6.1.4.1.1101.1.3.3 | ScalardevActTest | read-write | mandatory | Request the system to perform a internal test which does not require resetting the system. |
| 1.3.6.1.4.1.1101.1.3.4 | ScalardevActTestResult | read-only | mandatory | This object shows the result of the test activated by setting devActTest |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| MacAddress | OCTET STRING (SIZE (6)) |