RADWARE-STATISTICS-MIB
64 objects
No module-level DESCRIPTION found.
Imported Objects
| RADWARE-MIB | rndErrorDesc rndErrorSeverity rsStatistics |
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter enterprises Gauge IpAddress NetworkAddress |
| RFC1213-MIB | DisplayString ipAddrEntry PhysAddress |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.89.35.1.73.1 | TablersStatisticsProtocolTable | not-accessible | mandatory | Table containing statistics data for protocols |
| 1.3.6.1.4.1.89.35.1.73.1 | NodersStatisticsReportingProblems | This trap is sent to inform the user about problems in statistics' reporting. | ||
| 1.3.6.1.4.1.89.35.1.73.1.1 | RowrsStatisticsProtocolEntry | not-accessible | mandatory | The row definition for this table. |
| 1.3.6.1.4.1.89.35.1.73.1.1.1 | ColumnrsStatisticsProtocol | read-only | mandatory | This variable indicates L4 protocol. |
| 1.3.6.1.4.1.89.35.1.73.1.1.2 | ColumnrsStatisticsProtocolPort | read-only | mandatory | This variable indicates protocol's port (for TCP and UDP). |
| 1.3.6.1.4.1.89.35.1.73.1.1.3 | ColumnrsStatisticsProtocolLastPeriodUsedBW | read-only | mandatory | The bandwidth used by the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.1.1.4 | ColumnrsStatisticsProtocolLastPeriodPeakBW | read-only | mandatory | The peak bandwidth of the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.1.1.5 | ColumnrsStatisticsProtocolLastPeriodMatchedPackets | read-only | mandatory | The number of packets of the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.1.2 | RowrsStatisticsProtocolReportingPeriod | read-write | mandatory | This variable indicates protocol statistics reporting frequency (in seconds) using SRP. |
| 1.3.6.1.4.1.89.35.1.73.1.3 | RowrsStatisticsProtocolTableUseSRP | read-write | mandatory | This variable indicates whether the device will send the data to ConfigWare using SRP. |
| 1.3.6.1.4.1.89.35.1.73.1.4 | RowrsStatisticsMonitorProtocols | read-write | mandatory | This variable indicates whether the device will gather protocols' statistics. |
| 1.3.6.1.4.1.89.35.1.73.2 | ScalarrsStatisticsSRPDstIpAddr | read-write | mandatory | Statistics Destination Ip Address, the statistics will be sent to this address in SRP mode |
| 1.3.6.1.4.1.89.35.1.73.2 | NodersStatisticsTablesFull | This trap is sent to inform the user about one of the protocol discovery tables being full. | ||
| 1.3.6.1.4.1.89.35.1.73.3 | ScalarrsStatisticsProbeStatusMessagePeriod | read-write | mandatory | The frequency of status messages (probe). |
| 1.3.6.1.4.1.89.35.1.73.4 | ScalarrsStatisticsProbeMaxBufferingTime | read-write | mandatory | The maximal time for buffering session information in probe memory. |
| 1.3.6.1.4.1.89.35.1.73.5 | TablersStatisticsProbePostVariablesTable | not-accessible | mandatory | Table containing the list of POST variables to be added to the URL |
| 1.3.6.1.4.1.89.35.1.73.5.1 | RowrsStatisticsProbePostVariablesEntry | not-accessible | mandatory | The row definition for this table. |
| 1.3.6.1.4.1.89.35.1.73.5.1.1 | ColumnrsStatisticsProbePostVariable | read-write | mandatory | Variable name. |
| 1.3.6.1.4.1.89.35.1.73.5.1.2 | ColumnrsStatisticsProbePostVariablesRowStatus | read-write | mandatory | This variable indicates the administrative status of this entry. |
| 1.3.6.1.4.1.89.35.1.73.6 | ScalarrsStatisticsNMSDstPort | read-write | mandatory | Statistics Destination NMS port |
| 1.3.6.1.4.1.89.35.1.73.7 | ScalarrsStatisticsProbeURLMaxLength | read-write | mandatory | Maximum length of URL string |
| 1.3.6.1.4.1.89.35.1.73.8 | ScalarrsStatisticsProbeRefererURLMaxLength | read-write | mandatory | Maximum length of referer URL string |
| 1.3.6.1.4.1.89.35.1.73.9 | ScalarrsStatisticsProbeHostMaxLength | read-write | mandatory | Maximum length of host string |
| 1.3.6.1.4.1.89.35.1.73.10 | ScalarrsStatisticsProbeMimeTypeMaxLength | read-write | mandatory | Maximum length of mime type string |
| 1.3.6.1.4.1.89.35.1.73.11 | ScalarrsStatisticsProbeBrowserMaxLength | read-write | mandatory | Maximum length of browser string |
| 1.3.6.1.4.1.89.35.1.73.12 | ScalarrsStatisticsProbeTCPTableSize | read-write | mandatory | The size of the TCP statistics table. |
| 1.3.6.1.4.1.89.35.1.73.13 | ScalarrsStatisticsProbeHTTPTableSize | read-write | mandatory | The size of the HTTP statistics table. |
| 1.3.6.1.4.1.89.35.1.73.14 | ScalarrsStatisticsNMSDstIpAddr | read-write | mandatory | Statistics Destination NMS Ip Address |
| 1.3.6.1.4.1.89.35.1.73.15 | NodersProbe | |||
| 1.3.6.1.4.1.89.35.1.73.16 | TablersStatisticsDiscoveryTable | not-accessible | mandatory | Table for the policies for protocol discovery |
| 1.3.6.1.4.1.89.35.1.73.16.1 | RowrsStatisticsDiscoveryEntry | not-accessible | mandatory | The row definition for this table. |
| 1.3.6.1.4.1.89.35.1.73.16.1.1 | ColumnrsStatisticsDiscoveryName | read-only | mandatory | The name of the policy |
| 1.3.6.1.4.1.89.35.1.73.16.1.2 | ColumnrsStatisticsDiscoveryIndex | read-write | mandatory | Determines the order of the policies. |
| 1.3.6.1.4.1.89.35.1.73.16.1.3 | ColumnrsStatisticsDiscoveryDestination | read-write | mandatory | Destination IP or network. |
| 1.3.6.1.4.1.89.35.1.73.16.1.4 | ColumnrsStatisticsDiscoverySource | read-write | mandatory | Source IP or network. |
| 1.3.6.1.4.1.89.35.1.73.16.1.5 | ColumnrsStatisticsDiscoveryDestinationMACGroup | read-write | mandatory | Name of the destination MAC group. |
| 1.3.6.1.4.1.89.35.1.73.16.1.6 | ColumnrsStatisticsDiscoverySourceMACGroup | read-write | mandatory | Name of the source MAC group. |
| 1.3.6.1.4.1.89.35.1.73.16.1.7 | ColumnrsStatisticsDiscoveryPhysicalPortGroup | read-write | mandatory | Name of physical port group. |
| 1.3.6.1.4.1.89.35.1.73.16.1.8 | ColumnrsStatisticsDiscoveryVLANTagGroup | read-write | mandatory | Name of VLAN tag group. |
| 1.3.6.1.4.1.89.35.1.73.16.1.9 | ColumnrsStatisticsDiscoveryDirection | read-write | mandatory | This variable indicates the direction of the incoming packet. |
| 1.3.6.1.4.1.89.35.1.73.16.1.10 | ColumnrsStatisticsDiscoveryOperationalStatus | read-write | mandatory | This variable indicates if the policy is active or inactive. |
| 1.3.6.1.4.1.89.35.1.73.16.1.11 | ColumnrsStatisticsDiscoveryStatus | read-write | mandatory | Administrative row status. |
| 1.3.6.1.4.1.89.35.1.73.17 | TablersStatisticsDiscoveryProtocolTable | not-accessible | mandatory | Table containing statistics data for protocols |
| 1.3.6.1.4.1.89.35.1.73.17.1 | RowrsStatisticsDiscoveryProtocolEntry | not-accessible | mandatory | The row definition for this table. |
| 1.3.6.1.4.1.89.35.1.73.17.1.1 | ColumnrsStatisticsDiscoveryProtocolName | read-only | mandatory | The name of the policy |
| 1.3.6.1.4.1.89.35.1.73.17.1.2 | ColumnrsStatisticsDiscoveryProtocol | read-only | mandatory | This variable indicates L4 protocol. |
| 1.3.6.1.4.1.89.35.1.73.17.1.3 | ColumnrsStatisticsDiscoveryProtocolPort | read-only | mandatory | This variable indicates protocol's port (for TCP and UDP). |
| 1.3.6.1.4.1.89.35.1.73.17.1.4 | ColumnrsStatisticsDiscoveryProtocolLastPeriodUsedBW | read-only | mandatory | The bandwidth used by the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.17.1.5 | ColumnrsStatisticsDiscoveryProtocolLastPeriodPeakBW | read-only | mandatory | The peak bandwidth of the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.17.1.6 | ColumnrsStatisticsDiscoveryProtocolLastPeriodMatchedPackets | read-only | mandatory | The number of packets of the protocol in the last sampling period defined in rsStatisticsProtocolSamplingPeriod. |
| 1.3.6.1.4.1.89.35.1.73.18 | NodersStatisticsTuning | |||
| 1.3.6.1.4.1.89.35.1.73.18.1 | NodersStatisticsProtocolPolicyTuning | |||
| 1.3.6.1.4.1.89.35.1.73.18.1.1 | ScalarrsStatisticsProtocolPolicyEntries | read-only | mandatory | Maximum number of policy entries. |
| 1.3.6.1.4.1.89.35.1.73.18.1.2 | ScalarrsStatisticsProtocolPolicyEntriesAfterReset | read-write | mandatory | Future maximum number of policy entries. |
| 1.3.6.1.4.1.89.35.1.73.18.2 | NodersStatisticsProtocolReportTuning | |||
| 1.3.6.1.4.1.89.35.1.73.18.2.1 | ScalarrsStatisticsProtocolReportEntries | read-only | mandatory | Maximum number of protocols reports entries. |
| 1.3.6.1.4.1.89.35.1.73.18.2.2 | ScalarrsStatisticsProtocolReportEntriesAfterReset | read-write | mandatory | Future maximum number of protocols reports entries. |
| 1.3.6.1.4.1.89.35.1.73.18.3 | NodersStatisticsProtocolPortsTuning | |||
| 1.3.6.1.4.1.89.35.1.73.18.3.1 | ScalarrsStatisticsProtocolPortsEntries | read-only | mandatory | Maximum number of special protocols entries for protocols discovery. |
| 1.3.6.1.4.1.89.35.1.73.18.3.2 | ScalarrsStatisticsProtocolPortsEntriesAfterReset | read-write | mandatory | Future maximum number of special protocols entries for protocols discovery. |
| 1.3.6.1.4.1.89.35.1.73.19 | ScalarrsStatisticsProtocolsDiscoveryAgingTime | read-write | mandatory | Lifetime for protocol discovery entries. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| NetNumber | OCTET STRING (SIZE(4)) | ||
| RowStatus | INTEGER { active(1), notInService(2), notReady(3), createAndGo(4), createAndWait(5), destroy(6) } | ||
| TruthValue | INTEGER { true (1), false (2) } |