SERVICE-LOCATION-PROTOCOL-MIB
44 objects
The MIB module for monitoring (but not configuration) of SLP (Service Location Protocol) directory agents (DAs), service agents (SAs), and/or user agents (UAs) on managed systems.
Imported Objects
| SNMP-FRAMEWORK-MIB | -- IETF RFC 2580 SnmpAdminString |
| SNMPv2-CONF | -- IETF RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Integer32 mib-2 MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | -- IETF RFC 2578 TEXTUAL-CONVENTION TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.999 | IdentityslpMIB | The MIB module for monitoring (but not configuration) of SLP (Service Location Protocol) directory agents (DAs), service agents (SAs), and/or user agents (UAs)… | ||
| 1.3.6.1.2.1.999.1 | NodeslpMIBObjects | |||
| 1.3.6.1.2.1.999.1.1 | NodeslpAgent | |||
| 1.3.6.1.2.1.999.1.1.1 | TableslpAgentTable | not-accessible | current | A table containing SLP (Service Location Protocol) objects for all of the SLP directory agents (DAs), service agents (SAs), or user agents (UAs) currently inst… |
| 1.3.6.1.2.1.999.1.1.1.1 | RowslpAgentEntry | not-accessible | current | An entry containing SLP (Service Location Protocol) objects for one of the SLP directory agents (DAs), service agents (SAs), or user agents (UAs) currently ins… |
| 1.3.6.1.2.1.999.1.1.1.1.1 | ColumnslpAgentIndex | not-accessible | current | Ordinal of this conceptual row in 'slpAgentTable'. |
| 1.3.6.1.2.1.999.1.1.1.1.2 | ColumnslpAgentSWInstalledIndexOrZero | read-only | current | The value of 'hrSWInstalledIndex' in the Host Resources MIB (RFC 2790) for the executable software for this SLP agent, or zero if none. See: 'hrSWInstalledInde… |
| 1.3.6.1.2.1.999.1.1.1.1.3 | ColumnslpAgentName | read-only | current | The friendly locally unique name for this SLP agent, for use with remote network management scripts and GUIs For example 'daNewYork'. |
| 1.3.6.1.2.1.999.1.1.1.1.4 | ColumnslpAgentType | read-only | current | The type of this SLP agent (DA, SA, or UA). See: 'net.slp.isDA' in SLP API (RFC 2614). |
| 1.3.6.1.2.1.999.1.1.1.1.5 | ColumnslpAgentIsBroadcastOnly | read-only | current | Broadcast only network enabled for this SLP agent. If 'true', SLP agent MUST send only broadcast messages. If 'false', SLP agent MAY send multicast messages. S… |
| 1.3.6.1.2.1.999.1.1.1.1.6 | ColumnslpAgentActiveDADiscovery | read-only | current | Active DA discovery allowed for this SLP agent. If 'true', SLP agent MAY actively discover DAs, If 'false', SLP agent MUST NOT actively discover DAs. See: 'Act… |
| 1.3.6.1.2.1.999.1.1.1.1.7 | ColumnslpAgentPassiveDADiscovery | read-only | current | Passive DA discovery allowed for this SLP agent. If 'true', SLP agent MAY passively discover DAs, If 'false', SLP agent MUST NOT passively discover DAs. See: '… |
| 1.3.6.1.2.1.999.1.1.1.1.8 | ColumnslpAgentMessageTypesSupported | read-only | current | The SLP message types supported by this SLP agent, expressed as an array of binary Function-ID values (RFC 2608). For example '0102'H means 'SrvRqst, SrvRply'.… |
| 1.3.6.1.2.1.999.1.1.1.1.9 | ColumnslpAgentExtensionsSupported | read-only | current | The SLP extensions supported by this SLP agent, expressed as an array of binary Extension ID values (RFC 2608), in network byte order (i.e., big-endian represe… |
| 1.3.6.1.2.1.999.1.2 | NodeslpScope | |||
| 1.3.6.1.2.1.999.1.2.1 | TableslpScopeTable | not-accessible | current | A table containing SLP (Service Location Protocol) objects for scope lists on this managed system. Usage: This table sparsely augments the 'slpAgentTable'. Usa… |
| 1.3.6.1.2.1.999.1.2.1.1 | RowslpScopeEntry | not-accessible | current | An entry containing SLP (Service Location Protocol) objects for one scope value on this managed system. |
| 1.3.6.1.2.1.999.1.2.1.1.1 | ColumnslpScopeIndex | not-accessible | current | Ordinal of this conceptual single row in 'slpScopeTable', subordinate to 'slpAgentIndex'. |
| 1.3.6.1.2.1.999.1.2.1.1.2 | ColumnslpScopeSource | read-only | current | The source (DHCP, etc) of this SLP scope. See: Section 2 'Introduction' in RFC 2610. |
| 1.3.6.1.2.1.999.1.2.1.1.3 | ColumnslpScopeValue | read-only | current | One scope configured or discovered for this SLP agent. Note: The default (and lowest preference) scope value for any SLP agent is the string 'DEFAULT' verbatim… |
| 1.3.6.1.2.1.999.1.3 | NodeslpAddress | |||
| 1.3.6.1.2.1.999.1.3.1 | TableslpAddressTable | not-accessible | current | A table containing SLP (Service Location Protocol) objects for remote DA/SA address lists known to this managed system. Usage: This table sparsely augments the… |
| 1.3.6.1.2.1.999.1.3.1.1 | RowslpAddressEntry | not-accessible | current | An entry containing SLP (Service Location Protocol) objects for one remote DA or SA address known to this managed system. |
| 1.3.6.1.2.1.999.1.3.1.1.1 | ColumnslpAddressIndex | not-accessible | current | Ordinal of this conceptual single row in 'slpAddressTable', subordinate to 'slpAgentIndex'. |
| 1.3.6.1.2.1.999.1.3.1.1.2 | ColumnslpAddressAgentType | read-only | current | The type of this remote SLP agent (DA or SA). See: 'net.slp.isDA' in SLP API (RFC 2614). |
| 1.3.6.1.2.1.999.1.3.1.1.3 | ColumnslpAddressSource | read-only | current | The source (DHCP, etc) of this remote SLP agent address. For example 'static(1)'. See: 'slpScopeSource' above in this SLP MIB. |
| 1.3.6.1.2.1.999.1.3.1.1.4 | ColumnslpAddressOrName | read-only | current | Text formatted (dotted decimal) IPv4 address; or (per RFC 2373) text formatted (colon-delimited hexadecimal) IPv6 address; or a fully qualifed DNS name for thi… |
| 1.3.6.1.2.1.999.1.4 | NodeslpAttribute | |||
| 1.3.6.1.2.1.999.1.4.1 | TableslpAttributeTable | not-accessible | current | A table containing SLP (Service Location Protocol) objects for SLP agent (DA or SA) attribute lists on this managed system. Usage: This table sparsely augments… |
| 1.3.6.1.2.1.999.1.4.1.1 | RowslpAttributeEntry | not-accessible | current | An entry containing SLP (Service Location Protocol) objects for one SLP agent (DA or SA) attribute on this managed system. See: 'net.slp.DAAttributes' in SLP A… |
| 1.3.6.1.2.1.999.1.4.1.1.1 | ColumnslpAttributeIndex | not-accessible | current | Ordinal of this conceptual single row in 'slpAttributeTable', subordinate to 'slpAgentIndex'. |
| 1.3.6.1.2.1.999.1.4.1.1.2 | ColumnslpAttributeName | read-only | current | The name of this SLP attribute. For example 'printer-resolution-supported' in the 'service:printer' IANA registered service template. See: Section 5 'Service A… |
| 1.3.6.1.2.1.999.1.4.1.1.3 | ColumnslpAttributeType | read-only | current | The type of this SLP attribute. For example 'attrBoolean' for a string formatted boolean. See: Section 5 'Service Attributes' in SLPv2 (RFC 2608). |
| 1.3.6.1.2.1.999.1.4.1.1.4 | ColumnslpAttributeValue | read-only | current | The value of this SLP attribute: a) A UTF-8 string if 'slpAttributeType' is 'attrBoolean', 'attrInteger', or 'attrString' b) an escaped string if 'slpAttribute… |
| 1.3.6.1.2.1.999.2 | NodeslpMIBConformance | |||
| 1.3.6.1.2.1.999.2.1 | ComplianceslpMIBCompliance | current | The compliance statements for SNMP Command Responders that implement the Service Location Protocol MIB. | |
| 1.3.6.1.2.1.999.2.2 | NodeslpMIBObjectGroups | |||
| 1.3.6.1.2.1.999.2.2.1 | GroupslpAgentGroup | current | The Agent object group in the SLP MIB | |
| 1.3.6.1.2.1.999.2.2.2 | GroupslpScopeGroup | current | The Scope object group in the SLP MIB | |
| 1.3.6.1.2.1.999.2.2.3 | GroupslpAddressGroup | current | The Address object group in the SLP MIB | |
| 1.3.6.1.2.1.999.2.2.4 | GroupslpAttributeGroup | current | The Attribute object group in the SLP MIB |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| SlpAgentTypeTC | INTEGER { da(1), sa(2), ua(3) } | current | The type of this SLP agent. See: 'net.slp.isDA' in SLP API (RFC 2614). |
| SlpAttributeTypeTC | INTEGER { attrBoolean(1), attrInteger(2), attrString(3), attrOpaque(4), attrKeyword(5) } | current | The type of this SLP attribute. See: Section 5 'Service Attributes' in SLPv2 (RFC 2608). |
| SlpScopeSourceTC | INTEGER { static(1), staticDA(2), dhcp(3), dhcpDA(4), dynamicDA(5), dynamicSA(6), default(7) } | current | The source (DHCP, etc) of this SLP scope or scope list. See: Section 2 'Introduction' in RFC 2610. |