SWATCH-MIB
66 objects
No module-level DESCRIPTION found.
Imported Objects
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter enterprises Gauge IpAddress mgmt NetworkAddress TimeTicks |
| RFC1213-MIB | DisplayString |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.1931 | Nodedms | |||
| 1.3.6.1.4.1.1931.1 | NodedmsMib | |||
| 1.3.6.1.4.1.1931.1.1 | NodeisPerf | |||
| 1.3.6.1.4.1.1931.1.1.1 | ScalarisNumber | read-only | mandatory | The number of network servers currently monitored by this agent. |
| 1.3.6.1.4.1.1931.1.1.2 | ScalarisNextIndex | read-only | mandatory | The next available row index that can be used for the creation of a new ServiceWatch request. If there are no available rows, 0 is returned. |
| 1.3.6.1.4.1.1931.1.1.3 | TableisTable | not-accessible | mandatory | The list of network servers and their status. The number of entries is given by the value of isNumber. |
| 1.3.6.1.4.1.1931.1.1.3.1 | RowisEntry | not-accessible | mandatory | An entry for a network server containing objects describing the health and performance of the network server. |
| 1.3.6.1.4.1.1931.1.1.3.1.1 | ColumnisIndex | read-only | mandatory | A unique value for each URL entry. Its value ranges between 1 and isNumber. Row/ index numbers start at row 1. around to 0, etc. |
| 1.3.6.1.4.1.1931.1.1.3.1.2 | ColumnisRequestName | read-write | mandatory | The name of the ServiceWatch request. |
| 1.3.6.1.4.1.1931.1.1.3.1.3 | ColumnisStatus | read-write | mandatory | See 'RequestStatus' definition for possible values, except the value of isStatus will never be notReady(3): if this row exists, it will ALWAYS be ready. The no… |
| 1.3.6.1.4.1.1931.1.1.3.1.4 | ColumnisURL | read-write | mandatory | The URL monitored. You can add new URLs to be monitored by setting a URL in isURL. |
| 1.3.6.1.4.1.1931.1.1.3.1.5 | ColumnisUsername | read-write | mandatory | The username to use for access to the network service. Currently used for web and ftp services only. |
| 1.3.6.1.4.1.1931.1.1.3.1.6 | ColumnisPassword | read-write | mandatory | A password to use for access to the network service. Currently used for web and ftp services only. |
| 1.3.6.1.4.1.1931.1.1.3.1.7 | ColumnisProxy | read-write | mandatory | The hostname of a web proxy server, if any. If an isProxy server is set to a web proxy server name, the request will be sent to the proxy server, instead of di… |
| 1.3.6.1.4.1.1931.1.1.3.1.8 | ColumnisServiceStatus | read-only | mandatory | The current operational state of the server. |
| 1.3.6.1.4.1.1931.1.1.3.1.9 | ColumnisDescription | read-only | mandatory | A textual description of the server software. |
| 1.3.6.1.4.1.1931.1.1.3.1.10 | ColumnisResponseTime | read-only | mandatory | The response time, in seconds, for the server to complete the request. Note: A string containing a floating point number: real floating point values do not exi… |
| 1.3.6.1.4.1.1931.1.1.3.1.11 | ColumnisResponseTimeInteger | read-only | mandatory | The response time, in seconds, for the server to complete the request. (An integer.) |
| 1.3.6.1.4.1.1931.1.1.3.1.12 | ColumnisTimeExceeded | read-only | mandatory | The time for the server to complete the request exceeded maximum amount of time allowed. (See the isMaxWait variable which is related to this variable.) The re… |
| 1.3.6.1.4.1.1931.1.1.3.1.13 | ColumnisMaxWait | read-write | mandatory | The maximum amount of time to wait before timing out during an attempt to perform a query on the server. |
| 1.3.6.1.4.1.1931.1.1.3.1.14 | ColumnisLevel | read-write | mandatory | The error level to set when an event occurs for this URL. The type of error level can be determined by the user: For example 1-10, or 'low', 'medium', 'high', … |
| 1.3.6.1.4.1.1931.1.1.3.1.15 | ColumnisError | read-only | mandatory | The type of error that occurred (if any). |
| 1.3.6.1.4.1.1931.1.1.3.1.16 | ColumnisBytesRead | read-only | mandatory | The number of data bytes read from the server on the last request. |
| 1.3.6.1.4.1.1931.1.1.3.1.17 | ColumnisThroughPut | read-only | mandatory | The rate of bytes per second read from the server on the last request. |
| 1.3.6.1.4.1.1931.1.1.3.1.18 | ColumnisPortNumber | read-only | mandatory | The TCP/IP or UDP/IP port number used to contact the network server. You specify the port number to use in isURL. |
| 1.3.6.1.4.1.1931.1.1.3.1.19 | ColumnisPortType | read-write | mandatory | For DNS, isPortType can be either TCP or UDP. For other protocols, it can be only TCP, since the other protocols speak only TCP. |
| 1.3.6.1.4.1.1931.1.1.3.1.20 | ColumnisOptions | read-write | mandatory | Options (bitstring) on how the server will be contacted. You can add these together to set more than one option: none(1): By defaut, a sample query to the serv… |
| 1.3.6.1.4.1.1931.1.1.3.1.21 | ColumnisNRequests | read-write | mandatory | The number of times to perform the request. |
| 1.3.6.1.4.1.1931.1.1.3.1.22 | ColumnisInterval | read-write | mandatory | The number of seconds to wait, after the completion of the last request, before starting the next request. |
| 1.3.6.1.4.1.1931.1.1.3.1.23 | ColumnisRequestNumber | read-only | mandatory | The request number (relates to isNRequests and isInterval. |
| 1.3.6.1.4.1.1931.1.1.3.1.24 | ColumnisEventType | read-write | mandatory | The type of notification that will be performed. Add all of the options you wish to use and set isEventType to the total of these options. For example, if you … |
| 1.3.6.1.4.1.1931.1.1.3.1.25 | ColumnisEprog | read-write | mandatory | The filename of the program to run when an event occurs (or after every poll attempt if isOptions has allEprog set). |
| 1.3.6.1.4.1.1931.1.1.3.1.26 | ColumnisEmail | read-write | mandatory | The email address to send email when an event occurs. If this variable is not null, then email will be sent to this email address when an event occurs. |
| 1.3.6.1.4.1.1931.1.1.3.1.27 | ColumnisEpager | read-write | mandatory | The email address of an alphanumeric pager to send email formatted for a pager when an event occurs. If this variable is not null, then email formatted for alp… |
| 1.3.6.1.4.1.1931.1.1.3.1.28 | ColumnisNCFails | read-only | mandatory | The number of CONSECUTIVE failures when attempting to complete the request to a network server. |
| 1.3.6.1.4.1.1931.1.1.3.1.29 | ColumnisNCFailsAlert | read-write | mandatory | Report a failure when isNCFailsAlert consecutive failures have occurred. Failures are reported as defined by the isEventType variable. The default for isNCFail… |
| 1.3.6.1.4.1.1931.1.1.3.1.30 | ColumnisResponseType | read-only | mandatory | The response type as returned from the server. For example 200-299 means the request succeeded, 400-499 are bad requests, etc. |
| 1.3.6.1.4.1.1931.1.1.3.1.31 | ColumnisResponseReason | read-only | mandatory | A textual description of the server's response type, as returned from the server. (This response should contain the string describing the responseType byte.) |
| 1.3.6.1.4.1.1931.1.1.3.1.32 | ColumnisLastAttempt | read-only | mandatory | The last time that this agent attempted to contact the network server. The format returned: Thu Oct 3 13:18:50 1996 |
| 1.3.6.1.4.1.1931.1.1.3.1.33 | ColumnisFirstFailed | read-only | mandatory | The first time the network service failed this round of failures. The format returned: Tue Jan 4 23:08:21 2000 |
| 1.3.6.1.4.1.1931.1.1.3.1.34 | ColumnisFileType | read-only | mandatory | The retrieved file's type, such as text/html, image/gif etc. (Applies to web servers only, currently). |
| 1.3.6.1.4.1.1931.1.1.3.1.35 | ColumnisIPAddr | read-only | mandatory | The IP address to which this entry's monitoring information pertains. |
| 1.3.6.1.4.1.1931.1.1.3.1.36 | ColumnisData | read-only | mandatory | Additional information or data returned from the sample request. |
| 1.3.6.1.4.1.1931.1.2 | NodeisTraps | |||
| 1.3.6.1.4.1.1931.1.2.1 | NodeserverFailed | The network server failed to correctly reply to the request in the time allowed. | ||
| 1.3.6.1.4.1.1931.1.2.2 | NodeserverUp | If notifyStateChange is set in isOptions and the state of the network service changed from down to up, then a 'serverUp' trap is sent. | ||
| 1.3.6.1.4.1.1931.1.3 | NodedmsTraps | |||
| 1.3.6.1.4.1.1931.1.3.1 | NodedmsStart | This trap is sent when the ServiceWatch agent starts | ||
| 1.3.6.1.4.1.1931.1.3.2 | NodedmsShutdown | This trap is sent when the ServiceWatch agent terminates | ||
| 1.3.6.1.4.1.1931.250 | NodeswatchSnmpAgent | |||
| 1.3.6.1.4.1.1931.250.1 | Nodehpux9 | |||
| 1.3.6.1.4.1.1931.250.2 | Nodesunos4 | |||
| 1.3.6.1.4.1.1931.250.3 | Nodesolaris | |||
| 1.3.6.1.4.1.1931.250.4 | Nodeosf | |||
| 1.3.6.1.4.1.1931.250.5 | Nodeultrix | |||
| 1.3.6.1.4.1.1931.250.6 | Nodehpux10 | |||
| 1.3.6.1.4.1.1931.250.7 | Nodenetbsd1 | |||
| 1.3.6.1.4.1.1931.250.8 | Nodefreebsd | |||
| 1.3.6.1.4.1.1931.250.9 | Nodeirix | |||
| 1.3.6.1.4.1.1931.250.10 | Nodelinux | |||
| 1.3.6.1.4.1.1931.250.11 | Nodebsdi | |||
| 1.3.6.1.4.1.1931.250.12 | Nodeopenbsd | |||
| 1.3.6.1.4.1.1931.250.13 | Nodewin32 | |||
| 1.3.6.1.4.1.1931.250.255 | Nodeunknown |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| PhysAddress | OCTET STRING | ||
| RequestStatus | INTEGER { |