MIB Viewer

TRILL-OAM-MIB

108 objects
This MIB module contains the management objects for the management of TRILL Services Operations, Administration and Maintenance. Initial version. Published as RFC 7784. Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). Abbreviations Used Term Definition CFM Connectivity Fault Management IEEE Institute of Electrical and Electronics Engineers IETF Internet Engineering Task Force ITU-T International Telecommunication Union - Telecommunication Standardization Bureau FCOI The Final, Cross-Connect Error, Out-of-band, and In-band flags from the TRILL OAM Application Identifier TLV. LBM Loopback Message MA Maintenance Association (equivalent to a MEG) MAC Media Access Control MD Maintenance Domain (equivalent to an OAM Domain in Metro Ethernet Forum (MEF) 17) MEG Maintenance Entity Group (equivalent to a MA) MEG Level Maintenance Entity Group Level (equivalent to MD Level) MEP Maintenance Association End Point MIB Management Information Base MIP Maintenance Domain Intermediate Point MTVM Multi-destination Tree Verification Message MTVR Multi-destination Tree Verification Reply OAM Operations, Administration, and Maintenance On-Demand OAM actions that are initiated via manual intervention for a limited time to carry out diagnostics. On-demand OAM can result in singular or periodic OAM actions during the diagnostic time interval. PTM Path Trace Message PTR Path Trace Reply RFC Request for Comments SNMP Simple Network Management Protocol TLV Type-Length-Value, a method of encoding Objects TRILL Transparent Interconnection of Lots of Links VLAN Virtual LAN
OIDNameAccessStatusDescription
1.3.6.1.2.1.238IdentitytrillOamMibThis MIB module contains the management objects for the management of TRILL Services Operations, Administration and Maintenance. Initial version. Published as …
1.3.6.1.2.1.238.0NodetrillOamNotifications
1.3.6.1.2.1.238.0.1NotificationtrillOamFaultAlarmcurrentA MEP flow has a persistent defect condition. A notification (fault alarm) is sent to the management entity with the OID of the flow that has detected the faul…
1.3.6.1.2.1.238.1NodetrillOamMibObjects
1.3.6.1.2.1.238.1.1NodetrillOamMep
1.3.6.1.2.1.238.1.1.1TabletrillOamMepTablenot-accessiblecurrentThis table is an extension of the dot1agCfmMepTable and rows are automatically added or deleted from this table based upon row creation and destruction of the …
1.3.6.1.2.1.238.1.1.1.1RowtrillOamMepEntrynot-accessiblecurrentThe conceptual row of trillOamMepTable.
1.3.6.1.2.1.238.1.1.1.1.1ColumntrillOamMepRNameread-onlycurrentThis object contains the RBridge Nickname field of the TRILL RBridge as defined in RFC 6325, Section 3.7.
1.3.6.1.2.1.238.1.1.1.1.2ColumntrillOamMepNextPtmTIdread-onlycurrentNext Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. Implementati…
1.3.6.1.2.1.238.1.1.1.1.3ColumntrillOamMepNextMtvmTIdread-onlycurrentNext Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. An implement…
1.3.6.1.2.1.238.1.1.1.1.4ColumntrillOamMepPtrInread-onlycurrentTotal number of valid, in-order Path Trace Replies received.
1.3.6.1.2.1.238.1.1.1.1.5ColumntrillOamMepPtrInOutofOrderread-onlycurrentTotal number of valid, out-of-order Path Trace Replies received.
1.3.6.1.2.1.238.1.1.1.1.6ColumntrillOamMepPtrOutread-onlycurrentTotal number of valid, Path Trace Replies transmitted.
1.3.6.1.2.1.238.1.1.1.1.7ColumntrillOamMepMtvrInread-onlycurrentTotal number of valid, in-order Multi-destination Replies received.
1.3.6.1.2.1.238.1.1.1.1.8ColumntrillOamMepMtvrInOutofOrderread-onlycurrentTotal number of valid, out-of-order Multi-destination Replies received.
1.3.6.1.2.1.238.1.1.1.1.9ColumntrillOamMepMtvrOutread-onlycurrentTotal number of valid, Multi-destination Replies transmitted.
1.3.6.1.2.1.238.1.1.1.1.10ColumntrillOamMepTxLbmDestRNameread-createcurrentThe Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.11ColumntrillOamMepTxLbmHCread-createcurrentThe Hop Count field to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.12ColumntrillOamMepTxLbmReplyModeOobread-createcurrentTrue indicates that the Reply to an LBM is out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that in-band reply is transmitt…
1.3.6.1.2.1.238.1.1.1.1.13ColumntrillOamMepTransmitLbmReplyIpread-createcurrentThe IP address for an out-of-band IP Address TLV that is to be transmitted. Maximum length for IPv6 is 16 octets and IPv4 is 4 octets.
1.3.6.1.2.1.238.1.1.1.1.14ColumntrillOamMepTxLbmFlowEntropyread-createcurrent96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.15ColumntrillOamMepTxPtmDestRNameread-createcurrentThe Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.16ColumntrillOamMepTxPtmHCread-createcurrentThe Hop Count field to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.17ColumntrillOamMepTxPtmReplyModeOobread-createcurrentTrue indicates that a Reply to a PTM will be out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that an in-band reply is tran…
1.3.6.1.2.1.238.1.1.1.1.18ColumntrillOamMepTransmitPtmReplyIpread-createcurrentThe IP address for an out-of-band IP Address TLV to be transmitted. The maximum length for an IPv6 address is 16 octets. The maximum length for an IPv4 address…
1.3.6.1.2.1.238.1.1.1.1.19ColumntrillOamMepTxPtmFlowEntropyread-createcurrent96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.20ColumntrillOamMepTxPtmStatusread-createcurrentA Boolean flag set to TRUE by the MEP Path Trace Initiator State Machine or a MIB manager to indicate that another PTM is being transmitted. This is reset to F…
1.3.6.1.2.1.238.1.1.1.1.21ColumntrillOamMepTxPtmResultOKread-createcurrentIndicates the following results of the operation: - true indicates the Path Trace Message(s) will be (or has been) sent. - false indicates the Path Trace Messa…
1.3.6.1.2.1.238.1.1.1.1.22ColumntrillOamMepTxPtmSeqNumberread-createcurrentThe Path Trace Transaction Identifier of the first PTM (to be) sent. The value returned is undefined if trillOamMepTxPtmResultOK is false.
1.3.6.1.2.1.238.1.1.1.1.23ColumntrillOamMepTxPtmMessagesread-createcurrentThe number of Path Trace messages to be transmitted. As per RFC 7455, Section 10, the first Path Trace Message is transmitted with a Hop Count of 1; an RBridge…
1.3.6.1.2.1.238.1.1.1.1.24ColumntrillOamMepTxMtvmTreeread-createcurrentThe Multi-destination Tree identifier, as defined in RFC 6325, for an MTVM.
1.3.6.1.2.1.238.1.1.1.1.25ColumntrillOamMepTxMtvmHCread-createcurrentThe Hop Count field to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.26ColumntrillOamMepTxMtvmReplyModeOobread-createcurrentTrue indicates that the reply to an MTVM is out of band and this out-of-band IP Address TLV is where the reply is to be transmitted. False indicates that an in…
1.3.6.1.2.1.238.1.1.1.1.27ColumntrillOamMepTransmitMtvmReplyIpread-createcurrentIP address for an out-of-band IP Address TLV that is to be transmitted. The maximum length for IPv6 is 16 octets and IPv4 is 4 octets.
1.3.6.1.2.1.238.1.1.1.1.28ColumntrillOamMepTxMtvmFlowEntropyread-createcurrent96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.
1.3.6.1.2.1.238.1.1.1.1.29ColumntrillOamMepTxMtvmStatusread-createcurrentA Boolean flag set to TRUE by the MEP Multi-destination Initiator State Machine or a MIB manager to indicate that another MTVM is being transmitted. Reset to F…
1.3.6.1.2.1.238.1.1.1.1.30ColumntrillOamMepTxMtvmResultOKread-createcurrentIndicates the result of the operation in the following way: - true indicates the Multi-destination Message(s) will be (or has been) sent. - false indicates the…
1.3.6.1.2.1.238.1.1.1.1.31ColumntrillOamMepTxMtvmMessagesread-createcurrentThe number of Multi-destination messages to be transmitted. The RBridge transmit the Multi-destination message incrementing the session Identification Number a…
1.3.6.1.2.1.238.1.1.1.1.32ColumntrillOamMepTxMtvmSeqNumberread-createcurrentThe Multi-destination Transaction Identifier of the first MTVM (to be) sent. The value returned is undefined if trillOamMepTxMtvmResultOK is false.
1.3.6.1.2.1.238.1.1.1.1.33ColumntrillOamMepTxMtvmScopeListread-createcurrentThe Multi-destination RBridge Scope list, which requires 2 octets per RBridge.
1.3.6.1.2.1.238.1.1.1.1.34ColumntrillOamMepDiscontinuityTimeread-onlycurrentSnapshot of the value of the sysUpTime object at the beginning of the latest period of continuity of the statistical counters associated with this MEP.
1.3.6.1.2.1.238.1.1.2TabletrillOamMepFlowCfgTablenot-accessiblecurrentThis table includes configuration objects and operations for the TRILL OAM facilities in RFC 7455. Each row in the table represents a Flow Configuration Entry …
1.3.6.1.2.1.238.1.1.2.1RowtrillOamMepFlowCfgEntrynot-accessiblecurrentThe conceptual row of trillOamMepFlowCfgTable.
1.3.6.1.2.1.238.1.1.2.1.1ColumntrillOamMepFlowCfgIndexnot-accessiblecurrentAn index to the TRILL OAM MEP Flow Configuration table, which indicates the specific flow for the MEP. The index is never reused for other flow sessions on the…
1.3.6.1.2.1.238.1.1.2.1.2ColumntrillOamMepFlowCfgFlowEntropyread-createcurrentThis is 96 bytes of Flow Entropy as described in TRILL OAM, RFC 7455.
1.3.6.1.2.1.238.1.1.2.1.3ColumntrillOamMepFlowCfgDestRNameread-createcurrentThe Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.
1.3.6.1.2.1.238.1.1.2.1.4ColumntrillOamMepFlowCfgFlowHCread-createcurrentThe Hop Count field to be transmitted.
1.3.6.1.2.1.238.1.1.2.1.5ColumntrillOamMepFlowCfgRowStatusread-createcurrentThe status of the row. The writable columns in a row cannot be changed if the row is active. All columns MUST have a valid value before a row can be activated.
1.3.6.1.2.1.238.1.1.3TabletrillOamPtrTablenot-accessiblecurrentThis table includes Path Trace Reply objects and operations for the TRILL OAM facilities as described in RFC 7455. Each row in the table represents a Path Trac…
1.3.6.1.2.1.238.1.1.3.1RowtrillOamPtrEntrynot-accessiblecurrentThe conceptual row of trillOamPtrTable.
1.3.6.1.2.1.238.1.1.3.1.1ColumntrillOamMepPtrTransactionIdnot-accessiblecurrentSequence Number / Transaction Identifier returned by a previous transmit path trace message command, indicating which PTM's response is going to be returned.
1.3.6.1.2.1.238.1.1.3.1.2ColumntrillOamMepPtrHCread-onlycurrentHop Count field value for a returned PTR.
1.3.6.1.2.1.238.1.1.3.1.3ColumntrillOamMepPtrFlagread-onlycurrentFCOI (TRILL OAM Message TLV) field value for a returned PTR.
1.3.6.1.2.1.238.1.1.3.1.4ColumntrillOamMepPtrErrorCoderead-onlycurrentReturn Code and Return Sub-code value for a returned PTR.
1.3.6.1.2.1.238.1.1.3.1.5ColumntrillOamMepPtrTerminalMepread-onlycurrentA boolean value stating whether the forwarded PTM reached a MEP enclosing its MA, as returned in the Terminal MEP flag of the Flags field.
1.3.6.1.2.1.238.1.1.3.1.6ColumntrillOamMepPtrLastEgressIdread-onlycurrentAn Integer field holding the Last Egress Identifier returned in the PTR Upstream RBridge Nickname TLV of the PTR. The Last Egress Identifier identifies the Ups…
1.3.6.1.2.1.238.1.1.3.1.7ColumntrillOamMepPtrIngressread-onlycurrentThe value returned in the Ingress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the PTM.
1.3.6.1.2.1.238.1.1.3.1.8ColumntrillOamMepPtrIngressMacread-onlycurrentMAC address returned in the ingress MAC address field.
1.3.6.1.2.1.238.1.1.3.1.9ColumntrillOamMepPtrIngressPortIdSubtyperead-onlycurrentIngress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortIdSubtype object.
1.3.6.1.2.1.238.1.1.3.1.10ColumntrillOamMepPtrIngressPortIdread-onlycurrentIngress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortId object.
1.3.6.1.2.1.238.1.1.3.1.11ColumntrillOamMepPtrEgressread-onlycurrentThe value returned in the Egress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the PTM.
1.3.6.1.2.1.238.1.1.3.1.12ColumntrillOamMepPtrEgressMacread-onlycurrentMAC address returned in the egress MAC address field.
1.3.6.1.2.1.238.1.1.3.1.13ColumntrillOamMepPtrEgressPortIdSubtyperead-onlycurrentEgress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortIdSubtype object.
1.3.6.1.2.1.238.1.1.3.1.14ColumntrillOamMepPtrEgressPortIdread-onlycurrentEgress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortId object.
1.3.6.1.2.1.238.1.1.3.1.15ColumntrillOamMepPtrChassisIdSubtyperead-onlycurrentThis object specifies the format of the Chassis ID returned in the Sender ID TLV of the PTR, if any. This value is meaningless if the trillOamMepPtrChassisId h…
1.3.6.1.2.1.238.1.1.3.1.16ColumntrillOamMepPtrChassisIdread-onlycurrentThe Chassis ID returned in the Sender ID TLV of the PTR, if any. The format of this object is determined by the value of the trillOamMepPtrChassisIdSubtype obj…
1.3.6.1.2.1.238.1.1.3.1.17ColumntrillOamMepPtrOrganizationSpecificTlvread-onlycurrentAll organization-specific TLVs returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.
1.3.6.1.2.1.238.1.1.3.1.18ColumntrillOamMepPtrNextHopNicknamesread-onlycurrentNext hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.
1.3.6.1.2.1.238.1.1.4TabletrillOamMtvrTablenot-accessiblecurrentThis table includes Multi-destination Reply objects and operations for the TRILL OAM facilities described in RFC 7455. Each row in the table represents a Multi…
1.3.6.1.2.1.238.1.1.4.1RowtrillOamMtvrEntrynot-accessiblecurrentThe conceptual row of trillOamMtvrTable.
1.3.6.1.2.1.238.1.1.4.1.1ColumntrillOamMepMtvrTransactionIdnot-accessiblecurrentSequence Number / Transaction Identifier returned by a previously transmitted Multi-destination message command indicating which MTVM's response is going to be…
1.3.6.1.2.1.238.1.1.4.1.2ColumntrillOamMepMtvrReceiveOrdernot-accessiblecurrentAn index to distinguish among multiple MTVRs with same MTVR Transaction Identifier field value. trillOamMepMtvrReceiveOrder is assigned sequentially from 1, in…
1.3.6.1.2.1.238.1.1.4.1.3ColumntrillOamMepMtvrFlagread-onlycurrentFCOI (TRILL OAM Message TLV) field value for a returned MTVR.
1.3.6.1.2.1.238.1.1.4.1.4ColumntrillOamMepMtvrErrorCoderead-onlycurrentReturn Code and Return Sub-code value for a returned MTVR.
1.3.6.1.2.1.238.1.1.4.1.5ColumntrillOamMepMtvrLastEgressIdread-onlycurrentAn Integer field holding the Last Egress Identifier returned in the MTVR Upstream RBridge Nickname TLV of the MTVR. The Last Egress Identifier identifies the U…
1.3.6.1.2.1.238.1.1.4.1.6ColumntrillOamMepMtvrIngressread-onlycurrentThe value returned in the Ingress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the MTVM.
1.3.6.1.2.1.238.1.1.4.1.7ColumntrillOamMepMtvrIngressMacread-onlycurrentMAC address returned in the ingress MAC address field.
1.3.6.1.2.1.238.1.1.4.1.8ColumntrillOamMepMtvrIngressPortIdSubtyperead-onlycurrentIngress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortIdSubtype object.
1.3.6.1.2.1.238.1.1.4.1.9ColumntrillOamMepMtvrIngressPortIdread-onlycurrentIngress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortId object.
1.3.6.1.2.1.238.1.1.4.1.10ColumntrillOamMepMtvrEgressread-onlycurrentThe value returned in the Egress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the MTVR.
1.3.6.1.2.1.238.1.1.4.1.11ColumntrillOamMepMtvrEgressMacread-onlycurrentMAC address returned in the egress MAC address field.
1.3.6.1.2.1.238.1.1.4.1.12ColumntrillOamMepMtvrEgressPortIdSubtyperead-onlycurrentEgress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortIdSubtype object.
1.3.6.1.2.1.238.1.1.4.1.13ColumntrillOamMepMtvrEgressPortIdread-onlycurrentEgress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortId object.
1.3.6.1.2.1.238.1.1.4.1.14ColumntrillOamMepMtvrChassisIdSubtyperead-onlycurrentThis object specifies the format of the Chassis ID returned in the Sender ID TLV of the MTVR, if any. This value is meaningless if the trillOamMepMtvrChassisId…
1.3.6.1.2.1.238.1.1.4.1.15ColumntrillOamMepMtvrChassisIdread-onlycurrentThe Chassis ID returned in the Sender ID TLV of the MTVR, if any. The format of this object is determined by the value of the trillOamMepMtvrChassisIdSubtype o…
1.3.6.1.2.1.238.1.1.4.1.16ColumntrillOamMepMtvrOrganizationSpecificTlvread-onlycurrentAll organization-specific TLVs returned in the MTVR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated togethe…
1.3.6.1.2.1.238.1.1.4.1.17ColumntrillOamMepMtvrNextHopNicknamesread-onlycurrentNext hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.
1.3.6.1.2.1.238.1.1.4.1.18ColumntrillOamMepMtvrReceiverAvailabilityread-onlycurrentA value of true indicates that the MTVR response contained Multicast receiver availability TLV.
1.3.6.1.2.1.238.1.1.4.1.19ColumntrillOamMepMtvrReceiverCountread-onlycurrentIndicates the number of multicast receivers available on the responding RBridge on the VLAN specified by the diagnostic VLAN.
1.3.6.1.2.1.238.1.1.5TabletrillOamMepDbTablenot-accessiblecurrentThis table is an extension of the dot1agCfmMepDbTable and rows are automatically added to or deleted from this table based upon row creation and destruction of…
1.3.6.1.2.1.238.1.1.5.1RowtrillOamMepDbEntrynot-accessiblecurrentThe conceptual row of trillOamMepDbTable.
1.3.6.1.2.1.238.1.1.5.1.1ColumntrillOamMepDbFlowIndexread-onlycurrentThis object identifies the flow. If the Flow Identifier TLV is received, then the index received can also be used.
1.3.6.1.2.1.238.1.1.5.1.2ColumntrillOamMepDbFlowEntropyread-onlycurrent96 byte Flow Entropy.
1.3.6.1.2.1.238.1.1.5.1.3ColumntrillOamMepDbFlowStateread-onlycurrentThe operational state of the remote MEP (flow-based) IFF State machines. State Machine is running now per flow.
1.3.6.1.2.1.238.1.1.5.1.4ColumntrillOamMepDbFlowFailedOkTimeread-onlycurrentThe Time (sysUpTime) at which the Remote MEP flow state machine last entered either the RMEP_FAILED or RMEP_OK state.
1.3.6.1.2.1.238.1.1.5.1.5ColumntrillOamMepDbRBridgeNameread-onlycurrentRemote MEP RBridge Nickname.
1.3.6.1.2.1.238.1.1.5.1.6ColumntrillOamMepDbLastGoodSeqNumread-onlycurrentLast Sequence Number received.
1.3.6.1.2.1.238.2NodetrillOamMibConformance
1.3.6.1.2.1.238.2.1NodetrillOamMibCompliances
1.3.6.1.2.1.238.2.1.1CompliancetrillOamMibCompliancecurrentThe compliance statement for the TRILL OAM MIB.
1.3.6.1.2.1.238.2.1.2CompliancetrillOamMibReadOnlyComplianceread-onlycurrentCompliance requirement for implementations that only provide read-only support for TRILL-OAM-MIB. Such devices can be monitored but cannot be configured using …
1.3.6.1.2.1.238.2.2NodetrillOamMibGroups
1.3.6.1.2.1.238.2.2.1GrouptrillOamMepMandatoryGroupcurrentMandatory objects for the TRILL OAM MEP group.
1.3.6.1.2.1.238.2.2.2GrouptrillOamMepFlowCfgTableGroupcurrentTRILL OAM MEP Flow Configuration objects group.
1.3.6.1.2.1.238.2.2.3GrouptrillOamPtrTableGroupcurrentTRILL OAM MEP PTR objects group.
1.3.6.1.2.1.238.2.2.4GrouptrillOamMtvrTableGroupcurrentTRILL OAM MEP MTVR objects group.
1.3.6.1.2.1.238.2.2.5GrouptrillOamMepDbGroupcurrentTRILL OAM MEP DB objects group.
1.3.6.1.2.1.238.2.2.6GrouptrillOamNotificationGroupcurrentA collection of objects describing notifications(traps).