VPLS-DRAFT-00-MIB
36 objects
Copyright (C) The Internet Society (2006). The initial version of this MIB module was published in RFC XXXX. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html This MIB module contains managed object definitions for Virtual Private LAN Services as in [VPLS-LDP] This MIB module enables the use of any underlying Pseudo Wire network. Copyright (C) The Internet Society (2006). This version of this MIB module is part of RFC XXX; see the RFC itself for full legal notices.
Imported Objects
| IF-MIB | -- RFC3411 InterfaceIndexOrZero |
| INET-ADDRESS-MIB | -- RFC2863 InetAddressType InetAddress |
| PW-TC-STD-MIB | -- RFC4001 PwIndexType |
| SNMP-FRAMEWORK-MIB | -- RFC2579 SnmpAdminString |
| SNMPv2-CONF | -- RFC2578 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | Counter32 Counter64 Integer32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE TimeTicks transmission Unsigned32 |
| SNMPv2-TC | -- RFC2580 TruthValue RowStatus StorageType TimeStamp |
| VPN-TC-STD-MIB | VPNIdOrZero |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.10 | IdentityvplsDraft00MIB | Copyright (C) The Internet Society (2006). The initial version of this MIB module was published in RFC XXXX. For full legal notices see the RFC itself or see: … | ||
| 1.3.6.1.2.1.10.0 | NodevplsNotifications | |||
| 1.3.6.1.2.1.10.0.1 | NotificationvplsStatusChanged | current | The vplsStatusChanged notification is generated when there is a change in the administrative or operating status of a VPLS service. | |
| 1.3.6.1.2.1.10.0.2 | NotificationvplsFwdFullAlarmRaised | current | The vplsFwdFullAlarmRaised notification is draft-nadeau-l2vpn-vpls-mib-00 L2-VPN-MIB June 16, 2006 generated when the utilization of the Forwarding database is… | |
| 1.3.6.1.2.1.10.0.3 | NotificationvplsFwdFullAlarmCleared | current | The vplsFwdFullAlarmCleared notification is generated when the utilization of the Forwarding database is below the value specified by vplsConfigFwdFullLowWater… | |
| 1.3.6.1.2.1.10.1 | NodevplsObjects | |||
| 1.3.6.1.2.1.10.1.1 | ScalarvplsIndexNext | read-only | current | This object contains an appropriate value to be used for vplsIndex when creating entries in the vplsConfigTable. The value 0 indicates that no unassigned entri… |
| 1.3.6.1.2.1.10.1.2 | TablevplsConfigTable | not-accessible | current | This table specifies information for configuring and monitoring Virtual Private Lan Services(VPLS). |
| 1.3.6.1.2.1.10.1.2.1 | RowvplsConfigEntry | not-accessible | current | |
| 1.3.6.1.2.1.10.1.2.1.1 | ColumnvplsIndex | not-accessible | current | Unique index for the conceptual row identifying a VPLS service. |
| 1.3.6.1.2.1.10.1.2.1.2 | ColumnvplsName | read-create | current | A textual name of the VPLS. If there is no local name, or this object is otherwise not applicable, then this object MUST contain a zero-length octet string. |
| 1.3.6.1.2.1.10.1.2.1.3 | ColumnvplsDescr | read-create | current | A textual string containing information about the VPLS service. If there is no information for this VPLS service, then this object MUST contain a zero-length o… |
| 1.3.6.1.2.1.10.1.2.1.4 | ColumnvplsAdminStatus | read-create | current | The desired administrative state of the VPLS service. If the administrative status of the Vpls service is changed to enable then this service is able to utiliz… |
| 1.3.6.1.2.1.10.1.2.1.5 | ColumnvplsOperStatus | read-only | current | The current operational state of this VPLS Service. |
| 1.3.6.1.2.1.10.1.2.1.6 | ColumnvplsMacLearning | read-create | current | This object specifies if MAC Learning is enabled in this service. If this object is true then Mac Learning is enabled. If false, then Mac Learning is disabled. |
| 1.3.6.1.2.1.10.1.2.1.7 | ColumnvplsDiscardUnknownDest | read-create | current | If the value of this object is 'true', then frames received with an unknown destination MAC are discarded in this VPLS. If 'false', then the packets are proces… |
| 1.3.6.1.2.1.10.1.2.1.8 | ColumnvplsMacAging | read-create | current | If the value of this object is 'true' then the MAC ageing process is enabled in this VPLS. If 'false', then the MAC ageing process is disabled |
| 1.3.6.1.2.1.10.1.2.1.9 | ColumnvplsVpnId | read-only | current | This objects indicates the IEEE 802-1990 VPN ID of the associated VPLS service. |
| 1.3.6.1.2.1.10.1.2.1.10 | ColumnvplsConfigFwdFullHighWatermark | read-create | current | This object specifies the utilization of the forwarding database for this VPLS instance at which the vplsFwdFullAlarmRaised notification will be sent. |
| 1.3.6.1.2.1.10.1.2.1.11 | ColumnvplsConfigFwdFullLowWatermark | read-create | current | This object specifies the utilization of the forwarding database for this VPLS instance at which the vplsFwdFullAlarmCleared notification will be sent. |
| 1.3.6.1.2.1.10.1.2.1.12 | ColumnvplsRowStatus | read-create | current | For creating, modifying, and deleting this row. None of the read-create objects in the conceptual rows may be changed when this object is in the active(1) stat… |
| 1.3.6.1.2.1.10.1.3 | TablevplsPwBindTable | not-accessible | current | This table provides an association between a VPLS service and the corresponding Pseudo Wires. A service can have more than one Pseudo Wire association. Pseudo … |
| 1.3.6.1.2.1.10.1.3.1 | RowvplsPwBindEntry | not-accessible | current | Each row represents an association between a VPLS instance and one or more Pseudo Wires defined in the pwTable. Each index is unique in describing an entry in … |
| 1.3.6.1.2.1.10.1.3.1.1 | ColumnvplsPwIndex | not-accessible | current | Secondary Index for the conceptual row identifying a pseudowire within the PwEntry which MUST match an entry from the PW-STD-MIB's PwTable which represents an … |
| 1.3.6.1.2.1.10.1.3.1.2 | ColumnvplsPwBindBindType | read-create | current | The value of this object indicates whether the Pseudo Wire binding was created manually or via autodiscovery. The value of this object must be specifed when th… |
| 1.3.6.1.2.1.10.1.3.1.3 | ColumnvplsPwBindMacAddressLimit | read-create | current | The value of this object specifies the maximum number of learned and static entries allowed in the Forwarding database for this PW Binding. The value 0 means t… |
| 1.3.6.1.2.1.10.1.3.1.4 | ColumnvplsPwBindRowStatus | read-create | current | For creating, modifying, and deleting this row. None of the read-create objects in the conceptual rows may be changed when this object is in the active(1) state |
| 1.3.6.1.2.1.10.1.4 | ScalarvplsStatusNotifEnable | read-write | current | If this object is set to true(1), then it enables the emission of vplsStatusChanged notification; otherwise this notification is not draft-nadeau-l2vpn-vpls-mi… |
| 1.3.6.1.2.1.10.1.5 | ScalarvplsNotificationMaxRate | read-write | current | This object indicates the maximum number of notifications issued per second. If events occur more rapidly, the implementation may simply fail to emit these not… |
| 1.3.6.1.2.1.10.2 | NodevplsConformance | |||
| 1.3.6.1.2.1.10.2.1 | NodevplsCompliances | |||
| 1.3.6.1.2.1.10.2.1.1 | CompliancevplsModuleReadOnlyCompliance | current | Compliance requirement for implementations that only provide read-only support for VPLS-DRAFT-00-MIB. Such devices can then be monitored but cannot be configur… | |
| 1.3.6.1.2.1.10.2.2 | NodevplsGroups | |||
| 1.3.6.1.2.1.10.2.2.1 | GroupvplsGroup | current | The group of objects supporting management of L2VPN VPLS services | |
| 1.3.6.1.2.1.10.2.2.2 | GroupvplsPwBindGroup | current | The group of objects supporting management of Pseudo Wire (PW) Binding to VPLS. | |
| 1.3.6.1.2.1.10.2.2.3 | GroupvplsNotificationGroup | current | The group of notifications supporting the Notifications generated for VPLS Services |