MIB Viewer

MPLS-LPS-MIB

68 objects
This MIB module supports the configuration and management of MPLS-TP linear protection domains. Copyright (c) 2017 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
Imported Objects
DIFFSERV-MIB-- RFC 3411 IndexIntegerNextFree
MPLS-OAM-ID-STD-MIB-- RFC 3811 mplsOamIdMegIndex mplsOamIdMeIndex mplsOamIdMeMpIndex
MPLS-TC-STD-MIB-- RFC 3289 mplsStdMIB
SNMP-FRAMEWORK-MIB-- RFC 2579 SnmpAdminString
SNMPv2-CONF-- RFC 2578 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP
SNMPv2-SMICounter32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2580 TEXTUAL-CONVENTION RowStatus StorageType TimeStamp TruthValue
OIDNameAccessStatusDescription
1.3.6.1.2.1.10.166.22IdentitymplsLpsMIBThis MIB module supports the configuration and management of MPLS-TP linear protection domains. Copyright (c) 2017 IETF Trust and the persons identified as aut…
1.3.6.1.2.1.10.166.22.0NodemplsLpsNotifications
1.3.6.1.2.1.10.166.22.0.1NotificationmplsLpsEventSwitchovercurrentAn mplsLpsEventSwitchover notification is sent when the value of an instance of mplsLpsMeStatusSwitchovers increments.
1.3.6.1.2.1.10.166.22.0.2NotificationmplsLpsEventRevertiveMismatchcurrentAn mplsLpsEventRevertiveMismatch notification is sent when the value of mplsLpsStatusRevertiveMismatch changes.
1.3.6.1.2.1.10.166.22.0.3NotificationmplsLpsEventProtecTypeMismatchcurrentAn mplsLpsEventProtecTypeMismatch notification is sent when the value of mplsLpsStatusProtecTypeMismatch changes.
1.3.6.1.2.1.10.166.22.0.4NotificationmplsLpsEventCapabilitiesMismatchcurrentAn mplsLpsEventCapabilitiesMismatch notification is sent when the value of mplsLpsStatusCapabilitiesMismatch changes.
1.3.6.1.2.1.10.166.22.0.5NotificationmplsLpsEventPathConfigMismatchcurrentAn mplsLpsEventPathConfigMismatch notification is sent when the value of mplsLpsStatusPathConfigMismatch changes.
1.3.6.1.2.1.10.166.22.0.6NotificationmplsLpsEventFopNoResponsecurrentAn mplsLpsEventFopNoResponse notification is sent when the value of mplsLpsStatusFopNoResponses increments.
1.3.6.1.2.1.10.166.22.0.7NotificationmplsLpsEventFopTimeoutcurrentAn mplsLpsEventFopTimeout notification is sent when the value of mplsLpsStatusFopTimeouts increments.
1.3.6.1.2.1.10.166.22.1NodemplsLpsObjects
1.3.6.1.2.1.10.166.22.1.1ScalarmplsLpsConfigDomainIndexNextread-onlycurrentThis object contains an unused value for mplsLpsConfigDomainIndex, or a zero to indicate that the number of unassigned entries has been exhausted. Negative val…
1.3.6.1.2.1.10.166.22.1.2TablemplsLpsConfigTablenot-accessiblecurrentThis table lists the MPLS-TP linear protection domains that have been configured on the system. An entry is created by a network operator who wants to run the …
1.3.6.1.2.1.10.166.22.1.2.1RowmplsLpsConfigEntrynot-accessiblecurrentA conceptual row in the mplsLpsConfigTable.
1.3.6.1.2.1.10.166.22.1.2.1.1ColumnmplsLpsConfigDomainIndexnot-accessiblecurrentIndex for the conceptual row identifying a protection domain. Operators should obtain new values for row creation in this table by reading mplsLpsConfigDomainI…
1.3.6.1.2.1.10.166.22.1.2.1.2ColumnmplsLpsConfigDomainNameread-createcurrentTextual name that represents the MPLS-TP linear protection domain. It facilitates easy administrative identification of each protection domain.
1.3.6.1.2.1.10.166.22.1.2.1.3ColumnmplsLpsConfigModeread-createcurrentThe mode of the MPLS-TP linear protection mechanism. This can be either PSC or APS, as follows: PSC The Protection State Coordination mode as described in RFC …
1.3.6.1.2.1.10.166.22.1.2.1.4ColumnmplsLpsConfigProtectionTyperead-createcurrentThe protection architecture type of the protection domain. This object represents both the bridge type, which can be either a permanent bridge (1+1) or a selec…
1.3.6.1.2.1.10.166.22.1.2.1.5ColumnmplsLpsConfigRevertiveread-createcurrentThis object represents the reversion mode of the linear protection domain. The reversion mode of the protection mechanism may be either revertive or non-revert…
1.3.6.1.2.1.10.166.22.1.2.1.6ColumnmplsLpsConfigSdThresholdread-createcurrentThis object holds the threshold value of the Signal Degrade (SD) defect in percent. In order to detect the SD defect, the MPLS-TP packet loss measurement (LM) …
1.3.6.1.2.1.10.166.22.1.2.1.7ColumnmplsLpsConfigSdBadSecondsread-createcurrentThis object holds the number of Bad Seconds to detect the SD. If the number of consecutive Bad Seconds reaches this value, the SD defect is detected and used a…
1.3.6.1.2.1.10.166.22.1.2.1.8ColumnmplsLpsConfigSdGoodSecondsread-createcurrentThis object holds the number of Good Seconds to declare the clearance of an SD defect. After an SD defect occurs on a path, if the number of consecutive Good S…
1.3.6.1.2.1.10.166.22.1.2.1.9ColumnmplsLpsConfigWaitToRestoreread-createcurrentThis object holds the Wait-to-Restore timer value in minutes and can be configured in 1-minute intervals between 5 and 12 minutes. The WTR timer is used to del…
1.3.6.1.2.1.10.166.22.1.2.1.10ColumnmplsLpsConfigHoldOffread-createcurrentThe hold-off time in deciseconds. Represents the time between SF/SD condition detection and declaration of an SF/SD request to the protection switching logic. …
1.3.6.1.2.1.10.166.22.1.2.1.11ColumnmplsLpsConfigContinualTxIntervalread-createcurrentThe Continual Tx Time in seconds. Represents the time interval to send the continual PSC packet to the other end, based on the current state. This object may n…
1.3.6.1.2.1.10.166.22.1.2.1.12ColumnmplsLpsConfigRapidTxIntervalread-createcurrentThe Rapid Tx interval in microseconds. Represents the time interval to send the PSC packet to the other end, when there is a change in the state of the linear …
1.3.6.1.2.1.10.166.22.1.2.1.13ColumnmplsLpsConfigCommandread-createcurrentAllows the initiation of an operator command on the protection domain. When read, this object returns the last command written or noCmd if no command has been …
1.3.6.1.2.1.10.166.22.1.2.1.14ColumnmplsLpsConfigCreationTimeread-onlycurrentThe value of sysUpTime at the time the row was created.
1.3.6.1.2.1.10.166.22.1.2.1.15ColumnmplsLpsConfigRowStatusread-createcurrentThis object represents the status of the MPLS-TP linear protection domain entry. This variable is used to create, modify, and/or delete a row in this table.
1.3.6.1.2.1.10.166.22.1.2.1.16ColumnmplsLpsConfigStorageTyperead-createcurrentThe storage type for this conceptual row. Conceptual rows having the value 'permanent' need not allow write access to any columnar objects in the row.
1.3.6.1.2.1.10.166.22.1.3TablemplsLpsStatusTablenot-accessiblecurrentThis table provides status information about MPLS-TP linear protection domains that have been configured on the system.
1.3.6.1.2.1.10.166.22.1.3.1RowmplsLpsStatusEntrynot-accessiblecurrentA conceptual row in the mplsLpsStatusTable.
1.3.6.1.2.1.10.166.22.1.3.1.1ColumnmplsLpsStatusStateread-onlycurrentThe current state of the PSC state machine.
1.3.6.1.2.1.10.166.22.1.3.1.2ColumnmplsLpsStatusReqRcvread-onlycurrentThe current value of the PSC Request field received on the most recent PSC packet.
1.3.6.1.2.1.10.166.22.1.3.1.3ColumnmplsLpsStatusReqSentread-onlycurrentThe current value of the PSC Request field sent on the most recent PSC packet.
1.3.6.1.2.1.10.166.22.1.3.1.4ColumnmplsLpsStatusFpathPathRcvread-onlycurrentThe current value of the FPath and Path fields received on the most recent PSC packet.
1.3.6.1.2.1.10.166.22.1.3.1.5ColumnmplsLpsStatusFpathPathSentread-onlycurrentThe current value of the FPath and Path fields sent on the most recent PSC packet.
1.3.6.1.2.1.10.166.22.1.3.1.6ColumnmplsLpsStatusRevertiveMismatchread-onlycurrentThis object indicates a provisioning mismatch in the revertive mode across the protection domain endpoints. The value of this object becomes true when a PSC me…
1.3.6.1.2.1.10.166.22.1.3.1.7ColumnmplsLpsStatusProtecTypeMismatchread-onlycurrentThis object indicates a provisioning mismatch in the protection type, representing both the bridge type and the switching type, across the protection domain en…
1.3.6.1.2.1.10.166.22.1.3.1.8ColumnmplsLpsStatusCapabilitiesMismatchread-onlycurrentThis object indicates a provisioning mismatch in Capabilities TLVs across the protection domain endpoints. The value of this object becomes true when a PSC mes…
1.3.6.1.2.1.10.166.22.1.3.1.9ColumnmplsLpsStatusPathConfigMismatchread-onlycurrentThis object indicates a provisioning mismatch in the protection path configuration for PSC communication across the protection domain endpoints. The value of t…
1.3.6.1.2.1.10.166.22.1.3.1.10ColumnmplsLpsStatusFopNoResponsesread-onlycurrentThis object holds the number of occurrences of protocol failure due to a lack of response to a traffic switchover request within 50 ms. When there is a traffic…
1.3.6.1.2.1.10.166.22.1.3.1.11ColumnmplsLpsStatusFopTimeoutsread-onlycurrentThis object holds the number of occurrences of protocol failure due to no PSC message being received during at least 3.5 times the long PSC message interval. W…
1.3.6.1.2.1.10.166.22.1.4TablemplsLpsMeConfigTablenot-accessiblecurrentThis table lists ME associations that have been configured in protection domains.
1.3.6.1.2.1.10.166.22.1.4.1RowmplsLpsMeConfigEntrynot-accessiblecurrentA conceptual row in the mplsLpsMeConfigTable. There is a sparse relationship between the conceptual rows of this table and the mplsOamIdMeTable. Each time that…
1.3.6.1.2.1.10.166.22.1.4.1.1ColumnmplsLpsMeConfigDomainread-createcurrentThis object holds the mplsLpsConfigDomainIndex value for the protection domain in which this ME is included. If this ME is not part of any protection domain, t…
1.3.6.1.2.1.10.166.22.1.4.1.2ColumnmplsLpsMeConfigPathread-createcurrentThis object represents whether the ME is configured as the working path or the protection path.
1.3.6.1.2.1.10.166.22.1.5TablemplsLpsMeStatusTablenot-accessiblecurrentThis table contains status information of all the MEs that are included in MPLS-TP linear protection domains.
1.3.6.1.2.1.10.166.22.1.5.1RowmplsLpsMeStatusEntrynot-accessiblecurrentA conceptual row in the mplsLpsMeStatusTable.
1.3.6.1.2.1.10.166.22.1.5.1.1ColumnmplsLpsMeStatusCurrentread-onlycurrentIndicates the current state of the ME. localSelectTraffic This bit indicates that traffic is being selected from this ME. localSD This bit implies that a local…
1.3.6.1.2.1.10.166.22.1.5.1.2ColumnmplsLpsMeStatusSignalDegradesread-onlycurrentRepresents the count of Signal Degrade conditions. For the detection and clearance of Signal Degrade, see the description of mplsLpsConfigSdThreshold.
1.3.6.1.2.1.10.166.22.1.5.1.3ColumnmplsLpsMeStatusSignalFailuresread-onlycurrentRepresents the count of Signal Fail conditions. This condition occurs when the OAM running on this ME detects the Signal Fail event.
1.3.6.1.2.1.10.166.22.1.5.1.4ColumnmplsLpsMeStatusSwitchoversread-onlycurrentRepresents the count of switchovers that happened in this ME. When the mplsLpsMeConfigPath value is 'working', this object will return the number of times that…
1.3.6.1.2.1.10.166.22.1.5.1.5ColumnmplsLpsMeStatusLastSwitchoverread-onlycurrentThis object holds the value of sysUpTime at the time that the last switchover happened. When the mplsLpsMeConfigPath value is 'working', this object will retur…
1.3.6.1.2.1.10.166.22.1.5.1.6ColumnmplsLpsMeStatusSwitchoverSecondsread-onlycurrentThe cumulative Protection Switching Duration (PSD) time in seconds. For the working path, this is the cumulative number of seconds that traffic was selected fr…
1.3.6.1.2.1.10.166.22.1.6ScalarmplsLpsNotificationEnableread-writecurrentProvides the ability to enable and disable notifications defined in this MIB module. switchover Indicates that mplsLpsEventSwitchover notifications should be g…
1.3.6.1.2.1.10.166.22.2NodemplsLpsConformance
1.3.6.1.2.1.10.166.22.2.1NodemplsLpsCompliances
1.3.6.1.2.1.10.166.22.2.1.1CompliancemplsLpsModuleFullCompliancecurrentCompliance statement for agents that provide full support for the MPLS-LPS-MIB module. Such devices can provide linear protection and also be configured using …
1.3.6.1.2.1.10.166.22.2.1.2CompliancemplsLpsModuleReadOnlyComplianceread-onlycurrentCompliance statement for agents that only provide read-only support for the MPLS-LPS-MIB module.
1.3.6.1.2.1.10.166.22.2.2NodemplsLpsGroups
1.3.6.1.2.1.10.166.22.2.2.1GroupmplsLpsScalarGroupcurrentCollection of objects needed for MPLS linear protection.
1.3.6.1.2.1.10.166.22.2.2.2GroupmplsLpsTableGroupcurrentCollection of objects needed for MPLS linear protection configuration and statistics.
1.3.6.1.2.1.10.166.22.2.2.3GroupmplsLpsMeTableGroupcurrentCollection of objects needed for MPLS linear protection ME configuration and statistics.
1.3.6.1.2.1.10.166.22.2.2.4GroupmplsLpsNotificationGroupcurrentCollection of objects needed to implement notifications.
Type Definitions
NameSyntaxStatusDescription
MplsLpsCommandINTEGER { noCmd(1), clear(2), lockoutOfProtection(3), forcedSwitch(4), manualSwitchToWork(5), manualSwitchToProtect(6), exercise(7), freeze(8), clearfreeze(9) }currentThis command allows a user to perform any action over a protection domain. If the protection command cannot be executed because a request of equal or higher priority is in effect, an inconsistentValue error is returned.…
MplsLpsFpathPathOCTET STRING (SIZE (2))currentThis textual convention describes an object that stores the Fault Path (FPath) field and Data Path (Path) field of the PSC control packet. FPath is located in the first octet, and Path is located in the second octet. Th…
MplsLpsReqINTEGER { noRequest(0), doNotRevert(1), reverseRequest(2), exercise(3), waitToRestore(4), manualSwitch(5), signalDegrade(7), signalFail(10), forcedSwitch(12), lockoutOfProtection(14) }currentThis textual convention describes an object that stores the PSC Request field of the PSC control packet. The values are as follows: noRequest No Request doNotRevert Do-not-Revert reverseRequest Reverse Request exercise …
MplsLpsStateINTEGER { normal(1), unavLOlocal(2), unavSFPlocal(3), unavSDPlocal(4), unavLOremote(5), unavSFPremote(6), unavSDPremote(7), protfailSFWlocal(8), protfailSDWlocal(9), protfailSFWremote(10), protfailSDWremote(11), switadmFSlocal(12), switadmMSWlocal(13), switadmMSPlocal(14), switadmFSremote(15), switadmMSWremote(16), switadmMSPremote(17), wtr(18), dnr(19), exerLocal(20), exerRemote(21) }currentThis textual convention describes an object that stores the current state of the PSC state machine. The values are as follows: normal Normal state. unavLOlocal Unavailable state due to local LO command. unavSFPlocal Una…